MickScandalous

A3Launcher Configuration?

10 posts in this topic

My startup Parameters are as follows:
 "-mod=@CUP_Units;@CUP_Vehicles;@CUP_Weapons;@Exile;@HAP;heli;kart;mark" "-servermod=@CBA_A3;@ExileServer;@Ryanzombies;@infiSTAR_Exile;@AdvancedTowing" 
I cant see my server in the A3Launcher. I have been playing with others on it but we have to manually install mods and join in Arma 3 multiplayer.

please any help would be appreciated

Share this post


Link to post
Share on other sites
Advertisement
5 hours ago, MickScandalous said:

When i use that it says oh snap and tell me it timed out...any clue why it would do that? 

Try restarting your server.

Also can take up to 30 mins for it to show in A3Launcher.

Worked for me.

Share this post


Link to post
Share on other sites

When you do the check, are you using the steam port or the steam query port?   The default steam port is 2302, if I recall, and the steamquery port is generally the next port, 2303 - but it is user-definable.  You need to be using the steamquery port.

Once you get past that hurdle, I suspect you may have a mod installed that, although A3Launcher sees it, it won't recognize it.  The server starts fine but you'll get an "unknown mod" message when you check the server and it doesn't show up on the server list.  For whatever reason, A3Launcher is sometimes finicky with mod folder names.  Look at mod.cpp or meta.cpp to see what the folder name "should" be".  But on two occasions, even that didn't work.  Maca just recently adjusted the detection logic and the two that were causing my server to not show up now work properly.

Share this post


Link to post
Share on other sites

Yes i am using the correct report, i dont get the unknown mod error. It just says the server timed out, if i try to use my hostname it wont even use it. I have to use my public IP but it just says timed out. All the ports are open so im not sure what to do next. 

Share this post


Link to post
Share on other sites

If you are using a dedicated server or maybe hosting a server on your PC, you need to make sure you allow the UDP ports (2302-2306)  and the arma3server.exe in the inbound/outbound sides of your firewall.

1 person likes this

Share this post


Link to post
Share on other sites
3 hours ago, Kurewe said:

If you are using a dedicated server or maybe hosting a server on your PC, you need to make sure you allow the UDP ports (2302-2306)  and the arma3server.exe in the inbound/outbound sides of your firewall.

When I read your post I thought "Ive already done all that a hundred times, but because its always good to check I did and I had those ports forwarded just not on the right internal IP address. Thank you everyone for your help!!

1 person likes this

Share this post


Link to post
Share on other sites

Glad to help. Good the hear you figured it out. I had one of those moments the other day when setting up a 2nd server on my dedi.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.