David95

linux Dependency problem

11 posts in this topic

Fellow exiles,

 

I've been trying to make a Arma 3 Exile server. Hosted from my home server (Linux Ubuntu server 17.04). Vanilla Exile runs fine on Altis after fixxing a spawn problem (stuck in the ground waving back at grass).

Now i've been trying to add mods to the server. For this I edited my "startup script", and my "mission.sqm". If I leave out "Ryanzombies" from my mission.sqm it boots up fine, zombies work and all but in A3 launcher the game say's I only need Exile mod to play my server.

If I add the "Ryanzombies" to the addons in my "mission.sqm" I get the error shown in -PUtty Error.jpg-

Id like some hint of things i might have missed. If i need to give more structured files than .jpg's please ask.

Cheers

 

Note: Added screens of my mission.sqm, start script, serverstructure and the Putty Error.

mission sqm.JPG

Putty Error.jpg

start script.JPG

server structure.JPG

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, GamersRoost said:

I might suggest posting this in Linux forums. There is people there that support Linux installs.

I will say for sure that "@ryanszombies", in your Mission.sqm is wrong. There is a thread on Ryans zombies and it explains this addition very clearly. A search will show you the answer for that.

***EDIT*** I searched and opened the second result


class Mission
{
	addOns[]=
	{
		"exile_client",
		"Ryanzombies",
		"ryanzombiesfunctions",
		"Ryanzombiesanims",
		"Ryanzombiesfaces",
		"a3_map_altis",
		"A3_Characters_F"
	};

Good luck.

Josh

Thanks Josh, ill move my question to the linux forum. Cleared part of the problem wich is lower/uppercase sensivity in Linux.

 

Have a nice day,

David

Share this post


Link to post
Share on other sites

Tnx for moving my thread.

I edited my mission.sqm and modified my startup script, no breaking errors from here and the server runs just fine. But still in the Arma 3 launcher the game say's you only need Exile to play on this server (you can join with only exile but invisible zombies jeej).

 

Though somehow it does recognize i have mods implemented for the server does give "suggested mods".

ArmaLauncher.JPG

I want to change all mods to required so when for example you use A3Launcher it will setup the required mods for you.

 

Cheers

mission sqm.JPG

start script.JPG

Share this post


Link to post
Share on other sites
52 minutes ago, hogansheroes said:

question is this for you own server

Yes I have my own custom server machine running Ubuntu Server 17.4 and work through a ssh connection. Someone told me maybe Arma3Sync could do something for me so im creating a gui so I can use that application.

Edit: Self hosting but open to public.


Arma3Sync

 

Edited by David95

Share this post


Link to post
Share on other sites

from what i have been told ubuntu servers, everything for mod wise has to be lowercase

10 hours ago, David95 said:

 

start script.JPG

so just in writing can you put the list of mods and server mods down as you might have a mod name issue

Share this post


Link to post
Share on other sites
8 hours ago, hogansheroes said:

from what i have been told ubuntu servers, everything for mod wise has to be lowercase

so just in writing can you put the list of mods and server mods down as you might have a mod name issue

I thought the same that Linux would not recognize my mods for sometimes the mod makers use capitals and otherwise lowercase in their naming. Thus I ran this script in my "server"/steamcmd/arma3/mods. And copied my serversided mods to a seperate folder to lowercase their files aswell.

for SRC in `find * -depth`
do
    DST=`dirname "${SRC}"`/`basename "${SRC}" | tr '[A-Z]' '[a-z]'`
    if [ "${SRC}" != "${DST}" ]
    then
        [ ! -e "${DST}" ] && mv -T "${SRC}" "${DST}" || echo "${SRC} was already all lowercase."
    fi
done

Serversided mod is only an admintoolkit (Toolkit here)

Clientsided mods are:

bc-phoenix

cup weapons/units/vehicles

extended base mod

identizee

niarsenal

ryanzombies (using Exilez2.0 in server addons for spawn script)

 

Only thing I find weird when starting up my server /w a script is that I see a lot: Cannot edit/change this mission.

Isnt that making Arma3 not accepting my changes to the mission.sqm? (though scripts as Exad can be added without any problem, did that yesterday).

 

Cheers

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.