leonardos1978

What do you think about Vcom AI

42 posts in this topic

it should work @ least it did on 1.6? arma version when i was running a server, besides its mostly build for Multiplayer but try it out and let the rest know.

 

Do mind some players might get pissed of cuz of the realistic actions of AI and or just cuz they are into buildings

Share this post


Link to post
Share on other sites
Advertisement

I've never run into this before.  Sounds real interesting.   Anyone successfully installed it on Exile?  How difficult is it to install.   I have some reading to do!

Share this post


Link to post
Share on other sites

y as all mods are installed

 

A note to OP do NOT forget to turn Adrenaline to false its in  AIsettingsV2.hpp should be line 42 in Notepad++

VCOM_Adrenaline = false;

otherwise you have a sort of bullet time and that sucks bigtime

Share this post


Link to post
Share on other sites

Posted (edited)

So I put Vcom in.   I'm getting this remoteexec.log entry:

Spoiler

#2 "serverask ["VCOMAI_Func"]"

I added this to my remotexec.txt file:

Spoiler

 !="serverask [\"VCOMAI_Func\"]"

on line 4.   I also tried:

Spoiler

!"serverask [\"VCOMAI_Func\"]"

But I still often get kicked for the same restriction.  But not every time.  Sometimes I get the following in my scripts.log:

Spoiler
#3 "_scriptName;

#line 1 "\vcomai\init.sqf [VCOM_fnc_Init]"
[] execVM "\VCOMAI\VCOMAI\init.sqf";
"

So I added this to my scripts.txt on line 5:

Spoiler

!="_scriptName;\n\n#line 1 \"\\vcomai\\init.sqf [VCOM_fnc_Init]\"\n[] execVM \"\\VCOMAI\\VCOMAI\\init.sqf\";\n"

 

What am I missing?

Edited by Bob_the_K

Share this post


Link to post
Share on other sites
On 7/4/2017 at 8:08 PM, Bob_the_K said:

So I put Vcom in.   I'm getting this remoteexec.log entry:

  Reveal hidden contents

#2 "serverask ["VCOMAI_Func"]"

I added this to my remotexec.txt file:

  Reveal hidden contents

 !="serverask [\"VCOMAI_Func\"]"

on line 4.   I also tried:

  Reveal hidden contents

!"serverask [\"VCOMAI_Func\"]"

But I still often get kicked for the same restriction.  But not every time.  Sometimes I get the following in my scripts.log:

  Reveal hidden contents
#3 "_scriptName;

#line 1 "\vcomai\init.sqf [VCOM_fnc_Init]"
[] execVM "\VCOMAI\VCOMAI\init.sqf";
"

So I added this to my scripts.txt on line 5:

  Reveal hidden contents

!="_scriptName;\n\n#line 1 \"\\vcomai\\init.sqf [VCOM_fnc_Init]\"\n[] execVM \"\\VCOMAI\\VCOMAI\\init.sqf\";\n"

 

What am I missing?

line 4 

!"VCOMAI_Func"

should work

Share this post


Link to post
Share on other sites

Does it need to be installed by every player or only serverside?

Share this post


Link to post
Share on other sites

Posted (edited)

I took a hiatus from vcom for awhile.  But I'm trying again.  So I added in the line as suggested by McGough.  Now I'm getting numerical script restrictions one after the other.  Things like 

Spoiler

07.08.2017 19:48:13: Uncle Billy xxx.xxx.xxx.xxx:2314) xxxxxxxxxxxxxxxxxxxxxxxx - #2 "4+8+16"

The line in my scripts.txt looks like this:

Spoiler

5 !"VCOMAI_Func" !="1  +  4  + 12*  256  +  4096  +  2  + 8* 16  + 12*131072" !="-sin(5)*2.9" !="DestructDefault" !="31+32" !="0.273158*0.15" !="2+8+16" !="cos(5)*2.9"
 

 

Every time I add one, another pops up.  Is there any generic equation I can put in scripts.txt to stop these?

Edited by Bob_the_K

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.