wetNreckless

Second Server Setup

9 posts in this topic

I am trying to setup a second test server on the same machine that I run my main server. I have changed everything that needs to be changed to include port changes and database rename. I am running everything on a personal computer that I built just for the server. It runs Windows 10 and has Arma installed on it. Do I need another copy of Arma or license to run 2 servers on one personal rig? I have been doing my research and have come up empty on what to do now. Thanks in advanced.

Share this post


Link to post
Share on other sites
Advertisement

OK then I don't know why I cannot join it. I see if create and say that is it is running and unlocked but when I try and remote into the server nothing happens. There is nothing in the Arma 3 Launcher when I do a search and yes I know that it takes a while to show but you would think that me or someone else could remote in.  Not really sure what is going on and causing the issue of not joining.

Share this post


Link to post
Share on other sites

If you have nothing in your RPT logs, check to make sure you have the right ports. A second server requires you to change the 0 to a 1. 2302 now becomes 2312. In your startup parameters make sure you are launching it with this port.

Share this post


Link to post
Share on other sites

Side note.. should fix dms and exilez. i see errors in both of those. (which you should fix even though they likely aren't the cause of this.).

Side note 2,, When I run multiple versions on same box, i create a seperate folder. You can call them Arma1 and Arma2 for example. I also rename the exe's  Armaserver_x64_1.exe/Armaserver_x64_2.exe or something. then I make the auto starts accordingly. I also rename the servermonitors so they work for only the exe's i'm using.  But they pull from same mod folder which may sit in C:\MODS\ .  While I don't think this is your problem, i still wonder if you should do this

You said this was on your local machine?  when you try to search LAN does it show?

Share this post


Link to post
Share on other sites
27 minutes ago, odizzzzle said:

Side note.. should fix dms and exilez. i see errors in both of those. (which you should fix even though they likely aren't the cause of this.).

Side note 2,, When I run multiple versions on same box, i create a seperate folder. You can call them Arma1 and Arma2 for example. I also rename the exe's  Armaserver_x64_1.exe/Armaserver_x64_2.exe or something. then I make the auto starts accordingly. I also rename the servermonitors so they work for only the exe's i'm using.  But they pull from same mod folder which may sit in C:\MODS\ .  While I don't think this is your problem, i still wonder if you should do this

You said this was on your local machine?  when you try to search LAN does it show?

Thank you very much for the help and suggestions. I will fix DMS and ExileZ and then do what you suggested. In answer to your last question though, no I do not see the server when I search on LAN or even Direct Connect.

Share this post


Link to post
Share on other sites

what about the windows advanced firewall? again.. long shot, but i like to rule everythng out.. did you set the in and out parameters for the new exe? were you using a new exe?

Share this post


Link to post
Share on other sites
6 hours ago, odizzzzle said:

what about the windows advanced firewall? again.. long shot, but i like to rule everythng out.. did you set the in and out parameters for the new exe? were you using a new exe?

Yes the advance firewall is set up correctly but I will double check again. However, i have tried your suggestion and it did not work. I am going to try a fresh install of a vanilla server with no mods and do the port changes as needed and seen what I get. If anyone has any other ideas I am all ears.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.