• 0
Grant7O2O

Tanoa Radiation Zone not woking

Question

Posted (edited)

I'm Making a server on Tanoa, With the default radiation zone in the top left island on Tanoa, I've read multiple forums where people say they fix it with making it bigger or smaller, and none of that is working and I'm stumped... Maybe one of you can help?

 

Heres my Config.CPP

Quote

class Tanoa
    {
        class FireFlies
        {
            // 1 = enabled, 0 = disabled
            enable = 0;

            // At this hour fire flies begin to spawn
            startHour = 18;

            // At this hour fire flies stop spawning
            endHour = 4;
        };

        class Anomalies
        {
            // 1 = enabled, 0 = disabled
            enable = 0;

            // At this hour anomalies begin to spawn
            startHour = 19;

            // At this hour anomalies stop spawning
            endHour = 6;
        };

        class Breathing
        {
            // 1 = enabled, 0 = disabled
            enable = 0;
        };

        class Snow
        {
            // 1 = enabled, 0 = disabled
            enable = 0;

            // https://community.bistudio.com/wiki/surfaceType
            surfaces[] = {};
        };

        class Radiation
        {
            enable = 1;
            contaminatedZones[] = 
            {
                {{2691.628,    12311.693,    170.707},     1600,     1600}     
            };
        };

        class Temperature
        {
            // Temperature in °C for the time of day, per hour
            // Add the first index to the last index, so it is 25 indizes!
            daytimeTemperature[] = {15.93,16.89,18.42,20.40,22.68,25.10,27.48,29.63,31.40,32.66,33.32,33.80,33.80,33.32,32.66,31.40,29.63,27.48,25.10,22.68,20.40,18.42,16.89,15.93,15.93};
        
            // Temperature change in °C when it is 100% overcast
            overcast = -2;

            // Temperature change in °C when it is 100% raining
            rain = -5;

            // Temperature change in °C when it is 100% windy
            wind = -1;

            // Temperature change per 100m altitude in °C
            altitude = -0.5;

            // Difference from the daytime temperature to the water temperature
            water = -5;
        };
    };

And here's my Mission.sqm

Quote

 class Item41
        {
            dataType = "Marker";
            position[] = {2691.628, 170.707, 12311.693};
            name = "ExileMarker41";
            text = "";
            markerType = "ELLIPSE";
            type = "ExileContaminatedZone";
            colorName = "ColorBlack";
            fillName = "Border";
            a = 1600;
            b = 1600;
            drawBorder = 1;
            id = 141;
            atlOffset = 0;
        };
        class Item42
        {
            dataType = "Marker";
            position[] = {2691.628, 170.707, 12311.693};
            name = "ExileMarker42";
            text = "";
            type = "ExileContaminatedZoneIcon";
            id = 142;
            atlOffset = 0;
        };

I can See the markers on the map and everything, but the radiation just wont work, I even tried to disable all the other mods like infistar and ryanszombies, but to no avail!

Edited by Grant7O2O

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

reduce the 1600 in mission.sqm to whatever you want. That's the size in metres

Share this post


Link to post
Share on other sites
  • 0
class Tanoa: Altis
	{
		class FireFlies: FireFlies
		{
			enable = 0;
		};

		class Anomalies: Anomalies
		{
			enable = 0;
		};

		class Breathing: Breathing
		{
			enable = 0;
		};

		class Snow: Snow
		{
			enable = 0;
		};

		class Radiation: Radiation
		{
			enable = 1;
		};

		class Temperature: Temperature
		{
			daytimeTemperature[] = {15.93,16.89,18.42,20.40,22.68,25.10,27.48,29.63,31.40,32.66,33.32,33.80,33.80,33.32,32.66,31.40,29.63,27.48,25.10,22.68,20.40,18.42,16.89,15.93,15.93};
		};
	};
};

This is the default Tano class in the config. You don't need to set coordinates for contaminated zones. I know this to be a fact because I've created them before on a Chernarus map. 
 

class Chernarus
	{
		class FireFlies
		{
			enable = 0;
		};

		class Anomalies
		{
			enable = 0;
		};

		class Breathing
		{
			enable = 0;
		};

		class Snow
		{
			enable = 0;
		};

		class Radiation 
		{
			enable = 1;
		};

		class Temperature
		{
			daytimeTemperature[] = {15.93,16.89,18.42,20.40,22.68,25.10,27.48,29.63,31.40,32.66,33.32,33.80,33.80,33.32,32.66,31.40,29.63,27.48,25.10,22.68,20.40,18.42,16.89,15.93,15.93};
		};
	};

All you have to do is setup the zone in the mission editor and export it.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
On 7/14/2017 at 5:29 AM, Beowulfv said:

class Tanoa: Altis
	{
		class FireFlies: FireFlies
		{
			enable = 0;
		};

		class Anomalies: Anomalies
		{
			enable = 0;
		};

		class Breathing: Breathing
		{
			enable = 0;
		};

		class Snow: Snow
		{
			enable = 0;
		};

		class Radiation: Radiation
		{
			enable = 1;
		};

		class Temperature: Temperature
		{
			daytimeTemperature[] = {15.93,16.89,18.42,20.40,22.68,25.10,27.48,29.63,31.40,32.66,33.32,33.80,33.80,33.32,32.66,31.40,29.63,27.48,25.10,22.68,20.40,18.42,16.89,15.93,15.93};
		};
	};
};

This is the default Tano class in the config. You don't need to set coordinates for contaminated zones. I know this to be a fact because I've created them before on a Chernarus map. 
 


class Chernarus
	{
		class FireFlies
		{
			enable = 0;
		};

		class Anomalies
		{
			enable = 0;
		};

		class Breathing
		{
			enable = 0;
		};

		class Snow
		{
			enable = 0;
		};

		class Radiation 
		{
			enable = 1;
		};

		class Temperature
		{
			daytimeTemperature[] = {15.93,16.89,18.42,20.40,22.68,25.10,27.48,29.63,31.40,32.66,33.32,33.80,33.80,33.32,32.66,31.40,29.63,27.48,25.10,22.68,20.40,18.42,16.89,15.93,15.93};
		};
	};

All you have to do is setup the zone in the mission editor and export it.

I've Tried this, and about everthing else that all the other forums have suggested, none of it works

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

I made a few edits to your existing mission.sqm marker format. Try it and tell me how it works.

 

class Item41
        {
            dataType = "Marker";
            position[] = {2691.628, 170.707, 12311.693};
            name = "ExileMarker41";
            markerType = "ELLIPSE";
            type = "ExileContaminatedZone";
            colorName = "ColorBlack";
	    alpha = 0.0;
            fillName = "Border";
            a = 1600;
            b = 1600;
            drawBorder = 1;
            id = 141;
            atlOffset = 0;
        };
        class Item42
        {
            dataType = "Marker";
            position[] = {2691.628, 170.707, 12311.693};
            name = "ExileMarker42";
            type = "ExileContaminatedZoneIcon";
            id = 142;
            atlOffset = 0;
        };

 

Edited by Beowulfv

Share this post


Link to post
Share on other sites
  • 0
22 hours ago, Beowulfv said:

I made a few edits to your existing mission.sqm marker format. Try it and tell me how it works.

 


class Item41
        {
            dataType = "Marker";
            position[] = {2691.628, 170.707, 12311.693};
            name = "ExileMarker41";
            markerType = "ELLIPSE";
            type = "ExileContaminatedZone";
            colorName = "ColorBlack";
	    alpha = 0.0;
            fillName = "Border";
            a = 1600;
            b = 1600;
            drawBorder = 1;
            id = 141;
            atlOffset = 0;
        };
        class Item42
        {
            dataType = "Marker";
            position[] = {2691.628, 170.707, 12311.693};
            name = "ExileMarker42";
            type = "ExileContaminatedZoneIcon";
            id = 142;
            atlOffset = 0;
        };

 

All that did was make it so that there was no border around the contaminated zone, other than that, it didn't change anything

Share this post


Link to post
Share on other sites
  • 0

Can we just check quickly that you're not testing this with god mode on...?

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, BaroN said:

Can we just check quickly that you're not testing this with god mode on...?

This!... been there, done that :)

Share this post


Link to post
Share on other sites
  • 0

be funny if  he goes quiet now..... :D

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, BaroN said:

be funny if  he goes quiet now..... :D

Haha, I'm still here, and I've made sure many times that godmode isnt on, I even disabled Infistar

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.