• 0
Aristo

Using trigger in Eden to define safezone

Question

Posted (edited)

Hey!

I want to add a safezone to my custom trader and I am using a trigger for this. The problem is I have no idea what to add to the "On Activation" and "On Deactivation" section and I can't find anything on Google. I want it to be a classic safezone so that players, traders and vehicles have godmode.

I am completely lost, could anyone help me, please?

This is what I got so far:

trader.png

Edited by Aristo

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0
20 minutes ago, [HG]RaVeN103 said:

Place markers, not trggers^_^

Thanks for your reply, I did it the exact same way as you did, placed a tank and played as the character to test it and there is still no godmode. Or does this not apply in the editor itself?

Another question: is it possible to only give the trader godmode? I double clicked on the trader guy and unchecked "enable damage" but I can still kill him.

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Posted (edited)

On 16.8.2017 at 5:17 AM, gfourth said:

Check out this video, he's a member here too:

 

Thank you, I succesfully created the markers and the code but I can't get it working. I added it to my mission.sqm, increased the amount of items etc. and it's not working. I tried everything. Is there any tutorial on how to include these? I get the general idea but I make a mistake somewhere because otherwise it would be working.

The safezone is working now, now I am just having trouble with "dot markers" (A dot on the map that you can add text to - Like a list on the map)

 

Here is my code:

 

class Item184
		{
			dataType = "Marker";
			position[] = {4401.07, 0, 7841.45};
			name = "ExileMarker62";
			text = "LOREM IPSUM DOLOR";
			markerType = "ELLIPSE";
			type = "ExileNonConstructionZone";
			colorName = "ColorBlack";
			fillName = "Border";
			alpha = 0;
			a = 1;
			b = 1;
			drawBorder = 1;
			id = 559;
			atlOffset = 0;
		};

Any idea why it's not showing up on the map?

Edited by Aristo

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.