Spin Khan

[SOLVED] attachto #0 Opening Arsenal

6 posts in this topic

Posted (edited)

First off, since the thread was closed already, wanted to say thanks Chris(tian) for the quick fix on my previous thread about the server shutting down saying I needed to update.  I hadn't realized your script must be talking to your website (to keep it simple) so I hadn't considered such an externality figuring it was all having to do with my server and my local files.  But, it's all good now, Thanks!

I must say, I know BE filters are the bane of every server admin but I have spent many hours just in and out, in and out handling exceptions and filters.  There's got to be an easier way.  I realize it puts a big burden on the mod makers but IRL that's just the way it works, software teams must exhaustively test every button, every click, every sub-system.  Here in the Houston area in the space and aviation software industries, let me tell you, the testing departments are often bigger than the development teams!  But I really wish there was a better way, and especially that the community was a bit better at putting together at least a foundation of vanilla, out-of-the-box filter exception files to share.  Everyone, every single server owner out there shouldn't have to do the same work over and over for a common foundation.  I've written some analysis tools and hopefully one day I'll share them, the deepest string analysis algorithms are not trivial and once /I've/ finished and exhaustively tested them maybe they'll help.  I know what I have done has been a big help so far along with the BE_AEG too (kudos to it's author for that!)  I've made progress. 

I started with simple Exile, then infiSTAR and that's it and yet still, I don't know for a certainty that I'm not going to get into the game and get kicked again for some event or mouse-click that I hadn't tested. 

So far, I've gotten most of the obvious things handled, I've been able to spawn vehicles, tele where I want, etc. 

But I can't seem to open the Arsenal and I don't understand this attachto kick.  Here's the log entry

Quote

16.08.2017 21:30:58: Burns (73.255.117.176:2304) 0e1a00fcda93fcf75393b8d91c65a5ca - #0 5:139 Logic 2:1882 Exile_Unit_Player -1 [0,0,0]

And here's the current filter file,

Quote

//new
7 "" !"NVG_TargetG" !"Shot" !"Exile_Unit_Player" !"Logic 2" !"Exile_Unit_Player"
1 "Exile_Unit_Player"

Now Exile vanilla as well as what comes with infiSTAR reads as follows,

Quote

//new
7 "" !"NVG_TargetG" !"Shot" !"Exile_Unit_Player"
1 "Exile_Unit_Player"

So you can see the only entries I've added.  What I don't understand is why the patter isn't catching on 'exile_unit_player'

Any thoughts and feedback on what's going on here is much appreciated!

Thanks!

Edited by Spin Khan

Share this post


Link to post
Share on other sites

Hey

Can you please post your servers .rpt  file here?

16.08.2017 21:30:58: Burns (73.255.117.176:2304) 0e1a00fcda93fcf75393b8d91c65a5ca - #0 5:139 Logic 2:1882 Exile_Unit_Player -1 [0,0,0]

Client spawned Logic (5:) attaching to a server (2:) spawned player  object. However the Player object should be Local to your client too and if both things are local it is not checked by the attachto.log - if the player object isn't local to your client, then this kick is wanted. So the problem here is not really the attachto log, it is your setup somehow. Either the server being so slow, that the client would not get the locality of it's own playerobject in time and therefore being kicked when the logic is being attached from client side or you're using custom addons/scripts. Often people accidentally load Zeus with their server

7 "" !"NVG_TargetG" !"Shot" !"Exile_Unit_Player" !"Logic"

should be enough for that

You've added Exile_Unit_Player a second time which makes absolutely no sense, why? :P

Well and you added the "2" to the Logic object, even though the others don't have any spaces / numbers added behind.

#NewFact - Arma is harder than rocket science

I am not having the men, time, money to do your Houston checks for every single person neither am I willing to do so. If somebody hosts a server he should be committed enough to read / work on it and use common sense. You've written this huge dialog and posted your example which was completely strange (the double exception, the " 2" added at the end) I mean it's simply testing. Like no offense, good you're doing this and working on it but common that seemed like you didn't focus at all

slFUXMVkF3vxmO03zwvkF.png

--

But as mentioned earlier; this should not cause a kick at all. Player has to be local to your client at that point in time, If it isn't there is different issues -> post your server .rpt file

Share this post


Link to post
Share on other sites
Advertisement
//new
7 "" !"NVG_TargetG" !"Shot" !"Exile_Unit_Player" !"Logic"
1 "Exile_Unit_Player"

working perfectly fine

Share this post


Link to post
Share on other sites

I appreciate the feedback despite the broken English.  I can pick up plenty to at least try and research in the right direction.

Let's be clear.  THIS is the default infiSTAR attachto.txt:

Quote

//new
7 "" !"NVG_TargetG" !"Shot" !"Exile_Unit_Player"
1 "Exile_Unit_Player"

Let's pull our heads out:

You don't really think I got from THERE to my current one IF IT WAS WORKING?  SMH!

But I'll work on it.   The double Entry was simply an oversight.

Many thanks!

 

#NewFact - if you mean "no offense" don't be offensive  Son.   It's not about my focus or my efforts and you're really in no place to be a douche about it.  This is a forum for questions, I simply asked one, you can choose to respond or not but the self-righteous attitude isn't required nor helpful.  I don't know your background, but if you had one in the software industry you'd better understand my comment.  NO ONE expects you do be perfect or be able to do EVERYTHING.  And while I'm thankful for what you made me PAY for, the reality IS that a TON of BE exceptions have to be added just to get your addon to work out the box.  Challenges aside, In The Real World, software, especially software one pays for, whether it's $30 or $3000 simply doesn't work this way.  But I'm not here to debate nor argue with you on this, but be careful talking to courteous people just asking a question!

 

Share this post


Link to post
Share on other sites

If you paint your car red and then ask people why it's not yellow then why should I not ask if you even thought about the question itself? (towards your double entry and what else I pointed out)

I am no where responsible for you setting up your other addons/programs correctly and simply gave you a response to your question.

I'm not a douche and not your son.

 

On 8/17/2017 at 6:30 PM, Spin Khan said:

You don't really think I got from THERE to my current one IF IT WAS WORKING?  SMH!

I didn't think you got from there as I tested what I posted, again, and it works fine. I have no clue what you're doing that it doesn't work for you. Maybe working on the Wrong BE folder?

 

I am living and working in the real world.

--
use this:

//new
7 "" !"NVG_TargetG" !"Shot" !"Exile_Unit_Player" !"Logic"
1 "Exile_Unit_Player"

 

Share this post


Link to post
Share on other sites

We have closed this thread and marked it as solved.

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.