• 0
Wataya Lookinat

Advanced Vehicle Repair Menu Not working

Question

I am having a problem with the advanced vehicle repair menu, Player chooses "Repair/Salvage" from the scroll menu on the vehicle which then opens a new menu list ( top left of screen ) to select the item to be repaired (Tire,body,engine) etc. The problem most players are having is that when the secondary menu opens, the menu closes almost instantly and they cannot choose which item to repair. ( My menu work fine but I am admin ).   Any help or direction on this issue is greatly appreciated

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Sounds like infistar is shutting down the menu. If you have infistar ass the repair menu to the allowedIDDs section.

The install should tell you the menu number to add.

Share this post


Link to post
Share on other sites
  • 0

Agreed with above, it's one of the steps for install, you have to allow commanding menus in infistar ahat config.

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Thank you both for your input. I am currently on a GTX server and their service takes care of the infistar.i had not associated this problem with infistar. How would I go about changing these parameters? Thank you in advace.

Share this post


Link to post
Share on other sites
  • 0

Look in the thread for the advanced repair, I posted the fix in there.

Share this post


Link to post
Share on other sites
  • 0

Thank you all for your input. I am still a bit confused as to what action to take. In a previous post Kuplion suggested inserting

"#user:ASL_Show_Repair_Opyions_menu_Array into the allowedcommandingMenus[]

however others say this did not work for them and to add

"

//Advanced repair
Bones_fnc_salvageAndRepairMenuHelo = compileFinal preprocessFileLineNumbers "Custom\advancedRepair\Bones_fnc_salvageAndRepairMenuHelo.sqf";
Bones_fnc_salvageAndRepairMenuCar = compileFinal preprocessFileLineNumbers "Custom\advancedRepair\Bones_fnc_salvageAndRepairMenuCar.sqf";

'into your init.sqf instead of initplayerlocal.sqf  this is what we had to do to make it work."

I just want to make sure i am understanding the fix correctly and not trying to fix my issue with an outdated solution.

Thank you all again and sorry for the confusion.

 
 
  •  
 

Advanced Repair.png

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, Wataya Lookinat said:

Thank you all for your input. I am still a bit confused as to what action to take. In a previous post Kuplion suggested inserting

"#user:ASL_Show_Repair_Opyions_menu_Array into the allowedcommandingMenus[]

however others say this did not work for them and to add

"


//Advanced repair
Bones_fnc_salvageAndRepairMenuHelo = compileFinal preprocessFileLineNumbers "Custom\advancedRepair\Bones_fnc_salvageAndRepairMenuHelo.sqf";
Bones_fnc_salvageAndRepairMenuCar = compileFinal preprocessFileLineNumbers "Custom\advancedRepair\Bones_fnc_salvageAndRepairMenuCar.sqf";

'into your init.sqf instead of initplayerlocal.sqf  this is what we had to do to make it work."

I just want to make sure i am understanding the fix correctly and not trying to fix my issue with an outdated solution.

Thank you all again and sorry for the confusion.

 
 
  •  

 

Advanced Repair.png

Technically both are required as they are for different issues. The former is the issue you are having with the menu closing, and the latter is that of actions not firing because the files were compiled in the wrong place.

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.