kj(GrUnT)

infiSTAR Exile setup on End of Reality Server

14 posts in this topic

Hi new guy here....

A few buddies and I decided to rent  our own Arma3 server to play on. (End of Reality Hosting Co)  We also purchased infiSTAR Exile and we are not able to get it running. I've followed the The Gaming Junkie Show YouTube video to the T and also tried the posted version by "TheOldMan" and have been unsuccessful. I've wiped and installed a fresh copy of Arma3 Exile on the server twice now thinking i may have messed something up.  After many, many attempts it still does not work. When loading into the server there are no infiSTAR  messages coming up on the screen so i'm thinking it's not working at all and not just a admin console issue.

Any assistance would be appreciated,

Thanks

Edited by kj(GrUnT)
1 person likes this

Share this post


Link to post
Share on other sites

Check if infistar is loaded (RPT) - check if you have set your UIDs as admin in infistarconfig - check if all needed files are placed/included properly in missionconfig.

Share this post


Link to post
Share on other sites
Advertisement

Hey

Quote

13:29:05 "<infiSTAR.de> 0 - infiSTAR_AdminMenu.hpp is not in your MPMission or you forgot to #include it within your description.ext   [27794x2 - 03-12-2017 01-39-48 - v88 - Exile | PVE |Tanoa - [""Arma 3"",""Arma3"",178,143717,""Stable"",true,""Windows"",""x86""]]"

 

3 people like this

Share this post


Link to post
Share on other sites

@kj(GrUnT)  If you submit a support ticket, I will be more then happy to setup InfiSTAR for you :)

Edited by Rappidxshots

Share this post


Link to post
Share on other sites

I guess he didn't follow directions nor examine his RPT file...

While I did not view/nor read his 'instructions', it is clear as day in the RPT file that the IS Admin file was not loaded.

The real funny part is in the actual directions from InfiSTAR:

"06. Go to "infiSTAR.de_Exile\MPMission"
    - move all the files into your currently used MPMission
    - Open the description.ext in your MPmission with a notepad
    
    - find "class CfgRemoteExec {};" (might also have something within the {} curly brackets)
    - remove it!
    - now add these 2 lines in the file:
    #include "CfgRemoteExec.hpp"
    #include "infiSTAR_AdminMenu.hpp""

 

...Right there in the install file...

@kj(GrUnT), while we make mistakes, it appears you did a poor job on reading/following instructions.  InfiSTAR is not that hard to install, and if this caused you 'issues', be prepared for many more to come.

 

I would recommend for you to:

#1 - READ COMPLETELY and documentation FIRST and UNDERSTAND IT BEFORE you do ANYTHING!

#2 - Make a BACKUP OF EVERYTHING before you start!

 

If you do not, then you will have 'issues' on every mod install and on any Exile upgrade.

 

:)

 

1 person likes this

Share this post


Link to post
Share on other sites

First off... as i said i'm very new at this server stuff. I did read the report and noticed that error message. I did move the files as per the instructions. I tried to follow the directions as best as i could but for some reason my setup is just a little bit different than the two guides that i used. On top of that i dont know what every file does or how they interact with each other. That's why i asked for assistance.

 

Z80CPU

Really?  Your reply was extremely helpful.

Share this post


Link to post
Share on other sites

You followed the instructions?  To quote you, "Really"? 

 

...move all the files into your currently used MPMission...

...now add these 2 lines in the file:
#include "infiSTAR_AdminMenu.hpp"...

 

How can you say you did your 'best', when you did not follow directions?  And also, it appears your reading skills need improving too.  Not only could you not understand the PLAIN ENGLISH instructions from InfiSTAR, you also failed to read that the ONLY thing addressed to YOU in my post was:

I would recommend for you to:

#1 - READ COMPLETELY and documentation FIRST and UNDERSTAND IT BEFORE you do ANYTHING!

#2 - Make a BACKUP OF EVERYTHING before you start!

 

Good and solid advice.  If followed, your post would not have been made - And that is a FACT.

 

I also appears you missed this line as well "...while we make mistakes..." (which should have been "...while we ALL make...").   I did not set myself above you in any fashion.  Mistakes can be limited by following directions.

That AdminMenu.hpp file  has been part of IS for a long time.  So, you did not follow instructions from:

1 - A Video

2 - A Written Guide

3 - The InfiSTAR Instructions

All three said/showed the EXACT SAME THING - And you did not do it.  So by you ignoring ALL THREE, this is your 'best'?

 

As stated already, if you had FOLLOWED the instructions from InfiSTAR, your post would not be here.  By choosing to 'do it your way' and showing disregard to advice from those that KNOW, you failed.  Now you are here.

If you struggle with understanding 'copy all files over', perhaps running an ARMA server is a task you should leave alone.  That is not meant to be a 'smart remark', rather a blunt and cold truth.  An ARMA server is not a 'plug-n-play' server.  Medium knowledge of scripting is required.  Installing InfiSTAR requires 'limited' scripting knowledge, which you struggled and failed with it.  You think this is bad?  Wait till the next Exile update comes out, then you will REALLY see how much you truly know or other stuff such as adjusting prices, setting up custom traders, adding extra mods such as CUP/RHS, or the many other things that can be added/modified with Exile.

 

;)

 

Share this post


Link to post
Share on other sites

So are you always this pleasant to new admin/players who ask for some assistance setting up new servers using programs that they've never used before?

I'm trying to learn this whole Arma scripting thing and i'm sure i'll make more mistakes as i stumble along. This is only my second day messing with stuff so cut me some slack with the rude comments.

 

Share this post


Link to post
Share on other sites

Yes, I speak the TRUTH.  Besides, did I call you any names?  Did I say I was perfect?  Did I state anything that is false?  Did I not provide you with sound and solid advice?  If you want 'hand holding' and a 'shoulder to cry on', I would advise you to seek out your mommy.

 

Let us get the FACTS STRAIGHT here:

YOU failed to follow CLEAR INSTRUCTIONS FROM THREE SOURCES.

YOU stated. what most would term a LIE, by stating 'you did your best'.

You come here whining about how it failed because you failed to follow the instructions and want pity.

 

Truth is, if you could NOT FOLLOW THREE OTHER SOURCES, why are you here?   To IGNORE A FOURTH???  Any answer here WILL BE THE EXACT SAME THING AS THE OTHER ANSWERS!!! 

 

Again:  "...If you struggle with understanding 'copy all files over', perhaps running an ARMA server is a task you should leave alone..."

Copying those files over has NOTHING TO DO WITH ARMA!  It is just plain ole Windows file management, and you failed at that!  Why?  BECAUSE YOU FAILED TO FOLLOW SIMPLE INSTRUCTIONS!

 

The TRUTH helps; LIES do not.  You got called out on your behavior/actions and you have an issue with it.

;)

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.