Trillseeker82

Add custom billboards server side

58 posts in this topic

Thanks for your interest TroyT

Today I try to follow the indications and will communicate the results.
excellent

Share this post


Link to post
Share on other sites

Okay, here it is!
On the map Chernarus, in Kraslič airport, I have two signs "exile trader city".
I do not understand if I have to copy the coordinates (I can not find them with eden), or I have to put a new sign with eden.
Files, however, in exileserver, and in mp mission / textures / myname.paa, are exact, including the "billboard" replacement of my image name.
Do I also need to change the exact name of the signatures to krasnostav ???
Forgive the disguise.

Share this post


Link to post
Share on other sites
Advertisement

I'm back, then:
I put the billboards.sqf file in the custom folder in exile.chernarus
I put my xxxxx.paa file in the textures folder always in exile.chernarus
I inserted the init.sqf with the specified string
and I did not put any .pbo files in exileserver

Now I have two possibilities:
in billiboard.sqf i see the file of the sign, which is called "Land_Billboard_F"
while in initserver.sqf i have my file called: "Exile_Sign_TraderCity"

I see the billboard in the original location and the coordinates in billiboard.sqf, are those of my initserver.sqf, but I see my image flicker and almost flashing with even under the texture exile.

How can I fix ?????

Thank you - GRAZIE

Share this post


Link to post
Share on other sites

It sounds like there are 2 signs in the same location. If there was an Exile sign there that you are replacing with your own, make sure you remove the original one from your initServer.sqf.

1 person likes this

Share this post


Link to post
Share on other sites
On ‎04‎/‎09‎/‎2017 at 6:33 PM, TroyT said:

It sounds like there are 2 signs in the same location. If there was an Exile sign there that you are replacing with your own, make sure you remove the original one from your initServer.sqf.

Good morning, I settled for the image, if large serving just wait you enter. However, successful image placement. THANK YOU.

I also managed to place objects via @eden, but they are not the same as the location, and by string, example:
Billboard.sqf

_pos = [4796.48,10243.7,0.452452];
_object = createVehicle ["Land_Billboard_F", _pos, [], 0, "CAN_COLLIDE"];
_object setDir 345.743;
_object setPosATL _pos;
_object setObjectTextureGlobal [0, "textures\tonio.jpg"];
_object allowDamage false;


while my positioning string generate with eden initserver

..........


["Land_Billboard_F", [4796.48, 10243.7, 345.743], [0.452452, 0.891789, 0], [0, 0, 1], true] .....

the objects are positioned but do not match for height and rotation.
Thank you very much for the resolution of the image problem, shortly thanks to you, we will be contributing to exile.com.

Edited by EBEALIEN
insert code

Share this post


Link to post
Share on other sites

Don't use the positions that you get when you export your objects in Eden.  Only use the position that you get by right-clicking on the sign and selecting "Log Position".  This copies the position to your clipboard and you can paste this in your text editor.

1 person likes this

Share this post


Link to post
Share on other sites
4 hours ago, TroyT said:

Don't use the positions that you get when you export your objects in Eden.  Only use the position that you get by right-clicking on the sign and selecting "Log Position".  This copies the position to your clipboard and you can paste this in your text editor.

Yes, thank you, I got there yesterday to the solution, and it all works.
It's nice to plan something down with the help and also try to figure it out.
Your help was important, very important and honest.
Sincere thanks!


Antonio

PS. Now step by traders from scratch, then the vehicles with my skin and new buildings created from scratch.

Share this post


Link to post
Share on other sites

if u have infistar then heres my guide on how to do it

if u dont have infistar then in my guide m6mal from expendables uk also shows how to do it without infistar :)

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.