XxRTEKxX

Esseker Traders

6 posts in this topic

Can anyone explain in detail how to add traders and make them work in Exile, on any map other than Altis? 

What files need to be altered? What files need to be connected to the added traders? 

Share this post


Link to post
Share on other sites
Advertisement

Take a look at the initPlayerLocal.sqf and initServer.sqf files inside your mission folder.

Share this post


Link to post
Share on other sites

I did that. I changed the coordinates on the altis traders to be at the airfield in Esseker, commented out those props, and removed the move animations, left in just the idle ones. I also added in signs via xcam. Those show up, the traders do not. Ill link my 2 files later.

Share this post


Link to post
Share on other sites

I am having this same issue on Esseker. I am spawning the trader cities buildings in through a server side add on, these spawn fine. In my initplayerlocal.sqf I have this 

 

///////////////////////////////////////////////////////////////////////////////
// Static Objects
///////////////////////////////////////////////////////////////////////////////
#include "initServer.sqf"

if (!hasInterface || isServer) exitWith {};

///////////////////////////////////////////////////////////////////////////
// Armory Trader
///////////////////////////////////////////////////////////////////////////
_chair = "Land_CampingChair_V2_F" createVehicleLocal [0,0,0];
_chair setDir 208.182;    
_chair setPosATL [3679.383789, 3134.673828, 0]; <<< world space

[
    "Exile_Trader_Armory",
    "PersianHead_A3_02",
    ["InBaseMoves_SittingRifle1"],
    [0, -0.15, -0.45], <<< relative to chair (model space)
    180,
    _chair <<< link to chair
]

call ExileClient_object_trader_create;

The chair spawns in fine but the trader does not. I originally did not have a chair being used, however I wanted to test if it was a trade model issue causing no trader to be spawned. Anyone have a list of the trader models that work in Esseker?

Share this post


Link to post
Share on other sites

I am having this same issue on Esseker. I am spawning the trader cities buildings in through a server side add on, these spawn fine. In my initplayerlocal.sqf I have this 

 

///////////////////////////////////////////////////////////////////////////////
// Static Objects
///////////////////////////////////////////////////////////////////////////////
#include "initServer.sqf"

if (!hasInterface || isServer) exitWith {};

///////////////////////////////////////////////////////////////////////////
// Armory Trader
///////////////////////////////////////////////////////////////////////////
_chair = "Land_CampingChair_V2_F" createVehicleLocal [0,0,0];
_chair setDir 208.182;    
_chair setPosATL [3679.383789, 3134.673828, 0]; <<< world space

[
    "Exile_Trader_Armory",
    "PersianHead_A3_02",
    ["InBaseMoves_SittingRifle1"],
    [0, -0.15, -0.45], <<< relative to chair (model space)
    180,
    _chair <<< link to chair
]

call ExileClient_object_trader_create;

The chair spawns in fine but the trader does not. I originally did not have a chair being used, however I wanted to test if it was a trade model issue causing no trader to be spawned. Anyone have a list of the trader models that work in Esseker?

I have no words for what I did here. Obviously the issue was the <<<.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.