• 0
Sign in to follow this  
Followers 0
[COI]Naaaath

Safe Zone Double Spawning Objects (Low FPS?)

Question

Hello,

 

I don't have any custom scripts to spawn new safe zones its default (I think) and on server restart there are double of each object and that is causing the Physx engine to go crazy and for some people they are getting low FPS.

 

We are also getting random waves of low FPS and I have no idea how to debug what is causing it.

Edited by [COI]Naaaath

Share this post


Link to post
Share on other sites

12 answers to this question

  • 0

I got the same problem with the save zone im gonna try removing all scripts today and see if it gets fixed

Share this post


Link to post
Share on other sites
  • 0

I got the same problem with the save zone im gonna try removing all scripts today and see if it gets fixed

I've removed a few scripts like the status bar and it seems to be fixed, maybe I should add the exec code at the bottom of the initServer file?

Share this post


Link to post
Share on other sites
Advertisement
  • 0

I've removed a few scripts like the status bar and it seems to be fixed, maybe I should add the exec code at the bottom of the initServer file?

This may give you an idea: 

if (isServer) then {
[] execVM "scripts\real_weather.sqf";};
[] execVM "addons\statusBar\statusbar.sqf";
[] execVM "scripts\timematch.sqf";
[] execVM "ISAF\PvPZone.sqf";
[] execVM "ISAF\triggercheck.sqf";
#include "custom\acd_SZ\acd_SZ_load_props.sqf" // Work-around for ACiDy's custom spawn and traders.
publicVariable "acd_SZ_enabled_list"; // Work-around for ACiDy's custom spawn and traders.
if (!hasInterface || isServer) exitWith {};

{
    private ["_object"];

    _object = (_x select 0) createVehicle [0,0,0];
    _object setDir (_x select 2);
    _object setPosATL (_x select 1);
    _object allowDamage false;
    _object enableSimulationGlobal false;
}
forEach _objects;

EDIT: It doesn't fix ACiDy's custom spawn and traders just to put those 2 lines in there, a lot more work is required to make it work B| 

Edited by ka0s
Added edit for ACiDy

Share this post


Link to post
Share on other sites
  • 0

I've removed a few scripts like the status bar and it seems to be fixed, maybe I should add the exec code at the bottom of the initServer file?

I removed the statusbar now and it seems to work im gonna figure something out to fix it :D

Edited by Dope

Share this post


Link to post
Share on other sites
  • 0

I fixed it !

The problem is in the initPlayerLocal.sqf you probably just copy pasted it inside the file but at the top there already is a line of it so it executes it twice, your top should look like it and then its fixed

///////////////////////////////////////////////////////////////////////////////
// Static Objects
///////////////////////////////////////////////////////////////////////////////

// Taken away for now
//#include "initServer.sqf"
[] execVM "addons\statusBar\statusbar.sqf";

if (!hasInterface || isServer) exitWith {};

Edited by Dope

Share this post


Link to post
Share on other sites
  • 0

This may give you an idea: 

Hidden Content

EDIT: It doesn't fix ACiDy's custom spawn and traders just to put those 2 lines in there, a lot more work is required to make it work B| 

May I ask where you got the PVP Zones? I was looking at making my own (It would take a long time for me) but if it already exists that would be nice.

Share this post


Link to post
Share on other sites
  • 0

May I ask where you got the PVP Zones? I was looking at making my own (It would take a long time for me) but if it already exists that would be nice.

I'm porting a very old script, I might release it if I can get it to work as I want it to ;)

Edited by ka0s

Share this post


Link to post
Share on other sites
  • 0

I'm porting a very old script, I might release it if I can get it to work as I want it to ;)

Yeah that would be fantastic :) I wanted an area where players could go and PVP mode would start. If you are the last person standing and there is > 10 players you get a reward.

Share this post


Link to post
Share on other sites
  • 0

Well so far so good: 

18:23:41 "[ISAF-PVE] Anti-PvP Starting..."
18:23:41 "[ISAF-PVE] Anti-PvP eventHandlers added, ready!"
18:23:41 "SC/BIS_fnc_log: [postInit] SC_fnc_initPVE (0 ms)"
18:26:24 "[ISAF-PVE] Anti-PvP warning! R Alpha 1-2:1 ([faIR]iCEtIMed) REMOTE was killed by R Alpha 2-1:1 (ka0s) REMOTE"

That was outside PvP marker, so it almost works, just need to figure out why the handlers doesn't work :-/  

Share this post


Link to post
Share on other sites
  • 0

Well so far so good: 

Hidden Content

That was outside PvP marker, so it almost works, just need to figure out why the handlers doesn't work :-/  

Good work, I know a little bit of programming myself but the Arma 3 syntax is hard to get used to.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.