• 0
[COI]Naaaath

Headless Client help A3XAI

Question

Hello,

 

I have setup the headless client for A3XAI, I start the server up and then start the HC once the server is loaded and I get the following.

17:16:49 Client connected: 127.0.0.1:2310
headlessclient uses modified data file
17:16:48  > Welcome to Arma 3 Exile Mod!
17:16:48  > You were kicked off the game.
17:16:50  > Player headlessclient connecting
17:16:50  > headlessclient uses modified data file
17:16:50  > Welcome to Arma 3 Exile Mod!

 

Arma 3 Server has @A3XAI loaded as the server mods, It was working without HC enabled.

I have done a fresh install of Arma 3 for the headless client and installed the latest Exile Mod, @A3XAI_HC is also in the Headless client directory.

 

Step 1) Launch the server (Wait for it to unlock)

Step 2) Launch HC Start.bat

and... then I get kicked with the above message.

Startup params:

start "Exile" /wait /realtime /affinity F "arma3serverHC.exe" -client -mod=@Exile;@A3XAI_HC  -port=2310 -profiles=HC -bepath=C:\Arma\HeadlessClient\battleye -name=HC

 

RPT Log:

17:08:09 Starting mission:
17:08:09  Mission file: ExileIntro
17:08:09  Mission world: VR
17:08:09  Mission directory: exile_client\missions\ExileIntro.VR\
17:08:09 Attempt to override final function - bis_functions_list
17:08:09 Attempt to override final function - bis_functions_listpreinit
17:08:09 Attempt to override final function - bis_functions_listpostinit
17:08:09 Attempt to override final function - bis_functions_listrecompile
17:08:10 Attempt to override final function - bis_fnc_missiontaskslocal
17:08:10 Attempt to override final function - bis_fnc_missionconversationslocal
17:08:10 Attempt to override final function - bis_fnc_missionflow
17:08:10 "A3XAI blocked execution of A3XAI\init\client\fn_preInit.sqf."
17:08:10 "A3XAI blocked execution of A3XAI\init\server\fn_preInit.sqf."
17:08:10 Error: Bone world root doesn't exist in skeleton OFP2_ManSkeleton
17:08:10 Error: Bone hips doesn't exist in skeleton OFP2_ManSkeleton
17:08:14 "Exile Client - Playing intro..."
17:08:14 "[A3XAI] Initializing A3XAI HC build 0.2.0c using base path A3XAI."
17:08:14 "[A3XAI] Waiting for HC player object setup to be completed."
17:08:14 "A3XAI blocked execution of A3XAI\init\client\fn_postInit.sqf."
17:08:14 "A3XAI blocked execution of A3XAI\init\server\fn_postInit.sqf."

 

 

Edited by [COI]Naaaath

Share this post


Link to post
Share on other sites

15 answers to this question

  • 0

I'm going to bump this up because I'm  having a similar issue to the replies in this thread. Trying to run a headless client and the headless client is being kicked with the log is showing this:

12:51:28 Starting mission:
12:51:28  Mission file: ExileIntro
12:51:28  Mission world: VR
12:51:28  Mission directory: exile_client\missions\ExileIntro.VR\

My headless client command line parameters:

/HIGH /affinity 30 -client -mod=@Exile;@Namalsk;@Ryanzombies;@Rzinfection;@a3xai_hc -enableHT -profiles=HCLogs -autoinit

I am adding these parameters to arma3server.exe.

Edited by BetterDeadThanZed

Share this post


Link to post
Share on other sites
Advertisement
  • 0
On 2/4/2016 at 0:20 AM, Omen said:

I got A3XAI HC working by putting it in the LOGIC section. I left the top at Item99 but added another section below for LOGIC. It worked for me so...

 

Hopefully this helps you guys a bit.

 


				class Item99
				{
					position[]={13239.08,16.010651,11685.795};
					special="NONE";
					id=99;
					side="GUER";
					vehicle="Exile_Unit_GhostPlayer";
					player="PLAY CDG";
					skill=0.60000002;
				};
			};
		};
		class Item1
		{
			side="LOGIC";
			class Vehicles
			{
				items=1;
				class Item0
				{
					position[]={10720.502,12.714643,11356.243};
					special="NONE";
					id=100;
					side="LOGIC";
					vehicle="HeadlessClient_F";
					player="PLAY CDG";
					skill=0.60000002;
					text="A3XAIHC";
					forceHeadlessClient = 1;
				};
			};
		};
		class Item2

 

With text="A3XAIHC"; do I need to change the name of the headless client in the A3XAI anywhere?

 

This is what I get in my logs

 9:03:05 "[A3XAI Monitor] [Uptime:00:10:46][FPS:48][Groups:27/27][Respawn:0][HC:false]"
 9:03:05 "[A3XAI Monitor] [Static:0][Dynamic:0][Random:13][Air:3][Land:20][UAV:2][UGV:2]"

this is my hc bat file

cd /C "C:\arma3server"
"C:\Arma\Server\arma3server.exe" -client -connect=127.0.0.1 -port=2302 -mod=@Exile;@A3XAI_HC;@Extended_Base_Mod

My headless client stays connected but it doesn't appear to hand off AI.

These are my A3XAI settings:

    /*    A3XAI HC Settings
    --------------------------------------------------------------------------------------------------------------------*/

    //Enables A3XAI headless client support. (Default: 0)
    enableHC = 1;

    //If HC support enabled, A3XAI will pause during post-initialization until HC has successfully connected. (Default: 0)
    //IMPORTANT: It is highly recommended to ensure that the HC is properly setup before enabling this option, otherwise A3XAI may be stuck waiting for HC to to connect.
    waitForHC = 0;

My .rpt is the same following this guide as well:

https://github.com/Fickdichhard/A3XAI-UPLOAD/blob/master/6. Headless Client/A3XAI HC Installation and Setup Guide (Oct.4.2015).pdf

Edited by ChiefOwens

Share this post


Link to post
Share on other sites
  • 0

So here I am again, looking to set up a headless client for A3XAI. I added the stuff to the mission.sqm as per this reply: http://www.exilemod.com/topic/6296-headless-client-help-a3xai/?do=findComment&comment=61851

Here's my mission.sqm: http://pastebin.com/XQCRAfi3

I added this code to the end:

Spoiler

		class Item52
		{
			side="LOGIC";
			class Vehicles
			{
				items=1;
				class Item0
				{
					position[]={10720.502,12.714643,11356.243};
					special="NONE";
					id=52;
					side="LOGIC";
					vehicle="HeadlessClient_F";
					player="PLAY CDG";
					skill=0.60000002;
					text="A3XAIHC";
					forceHeadlessClient = 1;
				};
			};
		};

 

When the server starts, it gets stuck on "Unsupported language English in stringtable" which I assume is due to the mission.sqm not being set up right for A3XAI. Can someone that has this working advise what they added to their mission.sqm?

Share this post


Link to post
Share on other sites
  • 0

This is an OLD Thread .. but I'm old lol .. I'm trying to set up headless client .. I have the mission edited, and a3xai hc enabled, here is what I have for mission, start the HC and it just connects and disconnects over and over 

The startup for HC arma3server.exe -client -nosound -connect=127.0.0.1 -port=2302  -mod=@Exile;@A3XAI_HC; -profiles=HCLogs\A3XAI

Config.cfg in  @ExileServer I added to the bottom
localClient[]={127.0.0.1};
headlessClients[] = {"127.0.0.1"};
battleyeLicense=1;

Watch a video on how to do this .. but he also had a server with had no other mods I have a bunch .. do I need to add the full -mod= @Exile;@A3XAI_HC;this;@that;@whatsit etc or just as it is above ?
I tried with the full string .. as it tells me Im missing mods , without it but .. thought Id ASk

RPT shows this in regards to HC 
3:19:09 "[A3XAI] Compiling A3XAI HC functions."
 3:19:09 "[A3XAI] A3XAI HC functions compiled."
 3:19:09 "[A3XAI] Serverside PVEHs loaded."
 3:19:09 "[A3XAI] A3XAI is now listening for headless client connection."

FULL RPT  = https://pastebin.com/zn0VX8jc
MISSION SQM = https://pastebin.com/WP5jSN8f
HC Log = https://pastebin.com/pCMCv6L6
This looks pretty simple on paper :) but I'm bending over and hc is givin it to me good  I see above  that @ChiefOwens did this different .. but that was back in 2015 . I add mine via the editor ..  I've searched all over .. just not seeing much on this subject except a few posts from 2015 or before ..can anyone help a brotha out ?

 };
        class Item67
        {
            dataType="Logic";
            class PositionInfo
            {
                position[]={28.76,140.63373,35.792999};
                angles[]={0,0,6.2802181};
            };
            name="HC";
            isPlayable=1;
            id=169;
            type="HeadlessClient_F";
        };
    };

Edited by Chainsaw Squirrel

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.