khafir

centos7 Linux CentOS7 Launch Problems: Waiting for Server To Load

8 posts in this topic

OS: CentOS7 // Client: Waiting for server to load // Server: Multiple errors

I successfully installed ARMAIII via SteamCMD and pulled down the requisite Exile files, expanded them, etc. I am able to see my server when connecting via remote in the game client however after role selection, the client holds on "Waiting for server to load" message to screen and the server logs errors pertaining to a variety of things (Bone, sqf errors, etc). I thought it might be related to an sql issue so I dropped the database and recreated it and also recreated the exile user with no change to the client experience. I've been looking through every thread I can find and I'm not coming up with a solution.

Here is the STDERR output: http://pastebin.com/a3ee63uM
Here is the STDOUT output: http://pastebin.com/ng1iMYBR

Could someone take a look at this output, particularly STDERR and point me in the right direction please?

Many thanks in advance!

Edited by khafir
update title and tags

Share this post


Link to post
Share on other sites
Advertisement
Have you disabled strict mode in MySQL?

I have tried using this methodology with no change to server or client behavior:

MariaDB [(none)]> SELECT @@GLOBAL.sql_mode;
+-------------------+
| @@GLOBAL.sql_mode |
+-------------------+
|                   |
+-------------------+
1 row in set (0.00 sec)

MariaDB [(none)]> SET GLOBAL sql_mode="";
Query OK, 0 rows affected (0.00 sec)

Share this post


Link to post
Share on other sites

Anyone? I've been trolling every forum post I can find and trying to get smart on ARMA3, log files etc and I'm still not able to figure this out. Does anyone have experience using MariaDB with A3/ExileMod?

Share this post


Link to post
Share on other sites

** Resolved **

The problem was with my MySQL setup.

Here's what I did to resolve (taken from this post):

mysql -u root -p 
create database if not exists exile;
create user 'exile'@'localhost' identified by 'password';
grant all privileges on exile.* to 'exile'@'localhost';
flush privileges;
use exile; <-- I had to add this because I had to select the database.
source /home/steam/steamcmd/arma3/MySQL/exile.sql
Edited by khafir

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.