• 0
ComradeZoned

[SOLVED] Client Kicked "Uses Modified Data File."

Question

I get a modified data file error and get kicked from my own server. Have been trying all day for a solution and decided to come here.

Mods used(Client and Server):

  • CBA_A3
  • Exile (Of course ;) )
  • Ryans Zombies and Demons

This is a dedicated server owned by me. (The name is just a placeholder)

I have tried clearing mpmissions cache to no effect.

Pastebin, 'cause who likes long posts xD

 

SOLUTION

Solution might not work everywhere, but these were MY solutions.

  1. Change server appid in Arma 3 Server's appid.txt to the same id in Arma 3 client's.
  2. If that does not work reinstall server, repeat 1.
  3. Profit.
Edited by ComradeZoned
*Edited Solution

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

It can be all kinds of different errors. 

I would start looking into the server log, not the Arma Server RPT. If you have battleeye enabled it could be a restriction that's kicking you. 

I don't have any experience with the mods you are using but it could also be that you are missing a required addon in your client files. 

Share this post


Link to post
Share on other sites
  • 0

It's normal, it just means you're running a mod and not vanilla Arma 3.

Share this post


Link to post
Share on other sites
Advertisement
  • 0

It can be all kinds of different errors. 

I would start looking into the server log, not the Arma Server RPT. If you have battleeye enabled it could be a restriction that's kicking you. 

I don't have any experience with the mods you are using but it could also be that you are missing a required addon in your client files. 

when you said If you have battleeye enabled it ,where would you find that to make sure its enabled

Share this post


Link to post
Share on other sites
  • 0

when you said If you have battleeye enabled it ,where would you find that to make sure its enabled

there is a file in @Exileserver with a line (config.cfg) 

Battleeye                      = #;

0= no and 1= yes(enabled)

 

I personally have it disabled because I have my server offline/LAN.

Edited by ComradeZoned

Share this post


Link to post
Share on other sites
  • 0

@hogansheroes It depends what kind of file structure you are using for you arma server, but it should be located in the same file that you used to set your server name, the file is usually called server.cfg or config.cfg.

This .cfg file holds all basic init preferences for your server and this is also the "proper" place to adjust your battleye setting
Don't know if @ComradeZoned is incorrect but I would choose to use the designed config file for these kind of settings. (Exile has alot of bugs)

You can read about server.cfg settings here.

Edited by IWillNeverEverUseAdsInName

Share this post


Link to post
Share on other sites
  • 0

@hogansheroes It depends what kind of file structure you are using for you arma server, but it should be located in the same file that you used to set your server name, the file is usually called server.cfg or config.cfg.

This .cfg file holds all basic init preferences for your server and this is also the "proper" place to adjust your battleye setting
Don't know if @ComradeZoned is incorrect but I would choose to use the designed config file for these kind of settings. (Exile has alot of bugs)

You can read about server.cfg settings here.

Yeah ive ran into some other game-breaking bug after I fixed the current one. Ughhh

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.