Sign in to follow this  
Followers 0
NoxX83

Joinblock ohne Addon/mod ?

10 posts in this topic

Guten Abend.

 

Ich bin mal gerad wieder was aufgeschmissen.

 

Wo und wie kann ich das einstellen das der server beim joinen eine abfrage nach einen addon/mod startet und

wenn dieses addon/mod beim joinen nicht vorhanden ist das der joiner nicht auf den server kommt ?

Finde das problem gerad nicht aus eigene Hand und google .. naja :D da finden man alles mögliche aber nicht das was mach gerad sucht.

 

danke im vorraus für die Hilfe

Greetz NoxX

Share this post


Link to post
Share on other sites

in der servercfg

auf 1 stellen

verifySignatures=1;                    // Verifies the players files by checking them with the .bisign signatures. Works properly from 1.08 on

 

Share this post


Link to post
Share on other sites
Advertisement

jo steht standart da hab ich nichts dran gemacht...

 

weil hab das mas weapon sowie vehicle pack aufn server und die sollen da ohne es selbst zu haben garnicht erst drauf kommen.

hab sogar schon versucht das in die mission sqm die pbo´s rein zu machen aber dann loobt meine mission.sqm wie verrückt und hört garnicht mehr auf.

wenn ich meine standart mission.sqm benutz ist alles gut aber sobald ich die mit Eliteness bearbeite um eine pbo von dem mass pack einschreibe fängt es an ins endlose zu rennen .. keine ahnung vieleicht bediene ich das eliteness falsch oder es ist einfach zu spät ^^

Edited by NoxX83

Share this post


Link to post
Share on other sites

Moin.

Hier schau mal da nach.

config.cpp line 15

requiredAddons[] = {}; //to requiredAddons[] = {"ryanzombies"}; 

Dieses musste beim Zombi Script geändert werden damit Spieler ohne diesen Mod nicht draufkommen.

VG

Unbenannt.PNG

Edited by Gotteshand

Share this post


Link to post
Share on other sites

morgen :)

ja danke werd ich jetzt versuchen .. danke für eure hilfe :)

 

Edit:
okay habe ich dort eingegeben. "mas","NATO SF & SPETSNAZ Vehcile" aber es kommt immer nen fehler bei dem

waffenpack. ob ich jetzt mas oder NATO SF & SPETSNAZ Weapons" eingebe .. ändert sich nur der fehler auf den namen.

fehler bleibt ansonsten gleich

 

Edited by NoxX83

Share this post


Link to post
Share on other sites

ach man bin nen holz kopf ... kann es sein das ich die datei namen nehmen muss von der .pbo weil vom ryanszombies ist der name ja auch so von der pbo ?

Share this post


Link to post
Share on other sites

ich bekomms echt nicht auf die reihe in der server config die richtige datei da rein zu schreiben .. ob ich die pbo von mas da rein schreibe oder nur den @modname ("mas") es kommt immer der fehler das der server die datei braucht ...

 

 

also die .pbo´s sind im folgenden ordner  natürlich mit einem @ davor

mas/addons

NATO SF & SPETSNATZ\addons

Edited by NoxX83

Share this post


Link to post
Share on other sites

nimm eine datei aus dem addonordner...welche is wurscht und schreib diesen namen dort rein.

Lg Jürgen

Share this post


Link to post
Share on other sites

also das habe ich auch versucht jetzt dein  tip jürgen , vielen dank dafür... aber will er auch nicht nehmen.

also der fehler ist Addon 'exile_server_config' requires addon 'Mas'

ich habs im mas ordner gemacht in der exile_server

ich habs überall versucht aber irgentwie will der das nicht machen ... -.-

 

 

Share this post


Link to post
Share on other sites

vor dem selben Problem stehe ich auch, hab mich schon tod gegoogelt . gibts da nicht einfach ein script was die abfrage macht?

Das mit der Equalmod in der Server.cfg geht auch nicht.

 

wie habt ihr das gelöst?

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.