Sign in to follow this  
Followers 0
agentGoonie

Base Decay

11 posts in this topic

How does Base Decay work?  Doesn't look like there is anyway to maintain construction but it disappears for no reason even if you pay protection.  Anyone know?

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

go to office trader and pay territory protection.

that's what I'm saying has no relation.  When you pay protection for your territory it doesn't update your construction maintainence date in the database.  That's just so you can keep your territory.

So pieces of your base can disappear regardless if you pay territory protection.  At least that's what is happening on our servers.

Edited by agentGoonie

Share this post


Link to post
Share on other sites

Works fine on my server.

So your last_maintain fields in the construction table in your database actually update?

Share this post


Link to post
Share on other sites

There is no such thing as "pieces of your base despawning"  unless they changed it.

 

It's the FLAG that is your key item you are paying protection for.  IF that goes away then EVERYTHING in it's radius vanishes.

 

 

 

Share this post


Link to post
Share on other sites

Maybe someone raided you and blew something up?

I wish it was that simple, but it was center walls and nothing was breached.  I'm the admin so I have full access to the database and can see that the date doesn't update for construction when you pay for protection.  Maybe it's another bug, not related.

id just like to know the mechanics behind what actually disappears?  Is it all the construction object at the same time that meet the date?  I'm a nerd.

Share this post


Link to post
Share on other sites

I had the same questions.

When you pay protection the value in territory->last_payed_at get updated, unfortunatley you cannot see this in the XM8 until restart or if its relog... probably relog.

When the last_payed_at date is "older" that the set date which i think is 21 days as default, all base objects are deleted (think its everything in a certain radii that gets deleted). Im not entirely sure if this happes while the server is running or if it happens at restart as i had a restart and did a relog just when it wa about to happen and i didnt test it further, but i got a chopper i landed on top of the base dropped on my head and the safes dropped to the ground, a bit surpricing as shit just exploded when i got online =).

I believe the construction->maintained_at isnt used, at least for now, i also thought this was the value that was used.

So far i dont think i lost any baseparts except for that time when i let the time run out

Heres the thread where i made my questions, maybe its to some help

Edited by Cael817

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.