• 0
Sign in to follow this  
Followers 0
lostparadox

Trade static objects duping on player spawn

Question

So every time a player joins my server all the Trader static objects (shown in screenshot) duplicate. No idea why and really need help fixing it.

2015_11_05_00007.jpg

 

2015_11_05_00007.jpg

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Or he is executing initServer.sqf on initPlayerLocal.sqf, that would cause this as well, if he is using the stock traders. 

Share this post


Link to post
Share on other sites
Advertisement
  • 0

I honestly have no idea...I'm learning this as I go right now. Although I'm fairly good at scripting, i've never done it with Arma and still trying to learn at the issues with Exile. Is there something I can post so you can look for yourselves? such as my initServer.sqf or initPlayerLocal.sqf?

Share this post


Link to post
Share on other sites
  • 0

In case anyone needs the answer to this, the problem you were having is in the initServer.sqf in your Mission File. All you have to do to fix this is go all the way to the bottom, look for this phrase: 

Spoiler

{
    private ["_object"];

    _object = (_x select 0) createVehicle [0,0,0];
    _object setDir (_x select 2);
    _object setPosATL (_x select 1);
    _object allowDamage false;
    _object enableSimulationGlobal false; // :)
}

and change 

_object = (_x select 0) createVehicle [0,0,0];

to

_object = (_x select 0) createVehicleLocal [0,0,0];

 

There you go, your duping problem is solved. Hopefully this helps someone out!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.