Suranos

[SOLVED] RHS mods, Control Panel/Artillery Computer and R3F Logistics menu getting closed by infiSTAR

14 posts in this topic

As the title states, I have Inifstar installed along with my RHS mods on my Exile server, I run a partial militarized server so there is a SCUD launcher and some other military type vehicles. Infistar is not allowing normal players to use the SCUD launchers Control Panel/Artillery Computer, it allows it to open, and then closes it immediately, It also does this with the R3F Logistics menu even though I have added the IDD to the whitelist that was included with it.

another problem I have noticed is Infistar is preventing the teleport script from working properly when a vehicle is bought by a normal user, but does not affect admins...

This issue needs to be resolved soon as it is preventing me from fully opening my server!

 

How does one go about fixing this issue? The documentation for Infistar is not the most detailed for adding in functionality with other mods, and can't find anything searching for this particular problem, Also where does one find IDDs to add to the Whitelist? No documentation is included to describe where to find this information!

 

Currently using 16f

Share this post


Link to post
Share on other sites

2 sections of the AHCONFIG.  anti-teleport, set the coords of where your safezones are. Using scud bring up a scroll/other menu? check the config for enabling checks on scroll/command menus, or if the install guide for the extra mods has ids to add into the allowed section.

Share this post


Link to post
Share on other sites
Advertisement

2 sections of the AHCONFIG.  anti-teleport, set the coords of where your safezones are. Using scud bring up a scroll/other menu? check the config for enabling checks on scroll/command menus, or if the install guide for the extra mods has ids to add into the allowed section.

Ok, that fixed the teleport issues, the R3F IDDs I was able to find in another thread has fixed the issues i was having with that.

 

However I still have the issue with the RHS vehicle Artillery Computers/Control Panel for Non Admin users closing about 1-2 seconds after you open it, With Infistar disabled it works just fine as a normal user, With Infistar enabled, it auto closes it even with the Scroll/Command (_CAP) disabled.

Share this post


Link to post
Share on other sites

It should log something when it closes that display?

Either the idd of the computer is blacklisted or it is not white-listed :)

Share this post


Link to post
Share on other sites

I have the same problem, when I look in infistar log in the game it said #1, I added that number to IDD but players still can't use Artillery Computers Control Panel.

Any Idea what would be the real IDD. Oh i also added the tank to whitelist vehicle thinking it might fix that but no.

Share this post


Link to post
Share on other sites

Please post your Logs or a solution if you have one :)

Share this post


Link to post
Share on other sites

R3F uses "ctrlcreate", which was at least on Infistar-Epoch a very bad string.
Had to edit that out in Infistar-Epoch to use R3F.

Could it be related?

BR
Rob

Share this post


Link to post
Share on other sites

Nope - not checking for that on exile atm as we have very tide BE scripts.txt :)

but can you send me your server rpt file?

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.