• 0
Ephox

Failed to purchase vehicle: 13 on chernarus map

Question

So i got custom traders to nearly work. my only issue is Failed to purchase vehicle: 13 on the chernarus map with custom traders. It happens with ALL vehicles. Air, Boat Car. I had no problems 2 weeks ago but now suddenly it doesn't work. any tips?

Share this post


Link to post
Share on other sites

12 answers to this question

  • 0

Error 13 means it can't find a "safe" pos to spawn the car within the range of the safe zone.  The best solution would be to move the trader area to  a new spot with more open space so vehicles can spawn safely without risking colliding with map objects.  

Share this post


Link to post
Share on other sites
Advertisement
  • 0
3 hours ago, Darth_Rogue said:

Error 13 means it can't find a "safe" pos to spawn the car within the range of the safe zone.  The best solution would be to move the trader area to  a new spot with more open space so vehicles can spawn safely without risking colliding with map objects.  

The thing is it works on a different server... same exact trader positions and building positions... there is plenty of space for them to spawn.

Share this post


Link to post
Share on other sites
  • 0

ExileServer_system_trading_network_purchaseVehicleRequest.sqf, line #80.  Try changing the value of '80' to something larger.  That value means that it won't spawn the vehicle more than 80m away from the player.  If the server feels there is no "safe" position within 80m then it throws that error.  Changing it to 100 or more may allow it to work.  The findSafePos function is known to be wonky on certain cases though, so your mileage may vary.  

Edited by Darth_Rogue

Share this post


Link to post
Share on other sites
  • 0

^^ What he said. Theres also a script by BetterDedThanZed (sp?) that allows you to use placed helipads as vehicle spawn points like in Epoch.

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, Darth_Rogue said:

ExileServer_system_trading_network_purchaseVehicleRequest.sqf, line #80.  Try changing the value of '80' to something larger.  That value means that it won't spawn the vehicle more than 80m away from the player.  If the server feels there is no "safe" position within 80m then it throws that error.  Changing it to 100 or more may allow it to work.  The findSafePos function is known to be wonky on certain cases though, so your mileage may vary.  

Tried that. I put it at 175 to test. still didn't work. Can you give me that file? I think mine might be broken and i cant find a new one anywhere.

Share this post


Link to post
Share on other sites
  • 0
11 minutes ago, READTHESCROLL said:

Try making that number smaller, not bigger. Try 40.

I tried that aswell. put a trader in the middle of a huge open field. still error 13. I think there is something wrong with the file " ExileServer_system_trading_network_purchaseVehicleRequest.sqf" so i need a new one but i dont know where i can get one

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.