AtomicBrain

Problem with player slots and trade menus.

3 posts in this topic

So, I am having a bit of an issue.  I have searched all over these forums, and asked just about anyone that I can think of to help me with this and am not able to find the problem, or the solution.  I am not here begging anyone to solve my issue, I am really looking to see if anyone has had this issue, or if anyone knows of the best place for me to look in order to find the problem, I am still actively going through all of my files to find the problem, I have just been at this search for three days now.

I am building a mission for my community, this is my first full mission build, I wanted to try my hand at a custom mission because we are going to wipe the DB anyway when 0.9.36 drops, so a new mission will fill that void nicely.  I have almost everything working, spawns, trade cities and safe zones are built (with triggers for now), Exile is integrated nicely.  The problem I am having is that I can't buy anything from certain traders, and safezone sensors aren't reading the players entering and exiting the zones.  I can't access the inventory that my character has while in the trade menu (the left section of the trade menu), I can't buy or sell from SpecOps, Armory, Hardware, Equipment, Food, or even use the waste dump.  I can buy vehicles, boats, aircraft and plot poles.

Originally I thought it was just a bug with my traders, and then I looked at what I thought was a problem with the triggers.  I have not been able to find a problem there in mission.sqm, or initPlayerLocal.sqf.

What I think is happening is that my players/characters are not actually being authenticated or passing the boolean check when they enter or exit the zone, and/or access the trader.  I can access the menus for all of the traders, and see everything that they have for sale, but when I select the item, the purchase button never becomes selectable, it just stays transparent and I can't actually buy anything.

I know this is a wall-o-text, and I understand that everyone else has their own things going on, I am jut confused, and I think another set of eyes or another brain, familiar with Exile, might be able to at least point me in the right direction.

Thank you for any help you can provide.  I am including my mission.sqm and my initPlayerLocal.sqf in this post.

http://pastebin.com/yJSGLkWq <<<< mission.sqm

http://pastebin.com/9UMwdbnv <<<<<< initPlayerLocal.sqf

 

Share this post


Link to post
Share on other sites

I would love to help dude, but 1 thing at a time.

What is your first concern?

let me know maybe i can help. 

then we move on to the next.

Share this post


Link to post
Share on other sites
17 hours ago, kidesh said:

I would love to help dude, but 1 thing at a time.

What is your first concern?

let me know maybe i can help. 

then we move on to the next.

Thank you for your offer.  My first concern is that my traders aren't working properly.  I can access the trade menu for all traders, and I can see what they have for sale, I am just not able to actually purchase anything from certain traders (Armory, Equipment, Food, SpecOps, Hardware, Wastedump).  I can buy vehicles, aircraft, boats, and Plot Poles, and all players on the server are having the same issue. 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.