[BRG] Pé de Porco

nectarine [SOLVED] Waiting for server to load...

10 posts in this topic

I stuck on this screen(Waiting for server to load...) when i change any parameter on exile_server_config.pbo or Exile.Altis.pbo and re-pack with PBO Manager.

With stock files everything run without any issues.

Client Logs: http://pastebin.com/raw.php?i=kpTN3iNV
Server Logs: http://pastebin.com/raw.php?i=pTyTz4Ui
extDB Logs: http://pastebin.com/raw.php?i=uQav8X7Z

With Windows Server 2012 R2(64 bits) and Debian Jessie 8.2(64 bits).
Same issue on both.

I am using fresh install of ARMA3(with steamcmd) & Exile Nectarine.

Any help is welcome.
Thank you.

Edited by [BRG] Pé de Porco

Share this post


Link to post
Share on other sites
Advertisement

Upload full logs of server(after it finally unlocks), server specs.
Be sure something is not eating up IO on your system.

1 person likes this

Share this post


Link to post
Share on other sites

Hi Grim, thank you for the fast response.

[root@hefesto ~]:# top
top - 10:50:08 up  2:11,  1 user,  load average: 0,03, 0,09, 0,07
Tasks:  98 total,   1 running,  97 sleeping,   0 stopped,   0 zombie
%Cpu(s):  1,0 us,  0,2 sy,  0,0 ni, 98,8 id,  0,0 wa,  0,0 hi,  0,0 si,  0,0 st
KiB Mem:   4148324 total,  1399144 used,  2749180 free,    21092 buffers
KiB Swap:  1952764 total,        0 used,  1952764 free.   953612 cached Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
 2030 steam     20   0  474352 350328  36836 S   1,0  8,4   0:14.76 arma3server
 2017 steam     20   0    5488   2956   2400 S   0,3  0,1   0:00.33 tmux
    1 root      20   0    5416   4028   3044 S   0,0  0,1   0:01.02 systemd
    2 root      20   0       0      0      0 S   0,0  0,0   0:00.00 kthreadd
    3 root      20   0       0      0      0 S   0,0  0,0   0:08.38 ksoftirqd/0
    5 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 kworker/0:0H
    7 root      20   0       0      0      0 S   0,0  0,0   0:01.96 rcu_sched
    8 root      20   0       0      0      0 S   0,0  0,0   0:00.00 rcu_bh
    9 root      rt   0       0      0      0 S   0,0  0,0   0:00.05 migration/0
   10 root      rt   0       0      0      0 S   0,0  0,0   0:00.02 watchdog/0
   11 root      rt   0       0      0      0 S   0,0  0,0   0:00.06 watchdog/1
   12 root      rt   0       0      0      0 S   0,0  0,0   0:00.00 migration/1
   13 root      20   0       0      0      0 S   0,0  0,0   0:10.37 ksoftirqd/1
   15 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 kworker/1:0H
   16 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 khelper
   17 root      20   0       0      0      0 S   0,0  0,0   0:00.00 kdevtmpfs
   18 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 netns
   19 root      20   0       0      0      0 S   0,0  0,0   0:00.00 khungtaskd
   20 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 writeback
   21 root      25   5       0      0      0 S   0,0  0,0   0:00.00 ksmd
   22 root      39  19       0      0      0 S   0,0  0,0   0:00.00 khugepaged
   23 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 crypto
   24 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 kintegrityd
   25 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 bioset
   26 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 kblockd
   27 root      20   0       0      0      0 S   0,0  0,0   0:07.38 kworker/0:1
   28 root      20   0       0      0      0 S   0,0  0,0   0:00.00 kworker/1:1
   29 root      20   0       0      0      0 S   0,0  0,0   0:00.00 kswapd0
   30 root      20   0       0      0      0 S   0,0  0,0   0:00.00 fsnotify_mark
   36 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 kthrotld
   37 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 ipv6_addrconf
   39 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 deferwq
   75 root      20   0       0      0      0 S   0,0  0,0   0:00.00 khubd
   76 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 ata_sff
   77 root      20   0       0      0      0 S   0,0  0,0   0:00.00 scsi_eh_0
   78 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 scsi_tmf_0
   79 root      20   0       0      0      0 S   0,0  0,0   0:00.00 scsi_eh_1
   80 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 scsi_tmf_1
   81 root      20   0       0      0      0 S   0,0  0,0   0:00.00 scsi_eh_2
   82 root      20   0       0      0      0 S   0,0  0,0   0:00.00 kworker/u8:2
   83 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 scsi_tmf_2
   84 root      20   0       0      0      0 S   0,0  0,0   0:00.08 kworker/u8:3
   85 root      20   0       0      0      0 S   0,0  0,0   0:00.00 scsi_eh_3
   86 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 scsi_tmf_3
   92 root       0 -20       0      0      0 S   0,0  0,0   0:00.17 kworker/0:1H
[root@hefesto ~]:# free -m
             total       used       free     shared    buffers     cached
Mem:          4051       1366       2684         13         20        931
-/+ buffers/cache:        414       3636
Swap:         1906          0       1906
[root@hefesto ~]:# vmstat
procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 0  0      0 2749064  21092 953612    0    0    61    10  119  270  1  0 99  0  0
[root@hefesto ~]:# uname -a
Linux hefesto 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) i686 GNU/Linux
[root@hefesto ~]:# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.2 (jessie)
Release:        8.2
Codename:       jessie
[root@hefesto ~]:# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Core(TM)2 Duo CPU     E7500  @ 2.93GHz
stepping        : 10
microcode       : 0xa07
cpu MHz         : 1596.000
cache size      : 3072 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm tpr_shadow vnmi flexpriority
bogomips        : 5866.62
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Core(TM)2 Duo CPU     E7500  @ 2.93GHz
stepping        : 10
microcode       : 0xa07
cpu MHz         : 1596.000
cache size      : 3072 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
apicid          : 1
initial apicid  : 1
fdiv_bug        : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm tpr_shadow vnmi flexpriority
bogomips        : 5866.62
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
[root@hefesto ~]:# ifconfig
eth0      Link encap:Ethernet  Endereço de HW 48:5b:39:f7:80:e8
          inet end.: 192.168.1.2  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: fe80::4a5b:39ff:fef7:80e8/64 Escopo:Link
          UP BROADCASTRUNNING MULTICAST  MTU:1500  Métrica:1
          RX packets:9854 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7896 errors:0 dropped:0 overruns:0 carrier:0
          colisões:0 txqueuelen:1000
          RX bytes:3132324 (2.9 MiB)  TX bytes:1492179 (1.4 MiB)

lo        Link encap:Loopback Local
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACKRUNNING  MTU:65536  Métrica:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          colisões:0 txqueuelen:0
          RX bytes:1104 (1.0 KiB)  TX bytes:1104 (1.0 KiB)

I am using this init:

tmux new-session -d -s exile "./arma3server -port=2302 -pid=guerrilha/2302.pid -name=guerrilha -profiles=guerrilha -cfg=guerrilha/basic.cfg -config=guerrilha/config.cfg -mod=@exile;kart;mark;heli; -servermod=@exileserver;@a3_dms; -malloc=tbbmalloc -noPause -noSound -nosplash -enableHT -autoinit 2> guerrilha/errors.log | tee guerrilha/exile.log"

I have tried this:

tmux new-session -d -s exile "./arma3server -port=2302 -pid=guerrilha/2302.pid -name=guerrilha -profiles=guerrilha -cfg=guerrilha/basic.cfg -config=guerrilha/config.cfg -mod=@exile -servermod=@exileserver -autoinit 2> guerrilha/errors.log | tee guerrilha/exile.log"

Same in both.

I'm not sure if arma3server is eating much CPU, maybe not.


This machine not have X, and it's only for that server.
Debian minimal 64 bits, fresh install.

Now, to see the logs, we will have to wait an hour or two :(

Thank you.

Share this post


Link to post
Share on other sites

You can post your rpt file without letting the server run for hours.  Are you saying that it takes hours to fully launch?

Intel(R) Core(TM)2 Duo CPU     E7500  @ 2.93GHz

Your CPU isn't enough to run any kind of server with players. Infact, I would imagine that the armaserver application would easily max this cpu out. I feel like hardware may be the issue.

Share this post


Link to post
Share on other sites
6 minutes ago, bregan5 said:

You can post your rpt file without letting the server run for hours.  Are you saying that it takes hours to fully launch?


Intel(R) Core(TM)2 Duo CPU     E7500  @ 2.93GHz

Your CPU isn't enough to run any kind of server with players. Infact, I would imagine that the armaserver application would easily max this cpu out. I feel like hardware may be the issue.

Oh! Now I see!
Thank you.

But almost miraculously, is running :monkey:

Solved.

Share this post


Link to post
Share on other sites

I have a test server running on a Pentium G840 (2.8GHz), runs fine but I wouldn't expect it to be able to handle more than 10-15 players.

Share this post


Link to post
Share on other sites

It's running Windows 7 Pro x64:

start /min "arma3server" /realtime "arma3server.exe" -mod=@AllInArmaTerrainPack;@TavianaA3;@RHSAFRF;@RHSUSAF;@TRYK;@Exile; -serverMod=@ExileServer;@infiSTAR_servermod; -bandwidthAlg=2 -bepath=F:\A3server\SC\BattlEye\ -port=2302 -maxMem=3072 -enableHT -noTexHeaders -profiles=SC -name=SC "-config=SC\config.cfg" "-cfg=SC\basic.cfg" -autoinit

I would check the vehicle config in your exile_server_config.pbo 

		/**
		* Grid Size for vehicle spawning,
		* smaller the number more vehicles,
		* you get the point
		*/
		vehiclesGridSize = 2200;

		/**
		* Vehicle ammount per grid
		* kinda self explanitory
		*/
		vehiclesGridAmount = 1;

I use the settings above to limit the amount of random spawning vehicles, having more vehicle slows the server startup time massively.

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.