MGTDB

Fix for territory date due

8 posts in this topic

This is a temporary fix for the Xm8 territory due date error where it shows an incorrect date format that makes no sense.

What it does is change territory payment due to territory last paid so your players know when they last paid

arma3_2015_11_30_11_51_49_882.thumb.jpg.

Time paid format is year, month, day, hour, minute (and seconds if there)

1. Copy this ExileServer_system_territory_maintenance_recalculateDueDate.sqf into a new sqf file called ExileServer_system_territory_maintenance_recalculateDueDate.sqf and put it into your \exile_server\code folder , replacing the current version

2. Copy this ExileServer_system_territory_database_load.sqf into a new sqf file called ExileServer_system_territory_database_load.sqf and put it into your \exile_server\code folder , replacing the current version then repack exile_server.pbo

3. Copy this ExileClient_gui_xm8_slide_territory_event_onTerritoryDropdownSelectionChanged.sqf into a new file called ExileClient_gui_xm8_slide_territory_event_onTerritoryDropdownSelectionChanged.sqf and put it in your mission file root (or your edit folder)

4. In your mission file config.cpp search for class CfgExileCustomCode and add ExileClient_gui_xm8_slide_territory_event_onTerritoryDropdownSelectionChanged = "ExileClient_gui_xm8_slide_territory_event_onTerritoryDropdownSelectionChanged.sqf"; making sure you include any specific path (edit folder) if file is not in mission root

5. Repack mission.pbo

Thanks to Cen for bringing it to everyones attention everyday :)

Note: in some cases flags placed may sometimes not save so I would not recommend using this until I have debugged the reason for it
 

Edited by MGTDB
7 people like this

Share this post


Link to post
Share on other sites
25 minutes ago, MGTDB said:

Thanks to Cen for bringing it to everyones attention everyday

haha

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

With this fix, New territories are not saving to the database, i must have done something wrong

Share this post


Link to post
Share on other sites
10 hours ago, GR8 said:

With this fix, New territories are not saving to the database, i must have done something wrong

Or you can't read:

Note: in some cases flags placed may sometimes not save so I would not recommend using this until I have debugged the reason for it

Share this post


Link to post
Share on other sites
25 minutes ago, CEN said:

Or you can't read:

Note: in some cases flags placed may sometimes not save so I would not recommend using this until I have debugged the reason for it

Gotcha, i'll debug it and post the fix here.

1 person likes this

Share this post


Link to post
Share on other sites

Thanks, not had time to, I think its a conflicting variable between the changed files with an existing variable having 2 instructions sent to it.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.