• 0
Sign in to follow this  
Followers 0
AndyG

Player spawning in with no body at Makrynisi Island after logout

Question

A user is having the issue that whenever he logs out, the next time he logs back in he's stuck with no body at Makrynisi Island. This only happens when he has a valid character slot in the database. when he dies or I wipe the database he spawns in fine. This happened to me when I first started up but it was from mods not playing nice, he isn't running any of the mods that broke me.

mods Exile,CUP_Weapons,TRYK_Uniforms,RyansZombies all downloaded from A3Launcher (where I got the mods I crammed into the server if it helps)

Below is a screenshot he sent me of 3rd person. It irritates me and I would like to know why this happens, aside from the game gives up right when it's supposed to be getting the character from the database.

search any launcher for " Gahan "  and you'll see my test server and try it yourself 

Any help would be appreciated as I can't duplicate this on my end.

 

2015-11-24_00001.jpg

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

I ended up pushing 1.54 and broke the universe. Once I get that all sorted out I'll post something on here if I'm still having the same problem. Sorry if anyone tried to help and either couldn't find the server or it was in a permanent state of kerfluffle.  

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Bump, having same problem, this seems to be happening a few times a day on our server. 

Edited by Retribution

Share this post


Link to post
Share on other sites
  • 0

Can confirm right now that the character data bug is happening.

Remove their player data from the database and they can get back in.

IMPORTANT INFO:

Both players tonight logged out next to their vehicle and upon restart and log back in, they ended up bugged out at the island as Ghost Units.

Share this post


Link to post
Share on other sites
  • 0

The Issues we have found is in the column 'loaded_magazines'

I believe it has to do with the database for this column being set as " varchar(255)"  allowing a maximum of 255 characters. If your character has a primary with a underbarrel grenade launcher and a hand gun and an axe... you exceed this. For Example:

[["arifle_mas_fal_m203","20Rnd_mas_762x51_Stanag",15,"arifle_mas_fal_m203"],["arifle_mas_fal_m203","3Rnd_HE_Grenade_shell",3,"M203d"],["Exile_Melee_Axe","Exile_Magazine_Swing",999,"Exile_Melee_Axe"],["hgun_mas_m9_F","15Rnd_mas_9x21_Mag",15,"hgun_mas_m9_F"

I changed the "Varchar(255)" to "text" in the database and seems to have fixed the issue.

Share this post


Link to post
Share on other sites
  • 0

It is related.

The Hit points have a similar issue, to the data sent to the database. Both columns are 'varchar(255)' but the data can exceed that. So by following the above link for setting the hitpoints to a maximum of 3 decimal points (anymore is not worth it) Will limit the hitpoints characters to less that 255. But for the load_magazines, you have to change the datatype as it cannot be limited, especially if you use mas or cup weapons (They will contain more characters). 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.