Sign in to follow this  
Followers 0
Banzak

After installing infiSTAR V0021A on Ubuntu-Server *resolved*

5 posts in this topic

Hello!

After installation of the infiSTAR-AntiHack i got the following error when i start my Server on linux. It loops for several times and then stops.

20:41:13 "<infiSTAR.de> 0 - compiling AntiHack"
20:41:13 "<infiSTAR.de> 0 - Thread BEFORE MAIN: still compiling..."
20:41:13 "<infiSTAR.de> 0 - infiSTAR_PlayerLog: still compiling..."
20:41:13 "<infiSTAR.de> 0 - FNC_AH_KICKLOG: still compiling..."
20:41:13 "<infiSTAR.de> 0 - fnc_AdminReqReal: still compiling..."
20:41:13 "<infiSTAR.de> 0 - fnc_AdminReq: still compiling..."
20:41:13 "<infiSTAR.de> 0 - FNC_AH_KICKLOGSPAWN: still compiling..."
20:41:13 "<infiSTAR.de> 0 - adminStartupCode: still compiling..."
20:41:13 "<infiSTAR.de> 0 - Thread MAIN: compiling adminStartupCode"
20:41:13 Warning Message: Problem occurred when saving profile data. The file may be set to read-only or can be blocked by another instance of the game (e.g., dedicated server).
20:41:13 "<infiSTAR.de> 0 - AntiHack loaded!"
20:41:13 "<infiSTAR.de> 0 - STARTUP - AntiHack included!"
20:41:13 "Player/BIS_fnc_log: [preInit] a3_infiSTAR_Exile_fnc_preInit (225.998 ms)"
20:41:13 Problem occurred when saving profile data. The file may be set to read-only or can be blocked by another instance of the game (e.g., dedicated server).
20:41:13 "<infiSTAR.de> 0 - Thread #1: Server Loop #1 starting"
20:41:13 "<infiSTAR.de> 0 - Thread #1: Server Loop #1 - waiting for Logic #1"
20:41:13 "<infiSTAR.de> 0 - Thread #1: Server Loop #1 - waiting for Logic #1"
20:41:13 "<infiSTAR.de> 0 - Thread #1: Server Loop #1 looping now!"

I am running  Ubuntu 14.04.3-server. I think it's a problem of access rights. Does anybody know what files/directories I have to change or how can i fix?

What profile data cannot be saved?

Thank you for your help.

Regards.

Banzak

Share this post


Link to post
Share on other sites

Hello again!

I found out that the real problem is here:
19:17:08 Problem occurred when saving profile data. The file may be set to read-only or can be blocked by another instance of the game (e.g., dedicated server).
19:17:14 [ERROR] cannot save. [filename]=/home/steam/.local/share/Arma 3 - Other Profiles\Player\Saved\steam\meta\cacheItems.map

I will now create these path and give it another try!

I will post the results here.

Regards.

Banzak

 

Share this post


Link to post
Share on other sites
Advertisement

Bug.gifUpdate:

I thought that the armaserver3 had no rights to create files in the user home directory, so I wrote a bash-script and

started the script as the user.

the bash-script:

#!/bin/bash
./arma3server -enableHT -profiles -config=config.cfg "-mod=@exile;@Ryanzombies" "-servermod=@exileserver;@infiSTAR_Exile" -autoinit

and the start-up call:

sudo su steam -c ./arma_server.sh

Now the server has the rights to create files in the users home directory - but I got still the loop... -_-

Then I changed with chmod the permisions for others of the specific directory

/home/steam/.local/share/Arma 3 - Other Profiles\Player\Saved\steam\meta\

and all of its sub-directories with the following:

 chmod 775 .local/ -R

At the moment I am waiting for a reply from infiSTAR about this issue. I have no idea anymore how to fix this.

But I will post here the solution, as soon I found one. :)

Because it cannot be that I am the only one with an Ubuntu server and this problem.. :)

Regards

Banzak

Bug.gif

Edited by Banzak

Share this post


Link to post
Share on other sites

We are having a private discussion, I'll change it once he has confirmed me that the changes I've made work.
Innovation your priv message must have been a bad joke.

***CLOSED***

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.