NAIL

BEC not working anymore

10 posts in this topic

My BEC is starting and immediately closing when I try to open it.  BEC worked in the last version, and is also running on the arma 2 epoch server I am running as well.  

Server is a dedicated box.  Settings all seem to be fine, I have no errors and everything I have found so far online doesn't seem to help.  I can connect with dart, and BattlEye RCon tool.

 

 

 

Second unrelated question, "Quick Exile.ini Update"  where is this file on the install?

 

 

Thank you, 

NAIL

Edited by NAIL

Share this post


Link to post
Share on other sites

how do you start the bec.exe? The immediate close of bec is because the update service don't work and bec is searching for updates on the start. it closes when he can't connect.

You have to start BEC with the parameter --dsc, to tell him he should not try to update.

So like this:

Bec.exe -f Config.cfg --dsc

and the Config.cfg should be change, if you renamed your Config file.

Edited by Wyqer

Share this post


Link to post
Share on other sites
Advertisement

my batch (StartBEC10.bat)

 

@ECHO Off
echo.
echo Starting BEC Extended...
start /MIN Bec10.exe -f config10.cfg --dsc
exit

My config10.cfg

[Bec]
IP = 127.0.0.1
#Port = 2302
#BePath = D:\ARMA3_EXILE\battleye
#Admins = Admins.xml
#Commands = Commands.xml

[Misc]
#AsciiChatOnly = True
#Timeout = 30
#Scheduler = Scheduler10.xml
#ServerExeName = arma3server.exe
#SlotLimitKickMsg = Your late to the party! - GPG is currently full!

nothing changed except exile.  I am noticing that "beserver.cfg" is renaming itself to "beserver_active_59cd.cfg".  I think this may be related.

Edited by NAIL

Share this post


Link to post
Share on other sites

That's how it stands in your cfg?

Then remove all # there. The # let bec ignore it (or disable the option if you want to name it like that)

So you commented everything out, only the IP is "visible" vor BEC.

And you have to write the path for the filters in your arma profile.

So for example

D:\ARMA3_EXILE\SC\BattlEye

Edited by Wyqer

Share this post


Link to post
Share on other sites

oh, yeah, I read somewhere to comment out every thing but the ip to try to figure out the error.  I never did find the rpt file they claimed would show the error.  I must have not uncommented out all the lines, but this was still the problem before all the added comments, and still closes right away after i just now removed them again.

Edited by NAIL

Share this post


Link to post
Share on other sites

hello i have try it and that work

1 create bat file like "autorestart.bat" and edit it

Spoiler

@echo off
color 2
B: //hard driver where is the server file and ballteye filter
cd "B:\programe\steams\SteamApps\common\Arma 3\"
set count=0
:start "Arma3server" /min /wait arma3server.exe -port=2302 -mod=@Ryanzombies;@ExileServer;@Exile;@infiSTAR_servermod; -name=cfg -config=server.cfg -noCB -filePatching -BEPath=B:\programe\steams\SteamApps\common\Arma\BattlEye -autoinit
cls
echo %message% = [%date%] [%time:~0,8%]: Serveur Arma III Exile Z allumer
if %count% == 0 echo %message%. & goto next
echo %message% (relancer %count%x). & goto next
:next
    
set /a count+=1
"Arma3server" /min /wait arma3server.exe -port=2302 -mod=@Ryanzombies;@ExileServer;@Exile;@infiSTAR_servermod; -name=cfg -config=server.cfg -noCB -filePatching -BEPath=B:\programe\steams\SteamApps\common\Arma\BattlEye -autoinit
goto start

 

in red its the directory of your arma3server change for your own directorry

in green its the directory of your battleye YOU MUST CREATE A SPECIAL FOLDER FOR BATTLEYE

My server directory :  "B:\programe\steams\SteamApps\common\Arma 3\"

My battleye direcotry : B:\programe\steams\SteamApps\common\Arma\BattlEye

 

2. so go in your arma directory and open ballteye folder and take all file execpted "BEserver.dll" and put in you battleye special folder

 

3 run server enjoy ;)  (the server go to auto creat BEserver.dll so she can need a reboot after first try ) 

 

 

Share this post


Link to post
Share on other sites

Not following you 100% but what I tried, from what I could understand , not working.  I made a second BE folder with a new name, copied contents, and linked to that with BEC, no go, still closes.

Share this post


Link to post
Share on other sites

hum so lets go to try with that exactly please (in picture for best tuto )

first go in your root folder and create a bat file "test.bat"

WARNING make a spacer in folder name in directory cause bug and can't find the file

exemple : "B:\programe\steams\SteamApps\common\Arma 3" is bad

1.thumb.png.56f69ccb351204cc6830fd19d4c0

 

must be like this "B:\programe\steams\SteamApps\common\Arma" this is why we must create folder BattleEye

2.thumb.png.a0cb7fd04ec5bccfd6247a711ad0

 

so now in the file "test.bat" insert your start cmd mod etc and add this 

-BEPath=root directory\Arma\BattlEye

 

next in your Bec Config.cfg edit this line by your -BEPath=root directory\Arma\BattlEye

3.thumb.png.3d1d331d229fb06efc4437d4ba06

Now start your server with test.bat and run bec with admin right4.thumb.png.08212f1f3934acacb202dc7b0b42

you should have this

5.thumb.png.02a619ba8667d76bb85817f78228

if your bec continue to crash try to creat a text file "bans.txt" in your battleye folder

 

i hope i have help you if it's not done pm me and i go to come help you from skype or teamviewer if you want

 

Edited by Bozoweed

Share this post


Link to post
Share on other sites

The solution for your problem is:

BEC searches for Updates and can't find them. Insert following entries to your hosts file and it will work

127.0.0.1                    ibattle.org
127.0.0.1                    www.ibattle.org

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.