• 0
agentGoonie

Are Exile Weather Settings Working in Lime?

Question

Are the Exile Weather Settings working for everyone?  I have the below configs and yet it still rains:

Spoiler

class Sunny
  {
   fogValue = 0.1;
   fogDecay = 0.2;
   fogBase = 5;
   overcast = 0.2;
   waves = 0.2;
   wind = 0.25;
   gusts = 0.1;
   rain = 0;
   lightnings = 0;
   rainbows = 0;
  };

  class Cloudy
  {
   fogValue = 0.2;
   fogDecay = 0.1;
   fogBase = 5;
   overcast = 0.4;
   waves = 0.4;
   wind = 0.25;
   gusts = 0.5;
   rain = 0;
   lightnings = 0.1;
   rainbows = 1;
  };

  class Thunderstorm
  {
   fogValue = 0.7;
   fogDecay = 0.2;
   fogBase = 5;
   overcast = 1;
   waves = 1;
   wind = 0.25;
   gusts = 0.5;
   rain = 0;
   lightnings = 1;
   rainbows = 0.5;
  };

Thanks.

-Goonie

Edited by agentGoonie

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Anyone?  Yes, No, Maybe so??  I really don't think the weather settings in the config file have any impact on the weather any more.  Is it just me?  Please tell me I'm not crazy.

Edited by agentGoonie

Share this post


Link to post
Share on other sites
  • 0
  C:\EXILE_SQF\exile_server\code\ExileServer_system_process_postInit.sqf (1 hit)
	Line 21: 	call ExileServer_system_weather_initialize;
  C:\EXILE_SQF\exile_server\code\ExileServer_system_weather_initialize.sqf (7 hits)
	Line 2:  * ExileServer_system_weather_initialize
	Line 13: call ExileServer_system_weather_thread_weatherSimulation;
	Line 13: call ExileServer_system_weather_thread_weatherSimulation;
	Line 28: forceWeatherChange;
	Line 29: _changetime = round(getNumber (configFile >> "CfgSettings" >> "Weather" >> "interval") * 60);
	Line 30: [_changetime, ExileServer_system_weather_thread_weatherSimulation, [], true] call ExileServer_system_thread_addTask;
	Line 30: [_changetime, ExileServer_system_weather_thread_weatherSimulation, [], true] call ExileServer_system_thread_addTask;
  C:\EXILE_SQF\exile_server\code\ExileServer_system_weather_thread_weatherSimulation.sqf (5 hits)
	Line 2:  * ExileServer_system_weather_thread_weatherSimulation
	Line 2:  * ExileServer_system_weather_thread_weatherSimulation
	Line 13: _interval = round(getNumber (configFile >> "CfgSettings" >> "Weather" >> "interval") * 60);
	Line 14: _keyframes = getArray (configFile >> "CfgSettings" >> "Weather" >> "keyframes");
	Line 16: _keyframeConfig = configFile >> "CfgSettings" >> "Weather" >> _keyframeName;

Should still be loaded :P

Share this post


Link to post
Share on other sites
Advertisement
  • 0
45 minutes ago, infiSTAR said:

  C:\EXILE_SQF\exile_server\code\ExileServer_system_process_postInit.sqf (1 hit)
	Line 21: 	call ExileServer_system_weather_initialize;
  C:\EXILE_SQF\exile_server\code\ExileServer_system_weather_initialize.sqf (7 hits)
	Line 2:  * ExileServer_system_weather_initialize
	Line 13: call ExileServer_system_weather_thread_weatherSimulation;
	Line 13: call ExileServer_system_weather_thread_weatherSimulation;
	Line 28: forceWeatherChange;
	Line 29: _changetime = round(getNumber (configFile >> "CfgSettings" >> "Weather" >> "interval") * 60);
	Line 30: [_changetime, ExileServer_system_weather_thread_weatherSimulation, [], true] call ExileServer_system_thread_addTask;
	Line 30: [_changetime, ExileServer_system_weather_thread_weatherSimulation, [], true] call ExileServer_system_thread_addTask;
  C:\EXILE_SQF\exile_server\code\ExileServer_system_weather_thread_weatherSimulation.sqf (5 hits)
	Line 2:  * ExileServer_system_weather_thread_weatherSimulation
	Line 2:  * ExileServer_system_weather_thread_weatherSimulation
	Line 13: _interval = round(getNumber (configFile >> "CfgSettings" >> "Weather" >> "interval") * 60);
	Line 14: _keyframes = getArray (configFile >> "CfgSettings" >> "Weather" >> "keyframes");
	Line 16: _keyframeConfig = configFile >> "CfgSettings" >> "Weather" >> _keyframeName;

Should still be loaded :P

So is this now a client side weather system or can we still force that wonderful arma sunshine? 

Share this post


Link to post
Share on other sites
  • 0

Personally I know it's not working because I disabled rain and it still rains.  

 

Is is there there still a bug tracker for the 0.9.4 because I'll report it there I guess. I went to 0.9.4 pretty quickly.  

Even my loot tables are different from stock vanilla new exile install and the ones in the loot compiler.

getting frustrated with the update and the things I think it broke yet no tracking or ticket system.  Thought there was one but it should be a main link off the exile site.

 

-Goonie

Share this post


Link to post
Share on other sites
  • 0

When overcast is above 0.4 it still rains even if rain is set to 0. Just lower overcast in server settings.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.