• 0
Spartan

Strange Player Bug

Question

I had a strange incident today where a player placed a territory flag and went to build and was notified he was in enemy territory. So, he disconnected and reconnected to see if that would help and he loaded in on an island in the middle of nowhere and couldn't do anything. I check him in the player DB and everything looked fine, he wasn't dead and his recorded position was near his flag, not on the island. I wasn't able to figure out how to help him except by deleting him from the player table and having him fresh spawn.

Here are some selections I found in the server log that may be related:

18:52:56 Exile_Construction_Flag_Preview: Flag - unknown animation source flag <-- placing his flag?

18:56:57 Warning: Cleanup player - person 2:3174 not found <-- right after he logged, i get this a lot after players log off, figured it was typical

Then when he re-logged:

18:57:20 Error in expression <m_Codelock",1]],[],13122,6624,17,6,""]]]>
18:57:20   Error position: <>
18:57:20   Error Missing ]
18:57:20 Error in expression <m_Codelock",1]],[],13122,6624,17,6,""]]]>
18:57:20   Error position: <>
18:57:20   Error Missing ]
18:57:20 Error in expression <eateGroup independent;
_player = _group createUnit ["Exile_Unit_Player", _positi>
18:57:20   Error position: <createUnit ["Exile_Unit_Player", _positi>
18:57:20   Error Type Any, expected Number
18:57:20 File exile_server\code\ExileServer_object_player_database_load.sqf, line 21

He tried relogging once or twice with the same error above and then this:

18:59:20 "ExileServer - Database Error: Error Incorrect Number of Inputs"
18:59:20 Error in expression <se_handleBig;
};
};
((_result select 1) select 0) select 0>
18:59:20   Error position: <select 0) select 0>
18:59:20   Error Generic error in expression
18:59:20 File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27
18:59:20 Error in expression <se_handleBig;
};
};
((_result select 1) select 0) select 0>
18:59:20   Error position: <select 0) select 0>
18:59:20   Error Generic error in expression
18:59:20 File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27

Had him try a few more times while I was watching the logs and the errors alternated between the two above.

Some relevant snips from the DB logs:

[18:59:20:294207 +00:-1] [Thread 2920] extDB2: SQL_CUSTOM_V2: Trace: UniqueID: 1 Input: hasAlivePlayer:
[18:59:20:294207 +00:-1] [Thread 2920] extDB2: SQL_CUSTOM_V2: Incorrect Number of Inputs: Input String hasAlivePlayer:
[18:59:20:294207 +00:-1] [Thread 2920] extDB2: SQL_CUSTOM_V2: Incorrect Number of Inputs: Expected: 1 Got: 0
[18:59:20:294207 +00:-1] [Thread 2920] extDB2: Output to Server: [0,"Error Incorrect Number of Inputs"]

and

[18:58:47:245317 +00:-1] [Thread 2920] extDB2: Input from Server: 0:463809:hasAlivePlayer:UID
[18:58:47:245317 +00:-1] [Thread 2920] extDB2: SQL_CUSTOM_V2: Trace: UniqueID: 1 Input: hasAlivePlayer:UID
[18:58:47:312321 +00:-1] [Thread 2920] extDB2: SQL_CUSTOM_V2: Warning: Number of Output Options: 1, Number of SQL Columns: 0, this warning only exists in Debug Version. Its just to let you know of a possible mistake
[18:58:47:312321 +00:-1] [Thread 2920] extDB2: SQL_CUSTOM_V2: Trace: UniqueID: 1 Result: [1,[[true]]]
[18:58:47:312321 +00:-1] [Thread 2920] extDB2: Output to Server: [1,[[true]]]

FYI. If anyone knows of a fix for this, please let me know. Otherwise, I'll just keep an eye out.

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Can confirm this happens on our servers. No idea whats causing it.

Share this post


Link to post
Share on other sites
  • 0

There will be an error usually under hitpoints or loaded_magazines look at the end like ["muzzle_snds_338_black","","optic_Arco","bipod_01_F_blk" there should be a ]. I think for people that did the manual update for the db are having this issue. I think there must be an error somewhere in the db.

Edited by prue420

Share this post


Link to post
Share on other sites
Advertisement
  • 0
37 minutes ago, prue420 said:

There will be an error usually under hitpoints or loaded_magazines look at the end like ["muzzle_snds_338_black","","optic_Arco","bipod_01_F_blk" there should be a ]. I think for people that did the manual update for the db are having this issue. I think there must be an error somewhere in the db.

Exactly, the hit-points get corrupted. 

Share this post


Link to post
Share on other sites
  • 0
27 minutes ago, John said:

No idea, I wouldnt mind the devs chiming in on this with an official fix though

Well, people in this thread are saying it's a hit points problem and that's a fix for a hit points bug, so I'd say that's probably it.

Share this post


Link to post
Share on other sites
  • 0

can you paste a database record of the player in question. 

 

SELECT * FROM player WHERE account_uid=INSERTIDHERE

http://www.exilemod.com/topic/8654-bug-fix-for-character-creation-timeout-hitpoints/
That fix is for when hitpoints don't save correctly to the database, causing player timeout requests. It also reduces the character count from over 255 to 211. If it was over 255 it would cause a error, breaking the player data. Now that i limited it to 211 characters this error no longer exists

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, Jamie said:

can you paste a database record of the player in question. 

 


SELECT * FROM player WHERE account_uid=INSERTIDHERE

http://www.exilemod.com/topic/8654-bug-fix-for-character-creation-timeout-hitpoints/
That fix is for when hitpoints don't save correctly to the database, causing player timeout requests. It also reduces the character count from over 255 to 211. If it was over 255 it would cause a error, breaking the player data. Now that i limited it to 211 characters this error no longer exists

I deleted the players in question because I wasn't aware of this fix so I don't have the data available.

Share this post


Link to post
Share on other sites
  • 0

Okay, most likely more than 1 player in your database will still have the problem, so you will need to reset there player character (delete the record) and apply my fix as soon as possible to help prevent data corruption in the future.

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.