• 0
Sign in to follow this  
Followers 0
Adec

Trader Protection wears off

Question

Hey guys

So apparently our trader zones stop working randomly. When i enter a zone, it tells me I'm in a safezone, but after som time it states that I'm leaving the safezone, even tho I'm still there.

Here's my Sensor

Spoiler

class Item0
        {
            position[]={11313.081,21.619844,17887.918};
            a=200;
            b=200;
            activationBy="ANY";
            repeating=1;
            interruptable=1;
            age="UNKNOWN";
            name="DugeSeloTrader";
            expCond="(vehicle player) in thisList";
            expActiv="call ExileClient_object_player_event_onEnterSafezone";
            expDesactiv="call ExileClient_object_player_event_onLeaveSafezone";
            class Effects
            {
            };
        };

Anyone know how i can fix this? It also seems that the trader zone I've added doesn't match the actual place in the editor.

For example: One of my trader zones is 120 in diameter; as is my trigger. But it seems the trigger is not working in the full 120 when I'm on the server, running in and out of the trader.

Kind regards

Edited by Adec

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

There are no more sensors since 094. You need to remove them and just use a marker with type="ExileTraderZone"

Share this post


Link to post
Share on other sites
  • 0

Here are my settings for a custom trader zone. Hope this helps.

 

		class Item21
		{
			position[]={13260.645,73.596573,21314.902};
			name="NorthWildernessTrader";
			text="North Wilderness Trader";
			markerType="ELLIPSE";
			type="ExileTraderZone";
			colorName="ColorBlue";
			fillName="SolidBorder";
			a=175;
			b=175;
			drawBorder=1;
		};

 

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Thanks guys. I won't be able to edit my mission until after Christmas. I'll let you know how it turns out. 

Share this post


Link to post
Share on other sites
  • 0

Always use the new version of the files and modify them. Never use the old files, unless you run a compare on both stock files and find they are exactly the same. That way you can avoid situations like that.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.