kiri: arma3 server kenntnisse?

Bambi creation error

8 posts in this topic

after updating to clementine i am getting the following error in my rpt and new players are stucked at bambi creation error:

22:48:10 Error in expression <llExtension _query);
(_result select 1) select 0>
22:48:10   Error position: <select 0>
22:48:10   Error Generic error in expression
22:48:10 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16

Share this post


Link to post
Share on other sites

search is your friend.

Did you update @ExileServer\extDB\sql_custom_v2\exile.ini  ??

Share this post


Link to post
Share on other sites
Advertisement

i already searched all the threads in here and nothing helped...and yes i did update the exile.ini from the clementine download file....

 

if i add the player manually over the database with his uid and his nick, than they can join, but if i dont, they are stuck in bambi creation error? anyone know a solution for this? would donate to the person u can help me

Edited by kiri: arma3 server kenntnisse?

Share this post


Link to post
Share on other sites

SOLUTION (at least for me...)

It has something to do with the mysql sql_mode and the basic installation...

I set in the my.cnf the value to sql_mode ="" (after having NO sql_node setting in my my,cnf) and checked with the SQL statement SELECT @@GLOBAL.sql_mode; (i used phpmyadmin for that)... Answer ---> NOTHING SET. So i thought, all fine... Thats where i started to find a solution and finally i posted this thread - the bambi timed out all the time...

So what di i try? Search longer... and i found one thread saying to set to sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION".. I did that... I checked with SELECT... and modes changed... I checked with the server.. AND I HAVE A Bambi - i can PLAY

But i wanted to know the reason.. i set sql_mode="" again... I looked to SELECT @@GLOBAL.sql_mode; and i found some entries... it was not empty...

However, make sure:

- have an updated database (see install exilsever sql-files)

- have an UPDATED exile.ini (!!!)

- have your mysql-sever set to sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION" (at least on linux sql_mode="" was not working...)

- may be CBA mod disabling might be useful.

 

Have fun playing.

rumpelstill.

 

thanks to the guys on this thread: http://www.exilemod.com/topic/147-bambi-creation-timeout/

 

 

Hi all,

i can confirm this behaviour. running a complete new exile sever (linux @exilsever + @exil downloaded from epochmod yesterday) new extdb 0.70 - (also with 0.69 there is the same problem). Server Debian 8. fresh mysql 5.7 db, complete empty. updated sqls, updated exil.ini. NO CBA.

18:02:27 Error in expression <llExtension _query);
(_result select 1) select 0>
18:02:27   Error position: <select 0>
18:02:27   Error Generic error in expression
18:02:27 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16
18:02:27 Error in expression <llExtension _query);
(_result select 1) select 0>
18:02:27   Error position: <select 0>
18:02:27   Error Generic error in expression
18:02:27 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16
18:03:07 Client: Remote object 3:0 not found


So its the same - so bambi creation wont work... What are we doing wrong? If someone from the dev wants to help - im open for all. no solutions from the threads, no cba, no old files, no old exil.ini...

:(

rumpelstill.

 

edit - Code of the Extension_query:

private["_parameters","_query","_result"];
_parameters = _this;
_query = [0, ExileServerDatabaseSessionId, _parameters] joinString ":";
_result = call compile ("extDB2" callExtension _query);
(_result select 1) select 0

In the account table, the userinformation is added/updated. so extDB2 seems to work at least for the insert/update account.

Edited by rumpelstill

Share this post


Link to post
Share on other sites
On 12/26/2015 at 7:05 PM, rumpelstill said:

SOLUTION (at least for me...)

It has something to do with the mysql sql_mode and the basic installation...

I set in the my.cnf the value to sql_mode ="" (after having NO sql_node setting in my my,cnf) and checked with the SQL statement SELECT @@GLOBAL.sql_mode; (i used phpmyadmin for that)... Answer ---> NOTHING SET. So i thought, all fine... Thats where i started to find a solution and finally i posted this thread - the bambi timed out all the time...

So what di i try? Search longer... and i found one thread saying to set to sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION".. I did that... I checked with SELECT... and modes changed... I checked with the server.. AND I HAVE A Bambi - i can PLAY

But i wanted to know the reason.. i set sql_mode="" again... I looked to SELECT @@GLOBAL.sql_mode; and i found some entries... it was not empty...

However, make sure:

- have an updated database (see install exilsever sql-files)

- have an UPDATED exile.ini (!!!)

- have your mysql-sever set to sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION" (at least on linux sql_mode="" was not working...)

- may be CBA mod disabling might be useful.

 

Have fun playing.

rumpelstill.

 

thanks to the guys on this thread: http://www.exilemod.com/topic/147-bambi-creation-timeout/

 

 

Hi all,

i can confirm this behaviour. running a complete new exile sever (linux @exilsever + @exil downloaded from epochmod yesterday) new extdb 0.70 - (also with 0.69 there is the same problem). Server Debian 8. fresh mysql 5.7 db, complete empty. updated sqls, updated exil.ini. NO CBA.

18:02:27 Error in expression <llExtension _query);
(_result select 1) select 0>
18:02:27   Error position: <select 0>
18:02:27   Error Generic error in expression
18:02:27 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16
18:02:27 Error in expression <llExtension _query);
(_result select 1) select 0>
18:02:27   Error position: <select 0>
18:02:27   Error Generic error in expression
18:02:27 File exile_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16
18:03:07 Client: Remote object 3:0 not found


So its the same - so bambi creation wont work... What are we doing wrong? If someone from the dev wants to help - im open for all. no solutions from the threads, no cba, no old files, no old exil.ini...

:(

rumpelstill.

 

edit - Code of the Extension_query:

private["_parameters","_query","_result"];
_parameters = _this;
_query = [0, ExileServerDatabaseSessionId, _parameters] joinString ":";
_result = call compile ("extDB2" callExtension _query);
(_result select 1) select 0

In the account table, the userinformation is added/updated. so extDB2 seems to work at least for the insert/update account.

I just had this same problem with Debian, and I removed @CBA mod and it worked. 

Share this post


Link to post
Share on other sites

Removing cba isnt an option for me because im using other mods.  Unfortunately my hosting company doesnt allow me direct access to change anything on the sql server (unless im missing something).  They said they have changed the parameters as described above but to no avail.  Still getting the same Line 16 error when someone new joins the server.  Does anyone have a fix?

Share this post


Link to post
Share on other sites

Posted (edited)

7 hours ago, TommyGavin said:

Removing cba isnt an option for me because im using other mods.  Unfortunately my hosting company doesnt allow me direct access to change anything on the sql server (unless im missing something).  They said they have changed the parameters as described above but to no avail.  Still getting the same Line 16 error when someone new joins the server.  Does anyone have a fix?

What mods do you use that require CBA?

Im using CUP, which apparently only uses the old ASDG_JR which was recently added to CBA.

My soultion:  Replaced CBA server-side with ASDG_JR.

Clients can now connect with either CBA or ASDG_JR enabled.

Hope this helps!  :)

 

If the above simple solution doesn't work for you, try the solution at the end of the following thread, it has worked for others:

 

Edited by papagramps

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.