Akku

Help in Launching Via VB

8 posts in this topic

Hello guys 

I was trying to launch arma via small VB launcher managed to launch game but not mods (may be dir contains spaces) 

a example of arma2 is given same is not working for exile arma3

 Process.Start("steam://rungameid/33930// -cpucount=4 -exthreads=4 -maxmem=2047 -maxvram=2047 -nosplash -skipintro -nofilepatching -mod=E:\Games\SteamLibrary\SteamApps\common\Arma 2;F:\games\arma mods\@DayZ -connect=178.32.49.114 -port=2302")

any kind of help is appreciated 

Share this post


Link to post
Share on other sites

steam://run/107410//-connect=5.39.72.122%20-port=2400%20-mod=@Exile;@CUP_Weapons;@ASDG_JR;@NATO_Rus_Vehicle;@allinarmaterrainpack;%20-nosplash%20-world=empty%20-nopause%20-noLauncher%20-useBE

Share this post


Link to post
Share on other sites
Advertisement

dont start it like that try something like this 

a2path = (String)Registry.GetValue(@"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\bohemia interactive studio\ArmA 2 OA", "main", "");

this will for example find the folder for arma 2 oa(you have to change it arma3 ofcourse) and then you can just start the arma3battleye.exe with the following mods you are using

Edited by yellow|avdieking

Share this post


Link to post
Share on other sites

Still not loading mods properly for arma2 example :(

Thanks @yellow|avdieking for this try 

@cen i guess had to wait for @choppra to get online and reply me i tried whole day 

 

 

Share this post


Link to post
Share on other sites

Take a look at this www.exilemod.com/topic/1510-lightweight-exile-downloader-and-arma-3-launcher/ (code is open)

direct link to game starting stuff https://github.com/Jan18101997/Exile-Launcher/blob/master/Exile%20Launcher/GUI/Pages/pageMainMenue.xaml.cs#L146  ( AppSettings.getPropertyValue<string>("GamePath") = Arma3 Install dir e.g. C:\Program Files (x86)\Steam\SteamApps\common\Arma 3)

Share this post


Link to post
Share on other sites
19 hours ago, yellow|avdieking said:

can you send me your project?

can do that but its not working yet

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.