• 0
Banzak

extDB2: Error Invalid Format: 9:ADD_DATABASE_PROTOCOL:exile:SQL_CUSTOM_V2:558715:exile

Question

Hello,

can anybody help my with that issue?
 

my extDB-log:

extDB2: Version: 70
extDB2: https://github.com/Torndeco/extDB2
extDB2: Linux Version
Message: All development for extDB2 is done on a Linux Dedicated Server
Message: If you would like to Donate to extDB2 Development
Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2
Message: Also leave a message if there is any particular feature you would like to see added.
Message: Thanks for all the people that have donated.
Message: Torndeco: 20/02/15


extDB2: Found extdb-conf.ini
extDB2: Detected 4 Cores, Setting up 4 Worker Threads


[20:59:13 +01:00] [Thread 3346] extDB2: Database Type: MySQL
[20:59:13 +01:00] [Thread 3346] extDB2: Database Session Pool Started
[20:59:13 +01:00] [Thread 3346] extDB2: SQL_CUSTOM_V2: Loading Template Filename: /home/steam/steamcmd/arma3/@exileserver/extDB/sql_custom_v2/exile.ini
[20:59:13 +01:00] [Thread 3346] extDB2: SQL_CUSTOM_V2: Version 12 Detected, Latest Version 12 Available
[20:59:17 +01:00] [Thread 3346] extDB2: Error Invalid Format: 9:ADD_DATABASE_PROTOCOL:exile:SQL_CUSTOM_V2:818027:exile
[20:59:17 +01:00] [Thread 3346] extDB2: Error Invalid Format: 9:SHUTDOWN
[20:59:17 +01:00] [Thread 3346] extDB2: Error Invalid Format: 9:SHUTDOWN

my server-log:

20:59:21 "ExileServer - Installed extDB2 version: 70"
20:59:21 "ExileServer - Connected to database!"
20:59:21 "ExileServer - MySQL connection error!"
20:59:21 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
20:59:21 "ExileServer - MySQL Error: Failed to initialize database protocol: [0,"Error Invalid Format"]"
20:59:21 "ExileServer - Server will shutdown now :("

Thank you!

 

Regards

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

Could you show us your extdb config? (Obviously hide the password)

Also can you double check you have the extDB folder in your exile server folder, which would have the sql_custom_v2 folder in it, then the exile.ini folder within that.

Finally, make sure you have imported the exile.sql file into your database. You have to do this manually, you will need to install a program like phpmyadmin on your server. 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Thank you for your reply. I found the error myself, taking a closer look into the server-log:

  • ExileServer_object_tree_network_chopTreeRequest
  • ExileClient_object_item_craft

I forgot to put this two files into my mission.pbo.

Regards

Edited by Banzak

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, Banzak said:

Thank you for your reply. I found the error myself, taking a closer look into the server-log:

  • ExileServer_object_tree_network_chopTreeRequest
  • ExileClient_object_item_craft

I forgot to put this two files into my mission.pbo.

Regards

Ah yes, the emergency fix.


Glad you have it working :) 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.