• 0
TheSurvivor | trade.tf

[SOLVED] Older Exile Version?


Could anyone send me a version of exile that would work with 1.52 I would like to join the TNA servers but the mods says i have the wrong mod for said arma version?

Share this post

Link to post
Share on other sites

1 answer to this question

This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.