kidesh

Trade zone buildings duplicating.

10 posts in this topic

Hi

I have recently swapped my map from Altis to Chernarus and I have made all my own spawn points and traders.

Everything was fine just a few ups and down and nothing I couldn't fix. But now that I am read to go I have noticed that my trader buildings like my containers and signs and miscellaneous stuff start to duplicate not just once but alot. It's got to the point that I need to sit in the traders and delete them.

I run infistar but I switched that off and it still happens. 

I have checked my init file for building and it only has 1 item per object. But even if I had 2 items per object it would not be the reason why stuff duplicates constantly. 

Any help would be great here and if anyone has the same problem then maybe we can try fix together.

 

Thx

Share this post


Link to post
Share on other sites
Advertisement

In my init player local. Sqf I had 

#include "init Server.sqf"

When I should of had 

//#include "init Server. sqf"

 

Don't know how this done this. Put its a simple fix. 

Share this post


Link to post
Share on other sites

#include "initServer.sqf" is commented out on my initPlayerLocal.sqf and I still get crazy amounts of duplicates in trade zones. When I log in shit just goes flying through the air. xD  I didn't setup my server until after the update so the line was already commented out.  Just for reference I'm running a few weapon and vehicle packs, R3F logistics, custom trader configs (just adding weapons and vehicles from other mods), XM8 apps/view distance, and infiSTAR. RPT is clean. As far as buildings spawning on the map I have made no changes. Any insight on this would be greatly appreciated.

 

Thanks in advance, Dirty

Share this post


Link to post
Share on other sites
12 minutes ago, oSoDirty said:

#include "initServer.sqf" is commented out on my initPlayerLocal.sqf and I still get crazy amounts of duplicates in trade zones. When I log in shit just goes flying through the air. xD  I didn't setup my server until after the update so the line was already commented out.  Just for reference I'm running a few weapon and vehicle packs, R3F logistics, custom trader configs (just adding weapons and vehicles from other mods), XM8 apps/view distance, and infiSTAR. RPT is clean. As far as buildings spawning on the map I have made no changes. Any insight on this would be greatly appreciated.

 

Thanks in advance, Dirty

I am running very similar mods and i also have shit floating up in the air, only trader objects like crates ect.

Share this post


Link to post
Share on other sites
13 hours ago, oSoDirty said:

#include "initServer.sqf" is commented out on my initPlayerLocal.sqf and I still get crazy amounts of duplicates in trade zones. When I log in shit just goes flying through the air. xD  I didn't setup my server until after the update so the line was already commented out.  Just for reference I'm running a few weapon and vehicle packs, R3F logistics, custom trader configs (just adding weapons and vehicles from other mods), XM8 apps/view distance, and infiSTAR. RPT is clean. As far as buildings spawning on the map I have made no changes. Any insight on this would be greatly appreciated.

 

Thanks in advance, Dirty

 

13 hours ago, Tuna said:

I am running very similar mods and i also have shit floating up in the air, only trader objects like crates ect.

 

 

I'm not sure why you guys are having this problem but i fixed it by making  #include "init Server.sqf"  with  //#include "init Server.sqf" and it sorted it.

This is the start of my initserver.sqf 

 

///////////////////////////////////////////////////////////////////////////////
// Static Objects
///////////////////////////////////////////////////////////////////////////////
//#include "initServer.sqf"
[] execVM "addons\statusBar\statusbar.sqf";
if (!hasInterface || isServer) exitWith {};

///////////////////////////////////////////////////////////////////////////
// Hardware Trader
///////////////////////////////////////////////////////////////////////////
_workBench = "Land_Workbench_01_F" createVehicleLocal [0,0,0];
_workBench setDir 109.556,0,0;
_workBench setPosATL [6382.72,7791.74,0];

[
    "Exile_Trader_Hardware",
    "WhiteHead_17",
    ["InBaseMoves_sitHighUp1"],
    [0, 0, -0.5],
    289.956,
    _workBench
]
call ExileClient_object_trader_create;

 

Share this post


Link to post
Share on other sites
13 hours ago, Tuna said:

I am running very similar mods and i also have shit floating up in the air, only trader objects like crates ect.

Make sure '#include initServer.sqf is commented out in your 'initPlayerLocal.sqf at the top of the file.

InitServer.sqf is loaded at server startup (this loads the trader objects) so if you have it uncommented in your initPlayerLocal.sqf it will reload the file each time a player joins the server thus duplicating all the trader objects

Share this post


Link to post
Share on other sites

Mine is the same. That's what I meant by commented out. Still duplicates.

Share this post


Link to post
Share on other sites

Not sure then buddy when this normaly happens it's because of that.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.