Sign in to follow this  
Followers 0
Adec

Community Vehicle Trader

5 posts in this topic

Hey guys

I'm trying to create a second vehicle trader, by using a community trader, but when i try to trade ingame, it's the "Normal" menu showing up - Not the vehicle one.
Here's my settings:

Class (what vehicles are in my category)

Spoiler

class Gokart
    {
        name = "Gokarts";
        icon = "a3\ui_f\data\gui\Rsc\RscDisplayArsenal\itemacc_ca.paa";
        items[] = 
        {
            "Exile_Car_Kart_BluKing",
            "Exile_Car_Kart_RedStone",
            "Exile_Car_Kart_Vrana",
            "Exile_Car_Kart_Green",
            "Exile_Car_Kart_Blue",
            "Exile_Car_Kart_Orange",
            "Exile_Car_Kart_White",
            "Exile_Car_Kart_Yellow",
            "Exile_Car_Kart_Black"
        };
    };

Class (What category)

Spoiler

class Exile_Trader_CommunityCustoms2
    {
        name = "GOKART";
        showWeaponFilter = 0;
        categories[] = 
        {
            "Gokart"
        };
    };

Trader

Spoiler

[
    "Exile_Trader_CommunityCustoms2",
    "WhiteHead_10",
    ["HubStanding_idle2", "HubStanding_idle3"],
    [2190.76,7108.12,0],
    345
]
call ExileClient_object_trader_create;

I'm not sure what I'm doing wrong, hopefully you guys can help me.

Edited by Adec

Share this post


Link to post
Share on other sites

is Exile_Trader_vehicle2 even a trader class?? I dont think so.

You need to use Exile_Trader_Communitycustoms 1,2,3,4 etc 

These are already defined in your config.cpp

transfer all your information to one of them and you should be fine

Share this post


Link to post
Share on other sites
Advertisement
5 minutes ago, John said:

is Exile_Trader_vehicle2 even a trader class?? I dont think so.

You need to use Exile_Trader_Communitycustoms 1,2,3,4 etc 

These are already defined in your config.cpp

transfer all your information to one of them and you should be fine

I did that as a start, same thing happened. Reason i changed to  Exile_Trader_vehicle2  was simply to try something else.

Edit: Changed 1st post to something I've already tried too

Edited by Adec

Share this post


Link to post
Share on other sites

I've tried this in the past with the same results.

so far as I can tell this isn't currently possible.

 

I'm hoping someone can prove me wrong!

Share this post


Link to post
Share on other sites

It seems that it has to be specified as a vehicle trader where my players can Purchase Vehicle - instead of just being a trader.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.