• 0
Sign in to follow this  
Followers 0
YetiBlood

Database Deletes all base objects and vehicles on restart

Question

Hi, Im hoping someone out there can help us out. we have an exile server and on every restart all the player base items and their vehicles get deleted. The items are placed in the database and are there before restart. ive tried serval things already, fresh db install being the last thing i tried. im stumped. if someone can help out much appreciated. 

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Posted (edited)

Quote
On 1/2/2016 at 10:04 PM, GR8 said:

Try these Different things :

  • See it still happens with a fresh DB 
  • See if it still happens with fresh vanilla files.
On 1/2/2016 at 9:49 PM, wik said:

When was their last protection payment?  Do you have protection set to the default?  I think 3 days on cars and 5 days on flags is the default.

This was Missing from exile_server_config\config.cpp


class Database 
		{
			// Remove all territories (and contructions + containers in it) that were not paid after X days
			territoryLifeTime = 7;

			// Remove all containers outside of territories that have not been used for X days
			// Example: Tents
			containerLifeTime = 7;

			// Remove all constructions outside of territories that are older than X days or not moved for X days 
			// Example: Work Benches
			constructionLifeTime = 2;

			// Remove all vehicles that were not moved/used for X days
			vehicleLifeTime = 7;
		};

 

Thank you both, it ended up being a combination of both of these things. my config.cpp in server.pbo was outdated and didn't have the territory configs actually set up in there among other things on closer inspection lol. Up and running now. :)!!!!!!

Edited by YetiBlood
1 person likes this

Share this post


Link to post
Share on other sites
  • 1

Can you Post your extDB logs ?

Share this post


Link to post
Share on other sites
Advertisement
  • 1

this doesn't appear to be helpfull... i did notice that the db was intact before the player connected, and as soon as they loaded it everything dissapeared. 

Quote

extDB2: Version: 70
extDB2: https://github.com/Torndeco/extDB2
extDB2: Windows Version
Message: All development for extDB2 is done on a Linux Dedicated Server
Message: If you would like to Donate to extDB2 Development
Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2
Message: Also leave a message if there is any particular feature you would like to see added.
Message: Thanks for all the people that have donated.
Message: Torndeco: 20/02/15


extDB2: Found extdb-conf.ini
extDB2: Detected 10 Cores, Setting up 6 Worker Threads


[21:42:15:610857 --4:00] [Thread 5040] extDB2: Database Type: MySQL
[21:42:15:622611 --4:00] [Thread 5040] extDB2: Database Session Pool Started
[21:42:15:624206 --4:00] [Thread 5040] extDB2: SQL_CUSTOM_V2: Loading Template Filename: C:\TCAFiles\Users\gabriela\11\@ExileServer\extDB\sql_custom_v2\exile.ini
[21:42:15:624354 --4:00] [Thread 5040] extDB2: SQL_CUSTOM_V2: Version 12 Detected, Latest Version 12 Available

 

Share this post


Link to post
Share on other sites
  • 0

i have the same issue...i cant find a fix..Gr8 please help..it would save alot of people stress!!!!!!

Share this post


Link to post
Share on other sites
  • 0

When was their last protection payment?  Do you have protection set to the default?  I think 3 days on cars and 5 days on flags is the default.

 

 

 

Share this post


Link to post
Share on other sites
  • 0

Try these Different things :

  • See it still happens with a fresh DB 
  • See if it still happens with fresh vanilla files.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.