Freece

@Exile not found

12 posts in this topic

Posted (edited)

Hello all,

So I have been trying to set up another Arma3 server with Exile this time, but to no avail. I am running Debian 8 on a dedicated machine at home. It works to set up a vanilla server.

For some reason the server won't find the @exile mod. I have seen several people with the same problem, but none of their solutions worked for me. I am running the latest version of Exilemod and i have applied the emergency fix.

I am getting this in the console:

22:30:45 ============================================================================================= List of mods ===============================================================================================
22:30:45 modsReadOnly = true
22:30:45 safeModsActivated = false
22:30:45 customMods = true
22:30:45 hash = '610C3FBA5792AD2FE0F216CECBEBFE404680AC72'
22:30:45 hashShort = '241c7f96'
22:30:45                                               name |               modDir |    default |               origin |                                     hash | hashShort | fullPath
22:30:45 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
22:30:45                                                    |                      |      false |            NOT FOUND |                                          |           | 
22:30:45                                  Arma 3 DLC Bundle |            dlcbundle |       true |            NOT FOUND |                                          |           | 
22:30:45                                    Arma 3 Marksmen |                 mark |       true |             GAME DIR | a3cb8bd430002971f7ecedb65aca970ce6a3e880 |  3021f00c | /home/steam/arma3/mark
22:30:45                                 Arma 3 Helicopters |                 heli |       true |             GAME DIR | 21385ab46a1a725af129e211d3a9f73b047d1c83 |  5c1dd0e0 | /home/steam/arma3/heli
22:30:45                                       Arma 3 Karts |                 kart |       true |             GAME DIR | fc0cb7d662348d9651bfc620aff863ad545e0346 |  4bdcb8a9 | /home/steam/arma3/kart
22:30:45                                        Arma 3 Zeus |              curator |       true |             GAME DIR | 352756ce4c2c2b788be47fb754e3426ef3b8ba3d |  c6890f55 | /home/steam/arma3/curator
22:30:45                                             Arma 3 |                   A3 |       true |            NOT FOUND |                                          |           | 
22:30:45 ==========================================================================================================================================================================================================

And

22:30:49 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.exile_client
22:30:49 Mission Exile.Altis read from bank.
22:30:49 Missing addons detected:
22:30:49   exile_client

 

I followed this guide to install Exile as well as looking at a few others, just gathering information.

I have set all files and folders in the mods to lowercase and my startup script is the following:

#!/bin/bash
svCfgDir="/home/steam/arma3/\@exileserver"
netCfg="$svCfgDir/basic.cfg"
svCfg="$svCfgDir/config.cfg"
mods="\@exile\;"
serverMods="\@exileserver\;"
bepath="/home/steam/arma3/battleye"

./arma3server -cfg="netCfg" -config="$svCfg" -mod="$mods" -servermod="$serverMods" -port 2302 -bepath="$bepath" -noSound -autoinit

According to some people, it helped to add the \ in front of the @ of the mod names, but it makes no difference here.

I have also downloaded the extdb2.so for the linux version server and placed it in the @exileserver directory.

Any help is welcome!

Thanks,

Freece

Edited by Freece

Share this post


Link to post
Share on other sites

You either don't have @Exile in your launch parameters or you simply don't have @Exile at all. 

Share this post


Link to post
Share on other sites
Advertisement

lowercase your files on linux in your @exile directory

Share this post


Link to post
Share on other sites
2 minutes ago, wasti said:

lowercase your files on linux in your @exile directory

Please at least pretend to have read my description.

Share this post


Link to post
Share on other sites

Posted (edited)

I skimmed it ;P

also your missing your entire a3 folder, so ya know, that could be causing this seeing as that's most of the game....


also change
mods="\@exile\;"
serverMods="\@exileserver\;"

to
mods="\@exile"
serverMods="\@exileserver"

Edited by wasti

Share this post


Link to post
Share on other sites

Posted (edited)

6 minutes ago, wasti said:

mods="\@exile\;"
serverMods="\@exileserver\;"

to
mods="\@exile"
serverMods="\@exileserver"

 

Ok, fixed this now, but no difference.

6 minutes ago, wasti said:

also your missing your entire a3 folder

I did notice this, and it is very odd! I don't know why it says that, since the vanilla server worked.

Also thanks for answers! :D

Edited by Freece

Share this post


Link to post
Share on other sites

I could be wrong, but I think that the vanilla will run without most of the folders, but exile is dependent on some of the files there, could be causing issue.

Honestly I would just fire up steamCMD and run app_update 233780 validate

Share this post


Link to post
Share on other sites

I was thinking just the same thing, so I just did that, validated 100%.

Share this post


Link to post
Share on other sites

Posted (edited)

chmod -R 777 @exile
chmod -R 777 @exileserver


in terminal in your arma directory.

Edited by wasti

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.