Search the Community

Showing results for tags 'headless client'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Exile
    • Changelogs
    • Feedback
  • Exile Community
    • General Discussion
    • New Feature Voting
    • Problems & Bugs
    • Cat Walk
    • Recruitment
    • Small Talk
  • Exile Mod XM8 App
    • XM8 Server Administration
    • XM8 Android App
    • XM8 Discord Bot
  • Exile Mod Server Administration
    • Ask a Game Server Provider
    • Hosting
    • Operating Systems
    • Installation
    • Database
    • Security
    • Maintenance
  • Exile Mod Customization
    • Downloads & Releases
    • Content
    • Environment
    • Gameplay
    • Look & Feel
    • Tech Talk
  • Exile Life Mod
    • Visit forum on exilelifemod.com

Categories

  • Knowledge Base
  • Items
  • Constructions
  • Traders
  • Vehicles

Categories

  • Servers

Categories

  • Devblog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Homepage

Found 14 results

  1. What am I doing wrong. If I swap out the edited version and put in the base mission file exile.tanoa.pbo it works, but not with this one where I have a headless client. What have I done wrong? I've tried having it up as item 100 as well where it's ID was 101. Every time I start the server up, everything starts going but it pauses on the exile load screen and doesnt do the red load bar at top. It will sit there for well, i've waited 10 minutes so far before hitting escape. here is the .smq as created by mission editor by taking exile.tanoa.smq and placing the HC in it manually. What have I done wrong? Currently, I am not running @A3XAI (this is supposed to be in MODs right?) and @A3XAI_HC (in server mods right?). I wanted to see where the problem was coming from so little by little I've worked backwards. Problem also exists with the mods on in either combination of locations. Here is the most recent rqt I want to thank anyone willing to help me with this in advance. I've spent about 20 hours trying to set this up now and I'm getting pretty worn down by it (I've never tried this kinda thing before).
  2. What am I doing wrong. If I swap out the edited version and put in the base mission file exile.tanoa.pbo it works, but not with this one where I have a headless client. What have I done wrong? I've tried having it up as item 100 as well where it's ID was 101. Every time I start the server up, everything starts going but it pauses on the exile load screen and doesnt do the red load bar at top. It will sit there for well, i've waited 10 minutes so far before hitting escape. here is the .smq as created by mission editor by taking exile.tanoa.smq and placing the HC in it manually. What have I done wrong? Currently, I am not running @A3XAI (this is supposed to be in MODs right?) and @A3XAI_HC (in server mods right?). I wanted to see where the problem was coming from so little by little I've worked backwards. Problem also exists with the mods on in either combination of locations. Here is the most recent rqt I want to thank anyone willing to help me with this in advance. I've spent about 20 hours trying to set this up now and I'm getting pretty worn down by it (I've never tried this kinda thing before).
  3. JakeHekesFists

    AI Not moving (vemf / headless client)

    I currently have an issue with AI not moving around, using waypoints since Exile update to 1.0.3 I use a heavily modified VEMFr, It barely even resembles the original anymore. As such I am making this thread separate from the VEMF thread. Basically, I was wondering if one of the exile devs could respond to the following. 1. Has there been any changes made to "O_G_Sharpshooter_F" in the config which could prevent the AI from moving? 2. Have there been any changes made to the enableAI/disableAI commands 3. Is there any changes in this version which you think of which would prevent movement/waypoint commands being transferred to the headless client? Everything was working perfectly on exile 1.0.2, A3 1.70. Only encountered this issue after updating exile
  4. Hi Chris, Recently I attempted to update from v0069a to v0073 Updated as normal. Had an Issue with my headless client getting kicked repeatedly every 5 mins or so for being a "ghost player" too long Which then causes FuMS to stop working, of course. Ingame Logs http://imgur.com/DwEFkFG RPT shows this. 22:41:30 "<infiSTAR.de>SURVEILLANCELOG| headlessclient(HC7608) | Player is HeadlessClient_F for too long - either not correctly loaded in or trying to run around as a ghost (invisible player object) @002001 [276.308,15165.6,-0.00115967] | 0h 5min 8s [02-Mar-2017 23-49-34 - v0073]" For the time being, to hotfix the problem I have modified Exile_AH.sqf to add an additional check in before the kick. http://imgur.com/oG5Pw9a Test server has been up for 30 mins without kicking the headless client. Might be something to look out for in your next release. Thanks.
  5. Howdy folks, my name's BDC and I'm an active Arma scripter guy that's been writing small scripts and mods for the past several years since DayZ time. I've been writing code for Arma 3 for about three years now with much of it being focused on a campaign-level multiplayer mission (for Altis as well as variants for other maps) that's taken about 2 1/2 years to write and perfect. Since then, I've recently setup an Exile mod server and started writing things for it, which brings me to the point of this post. The reason for my post is about two things I've been working on; one of which I just today got working. I've called them 'Client ID Framework' and 'RZD Helper' respectively. A bit about the two: The Client ID Framework is a small set of eventhandlers that grab and log the owner/client ID's of both headless clients and players that log in that can be used for two-way acknowledgements and ultimately the offloading of spawned AI from one instance to another via setGroupOwner command. What initially brought me to writing it is a desire for my being able to run ExileZ w/ Ryan's Zombies and Demons on my own box but offload the AI to a headless client. I've modified ExileZ with a few additional configuration options where I tell it what headless client to offload AI to on-the-fly; not with a client ID or a configured name in the mission file, but rather literally by the number of the headless clients in the order they've connected to the server. I've verified that it works by log files that are configured to be turned on that show when units have been transferred over to a specific HC. On the second thing I wrote, it's something I've been working on for a couple of weeks now called RZD (for Ryan's Zombies and Demons) Helper that adds an additional behaviour script that runs for each locally owned Zed. The idea is to augment the existing zombie.sqf behaviour script in the default PBO package and add things like target acquisition, herd mentality, the ability to get around the large vehicle bounding box exploit (when a player hugs up against a plane and the zed can't hit you thing), as well as random roaming and even the ability to stealth around depending upon player stance and speed. I even take into account the use of firearms to attract zed over (or not, if the firing player or AI unit is using a suppressed weapon) as well as chemlights, smoke grenades, demolitions, and other explosives (grenades, RPG use, etc). I accomplish this by changing a few values in the ExileZ spawner routine to greatly reduce the ability of the standard zombie.sqf script to "Autodetect" players that are far away. So far, it's working well but likely needs more play time and perhaps some tweaking. My main question: Since I'm not an active Exile forum user or member of the community (I tend to keep to myself), would either of these be of interest to anyone? Or do things like this already exist and I'm merely just re-inventing the wheel? Thanks, B
  6. bustednuts

    Headless Client Setup

    I amm looking for help on what to do to set up a headless client for my servers. I have 2 VDS's that I rent and have 5 maps of exile running with a ton of mods. I am wanting to put a sarge ai for the roaming and dms for the mission system. I know there is alot of information out there.. But If asking in here to some one that has set on up and has these mission systems working with exile. I am also willing on paying someone for there time.
  7. Brit

    Hardstyle Exile Infection

    IP: 164.132.200.239 Port: 2302 This will be a public PVP-PVE server. SERVER FEATURES ✔ AI Headless Client All unit management offloaded to a headless client (HC) which improves AI responsiveness and overall server performance. The HC allows for more simultaneous missions and a larger number of concurrent AI spawns. ✔ FuMS: Fulcrum Mission System Several mission types including: town invasions, vehicle convoys, captives rescue, soldier patrols, and more traditional "AI guarding a crate" missions. Most missions spawn with a large group of AI. Zombie missions are currently enabled, with 60+ FPS. There is a group of helicopters that patrols the map. ✔ Custom Trade Cities There are 6 traders on the map - Zelenogorsk - Stary Sobor - Lumber Mill - Olsha and two other traders with one bandit. ✔ UI Customizations Kill Messages, Status Bar, Custom Map Markers. SERVER INFO - Server restarts are every 4 hours with warnings and server lock before restart. - Server logins are locked 3 minutes before restart. - New Exile releases: server will usually be updated within 2-4 hours. SERVER RULES - No racism or any other form of discrimination. There is zero tolerance. - No parking in safezones - vehicles are unlocked after server restart and considered FAIR LOOT. - There will be no compensation for lost vehicles or gear in trade zones (due to auto-unlocked vehicles). HOW TO CONNECT The following addons are required: ✔ Exile Mod ✔ CBA_A3 ✔ Extended Base Mod ✔ CUP - Vehicles - Weapons - Units ✔ Cherno Map ✔ Ryan's Zombies - The simplest way to obtain/update the required addons and connect to the server is A3 Launcher: a) In the "Mods" tab, download/subscribe* to the required addons listed above. b) Search for "Hardstyle Exile" in the "Servers" tab. c) When you click on the "Play" icon, the launcher will ensure all required addons are loaded. *Addon downloads will be placed in the folder specified in A3 Launcher settings. *Addon subscriptions are Steam Workshop content and will be managed by the Steam API. TROUBLESHOOTING - If you encounter issues and require support, please post in the www.HardstyleExile.com server forum or send a PM to BRIT - If you encounter a Battleye kick, the following info would be great to have: --> The full kick message (screenshot or text) --> Date and time of the kick PLANNED Infected areas (CUP Loot will be available if you succeed) KNOWN ISSUES Trader objects need work (Scheduled to be fixed on 22/05/2016
  8. Blacksheep

    @FuMS issues

    Hi folks, I configured for my server @FuMS and it seems to work (as per log). However: o No missions are spawning o The status bar disappeared Is it normal that I don't see the headless client connected in RCON? I posted all logs and ps -ef output in pastebin: http://pastebin.com/EhULEbPK Any help is really appreciated!
  9. To whom it may concern: Running a headless client on linux is buggy. You will observe failing signature checks when the client connects (the failing signature checks on FILES is a differnt issue, here you need to ensure that the keys for the hc and the refered *.pbo's are correct!). You may able to extend the time to the failing signature check to roundabout 150 minutes per my tests with starting the HC only with -cpuCount=1. As a workaround I am restarting the HC now every 150 minutes via cron job. I asked Dwarden@Arma3 if they are working on this and he told me they do. They are also discussing a server variable to disable the sig check for HC's only (sig checks for mods remains of course). Reference: https://forums.bistudio.com/topic/173767-dedicated-client-headless-client-feedback-dev-branch/?p=3004711
  10. Hello, I run the FuMS mission system which requires a headless client. Everything has been running great for months. A couple of weeks ago I tried updating infiSTAR from v0028 to the newest version which I think was v0030 at the time. I've done the update many times, I'm familiar with the process and haven't had issues in the past when updating infiSTAR. What's happening is this: Start up server Wait 2 minutes and then start up headless client Headless client connects to the server FuMS mission system starts and Missions/AI are spawned After about 30 seconds the Missions/AI disappear infiSTAR logs show the headless client disconnecting and connecting again at the time the Missions/AI disappear Server RPT and headless client RPT do not show a disconnect I thought maybe there was a bug in v0030, so I waited a while. I tried updating my infiSTAR again yesterday, this time to v0033. The issue persists. I setup a test server. Vanilla Altis Exile with no additional mods or addons. Installed infiSTAR v0028 and FuMS. Works flawlessly. Update infiSTAR to v0033, have the disconnect issue. Delete infiSTAR and re-install with stock settings only adding the server password, same result. There's no reason listed in the infiSTAR log why the headless client is disconnecting. You'll see in the attached screenshot the blue RemoteAI graph goes up, then suddenly drops off when the headless client is disconnected. 21-02-2016 10:19:55 infiSTAR.de | #0 Connected: __SERVER__() ID: 2 [UpTime: 0h 0min 0s | - ServerFPS: 0.773881] (v0033) 21-02-2016 10:21:38 infiSTAR.de | #0 Connected: headlessclient(HC1480) ID: 3 SteamName: [UpTime: 0h 1min 43s | - ServerFPS: 45.4545] (v0033) 21-02-2016 10:23:29 infiSTAR.de | #0 Disconnected: headlessclient(HC1480) ID: 3 SteamName: [UpTime: 0h 3min 27s | - ServerFPS: 45.1977] (v0033) 21-02-2016 10:23:32 infiSTAR.de | #0 Connected: headlessclient(HC1480) ID: 3 SteamName: [UpTime: 0h 3min 30s | - ServerFPS: 45.4545] (v0033) 21-02-2016 10:26:02 infiSTAR.de | #0 Disconnected: headlessclient(HC1480) ID: 3 SteamName: [UpTime: 0h 5min 60s | - ServerFPS: 46.1095] (v0033) 21-02-2016 10:26:06 infiSTAR.de | #0 Connected: headlessclient(HC1480) ID: 3 SteamName: [UpTime: 0h 6min 4s | - ServerFPS: 46.7836] (v0033) Because the server RPT and headless client RPT do not show an actual disconnect from the server, I'm assuming that infiSTAR is kicking it to the lobby and then it's reconnecting. Any help would be appreciated.
  11. On4fox

    HC start problems

    Hello, i just started reading into the headless client. I know all the controversity about it but i would love to give it a shot myself. So i got my self a working local Server. Now when i start the hc with all the needed mods for the mission its running but the logfile is just not complete and the HC is not working as it should. If i start the HC with a mod missing the mission is "loaded" and throws some errors. Despite the fakt that now the HC seems to run longer( since there is more in the log). It can't be fully functional without the missing mods. Here is the start param for the first try and the rpt log: start "HC" "arma3server.exe" -client -connect=127.0.0.1 -port=2302 -mod="@allinarmaterrainpack;@Ryanzombies;@Exile;@zombies_hc;" -nosound -name=HC -profile=HC http://pastebin.com/3fK1mEJX And here the start without for example @Ryanzombies; start "HC" "arma3server.exe" -client -connect=127.0.0.1 -port=2302 -mod="@allinarmaterrainpack;@Exile;@zombies_hc;" -nosound -name=HC -profile=HC http://pastebin.com/WrEAq82A Has someone some tips for me on what iam doing wrong? Why are my debug statements and the code only called when there is a missing mission mod? Thanks for any help.
  12. DEADPOOL_ZA

    HC is the way!!!

    Hi guys We have a HC server and i must say that is the future for exile servers! we are running better frames with more players. i wish just there is more ai scripts that support headless, but guys HC is the way
  13. Hi, I've rebuilt ExileZ into ExileZ 2.0 http://www.exilemod.com/topic/7952-exilez-20/ The only missing thing is Headless client support. I could not figure how to make it work even though I'm using an HC with other mods. I would like to find someone who could help me with this. One other thing I would like to do would be to transfer the AI of the zombies to the client themselves if this is possible. Thanks.
  14. My HC is being kicked and i'm trying got figure out.. 13:53:30 Player HC_HAL: Wrong signature for file addons\data_f_exp_b.pbo 13:53:30 Player HC_HAL disconnected. Mission SQM is: Startup Parameters: start "Arma3" /min /wait arma3server.exe -client -nosound -connect=127.0.0.1 -port=2312 -mod="@Exile;@Bornholm" -profiles=HCLogs I have RHS/CUP/ASDG/TRYK running too on the server.. When I take bornholm off, it instakicks as its required in the mission.sqm. If I add all of them he gets kicked for a wrong signature for an RHS pbo. sigh. Also running @FuMS on server startup. init has []execVM "HC\init.sqf" config.cfg has localClient[]={127.0.0.1}; headlessClients[] = {"127.0.0.1"}; battleyeLicense=1; HC is on same server. Also.. I have verified the steam files. Any ideas? -------------------------------------------------------------- Solution for me was here: http://feedback.arma3.com/view.php?id=21915 but since my issue wasn't the helis pbo, here is what I did: Copy the "addons" folder its entirety to the Arma folder where the HC resides.. Viola.