Search the Community

Showing results for tags 'mysql'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Exile
    • Changelogs
    • Feedback
  • Exile Community
    • General Discussion
    • New Feature Voting
    • Problems & Bugs
    • Cat Walk
    • Recruitment
    • Small Talk
  • Exile Mod XM8 App
    • XM8 Server Administration
    • XM8 Android App
    • XM8 Discord Bot
  • Exile Mod Server Administration
    • Ask a Game Server Provider
    • Hosting
    • Operating Systems
    • Installation
    • Database
    • Security
    • Maintenance
  • Exile Mod Customization
    • Downloads & Releases
    • Content
    • Environment
    • Gameplay
    • Look & Feel
    • Tech Talk
  • Exile Life Mod
    • Visit forum on exilelifemod.com

Categories

  • Knowledge Base
  • Items
  • Constructions
  • Traders
  • Vehicles

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Homepage

Found 79 results

  1. Hey whatsupp together. At first, i'm trying to help you, if it doesn't work. Tell me and i'm trying to find some solution! Today i'm gone show you, how we can easy fix a MYSQL-Server bug. My bug was looking like this: Sounds terrible i know. But it isn't. Here are my solutions. It exist 2 Way's. Which you choose, i dont care. Way 1 -For the first problem you need a Console for your Database like MYSQL Workbench. If you opened. You need to go to your exile Databse with a doubleclick. If exile is open and you can see al your tables (if not, you need to setup your databse correctly). -Next you go write a new SQL command with these button with the + in the Paper. -*First you write SELECT @@GLOBAL.sql_mode; - And start the command with the lightning. -it opens a formular with sql_mode: (and some Text), -Next you write a new command with: SET @@GLOBAL.sql_mode= ''; - And start it with the lightning -You go to the step with the '*' back. And write the command with SELECT again. If the modes are gone and there is just sql_mode: ' '. -Now we gonne need to Set the strict mode. SET @@GLOBAL.sql_mode= 'NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION'; - And start it with the lightning -Now we go to make sure, it activate it. with the SELECT command again (the step with the '*') - If it looks like this: (on the Picture) -you win. And it shoud work! Way 2 - You need to aviable to see all folders. Then you go to the path C >>ProgramData >> MYSQL >> MYSQL Server 5.7 >> my.ini and minimze it! - WIth win + R you, then you write ' services.msc '. You search MYSQL57, then you stop it with rightclick! -You go back to the file we opened (my.ini). Search sql-mode: -Edit the line to sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION" -you save it and close it. -go back to the services.msc, and start the mysql again! -You win, the server should work! If it doesn't work. Let me know. If it work. Let me know also. //Guess BlugDeg
  2. hello everyone A lot of vehicles are destroyed by physical engine bugs on my running server. I do not want to betray the efforts of friends visiting my server. When the vehicle is destroyed, it is deleted from the DB, but I want to change it so that it can be stored in a exad virtual garage. The price of the vehicle will be very high, but I want to make it permanent when I buy it once. However, I am having difficulty because I am not a script or DB expert. What I think is 1. Unlock exad virtual garage range 2. When the vehicle is destroyed, it is stored in the garage without being deleted from the DB. 2-1. If you can not prevent deletion from the DB, create separate schemas and save and load them separately. 3. Remove existing vehicles wrecks and recall them via xm8 garage menu I wonder what the opinion is on how I am thinking.
  3. Mirolife

    Error in expression

    Hello, So, here's my problem, installed server, first join is ok, but after relog and second join is: Waiting for server to load. "ExileServer - Database Error: Error Unknown Protocol" Error in expression <se_handleBig; }; }; ((_result select 1) select 0) select 0> Error position: <select 0) select 0> Error Generic error in expression File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27 Error in expression <se_handleBig; }; }; ((_result select 1) select 0) select 0> Error position: <select 0) select 0> Error Generic error in expression File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27 And this is this file .sqf /** * ExileServer_system_database_query_selectSingleField * * Exile Mod * www.exilemod.com * © 2015 Exile Mod Team * * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/. */ private["_parameters", "_query", "_result"]; _parameters = _this; _query = [0, ExileServerDatabaseSessionId, _parameters] joinString ":"; _result = call compile ("extDB2" callExtension _query); switch (_result select 0) do { case 0: { (format["Database Error: %1", (_result select 1)]) call ExileServer_util_log; }; case 2: { _result = (_result select 1) call ExileServer_system_database_handleBig; }; }; ((_result select 1) select 0) select 0 line 27 is this -----> ((_result select 1) select 0) select 0
  4. alycee1993

    external db

    hi can someone help me I am trying to set up a few servers but have the db on another computer within the network. I set the extdb config with my username and password and the ip of the db computer but I keep getting an error as shown in the pic. I have tryed the internal ip and external ip but still can't find it do i need to port forward 3306 or something thanks
  5. lowrey

    Complete Backup Scripts

    Simple scripts that can be run from task scheduler or BEC/MRCON etc... .bat files the will Backup MySQL and any important Arma 3 server files. These .bat files can be uses for multiple applications. Feel free to download and amend the files here: Link If you want to automate the Arma 3 server backup, insure you remove the “pause” from around line 96. Avoid spaces in your file patch, this has been known to break the script. If you would like help visit: http://darkmattergaming.com Useful tools: Notepad++: https://notepad-plus-plus.org/download/v6.9.html CMTools (for log files): https://www.microsoft.com/en-us/download/details.aspx?id=50012 7zip: http://7-zip.org/download.html Visual Studio Code: https://code.visualstudio.com/Download
  6. Vanish

    Unable to join server

    Hello, I've spend over 20 hr's trying to fix this issue. Please someone help me 1. I already attempted re-installing my database from scratch. 2. disable BE 3. Re-install some of my mods and double check
  7. Hello! I am trying to get a dedicated server set up and running (on Linux) and have gotten so far as to have the mission start and run. However, when I or anyone else tries to load in they spawn in the ground and disconnect a few seconds later. I have tried making sure the player hitpoint value is VARCHAR(1024) and making sure the SQL strict mode settings are disabled. In my @ExileServer folder I have extDB-conf.ini set up with a username and password and my Battleye Rcon passwords match. However, when I look at the extDB log file it contains two lines: extDB-conf.ini found Access denied for user 'changeme'@'localhost' (use password=NO) I have set up a user and password using MySQL and the database appears to be intact, and put that users information in extDB-conf.ini. I cannot figure out why it is trying to log in with 'changeme'@'localhost'. Would having the server and the database on the same port cause this behavior? (Apologies for not posting log/rpt files. I do not currently have access to the PC running the server. They can be posted later if needed.)
  8. sandy4596

    Stuck Facing a Mountain at Spawn In,

    Hello, I had seen a thread similar to this one, but I couldn't find a definitive answer to help, so I figured that I would ask myself. I recently just bought a dedicated box to run my exile server, and have gone through doing all that implies. Mostly through the help of youtube videos, as I have...no real idea what I'm doing. I got the server up and running, but when I connect to it, it spawns me in, facing the ground. The same with other people that I have try it. In the other thread I read, I saw that it's an issue with mysql, but when I connect to phpadmin to look for the lines discussed, I find nothing. It could easily be because I don't know what this all means, but if someone could break it down barney style for me, that would be absolutely amazing.
  9. aussie battler

    MySQL Dumper - web based auto backup to FTP

    MySQL Dumper created by Daniel Schlichtholz Grab it here: https://sourceforge.net/projects/mysqldumper or here https://github.com/aussie-battler/MySql-Dumper About: MySQLDumper is a free web based backup/restore script for MYSQL which can handle huge dbs. You can use cpanel's cron jobs to create regular backups of multiple databases to FTP sites. Unfortunately there is no longer any support, however install / setup is easy. Installation is very easy: Upload the install files to your website. Configure the databases & ftp site to backup to. Here is a tutorial: https://www.1and1.com/digitalguide/hosting/technical-matters/creating-backups-with-mysqldumper/ Schedule backups: 1. in MySQLDumper click in the "backup" tab. 2. Click "Backup Perl" 3. Copy the "Commandline in the Shell or for the Crontab" (your path to MysqlDumper will be different): 4. Open Cpanel on your website. 5. Click "cron Jobs". 6. Schedule how often you would like to backup & if you want to receive an email notification. 7. Paste in the MysqlDumper command into the "command section". Sit back & crack a beer.
  10. Is it possible to make infistar admin access thru a MySQL database? So you don't have to restart server just to add a players UID to the admin list, and to give individual access to some privileges. I have uploaded a picture of the EXILE_AHAT_CONFIG file that might help with what I am trying to incorporate. I have already looked at all topics, you-tube videos and website. The only thing close is Arma life witch might grand access to a police officer. Any help would be greatly appreciated. PS. I am also trying to incorporate MCC into Exile, but with no success. If anyone know where I might fine the conflict or the starting point, please chime in.
  11. Hightaxes (Ask for ark server)

    Requesting server version / Timeout / w. Error log

    I read a couple walkthroughs of how setting up a Arma 3 Exile server, gave it a try and now im at the point where (Through the launcher) it loads most of the data but gets hung up with "recieving server version..." "Server Version Request Timed Out" I've tried the mySQL/Steam command/Starting file for server with little luck
  12. red_ned

    Code dump

    Started dumping snippets of code and explanations of things I have come across: https://github.com/redned70/CodeAddons I will add more over time or as people donate things to the store. cheers
  13. Im here for ask your help "exile servers" PROS, this error it's driving me crazy! I have tried all the solutions but still staying on the floor when I login... (PC settings: i7 , 16ram , Win10x64 , fiber connection) Screenshot: http://steamcommunity.com/sharedfiles/filedetails/?id=1347467304 Server log: 23:25:49 "ExileServer - Server is loading..." 23:25:49 Client: Nonnetwork object c99600. 23:25:49 CallExtension 'extDB2' could not be found 23:25:49 "ExileServer - MySQL connection error!" 23:25:49 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong." 23:25:49 "ExileServer - MySQL Error: Unable to locate extDB2 extension!" 23:25:49 "ExileServer - Server will shutdown now :(" 23:25:49 CallExtension 'extDB2' could not be found extDB2 log: extDB2: Unable to find extdb-conf.ini it's a connection problem with mysql but I have tried everything... - Install C++ 2013 - 2014 - 2015 x86+x64 + NetFramework - Installed All in same Drive (mysql and arma3server in D: ,game in C:) - Install mysql and execute "exile.sql" with Navicat for schemma and tables... (and try xampp ,mysql and mariaDB) - Config "extdb-conf.ini" inside "@ExileServer" folder (with root@mypasword) (and try put in "Server" folder and nothing) - Add exile.bikey in keys folder - Port forwarding for requiered ports UDP and TCP and included Firewall rules "in" and "out" - Trying different config.cfg and different "-parameters" and still in ground when login... HELP!! if someone can help me in person can you add me here http://steamcommunity.com/id/gm-uranus PD. Some tutorials use "arma3server.exe" for start server but it does not work for me and the server goes down, instead use "arma3server_x64.exe" and the server starts but no connect with database its posible the server or mysql uses x32bit and it does not work with "arma3server.exe" (32bits exe)
  14. I'm the bottomfrag

    [Solved] MySQL

    How would one go about checking if some data exists in a MySQL table from SQF?
  15. mathis_kb135

    Error with DB, stuck in the ground

    Hi, Im running an Exile 1.0.3 server on a dedicated server and have problems with my database. When I want to connect to my server i get stuck in the ground. I have turned strict sql mode off and have no other mods than Exile installed. Here are my log and .rpt files: RPT log
  16. Fin ¯\_(ツ)_/¯

    RyanZombies causing DB Issues?

    Hi, i am trying to set up an Exile Server on Altis, but im coming across lots of bugs. The main one i want to sort is the issue described in the title When i start my server with these params: everything is fine, i can run around, go to traders, my connection with mysql is fine, and everythign runs great. However, When i launch with these params: The whole server hates it, i get a huge amount of errors: Suddenly i am spawning in the ground, with no connection to DB as the last seen time was when i last joined without the "@ryanzombies" in the params Server gets stuck on "connected to steam servers" - Until a player joins, it then proceeds to finish setup, and the player freezes I also get errors saying "Bash: command not found '@Ryanzombies'", which also happens if i try and use another mod along with exile??!? And more, but they are irrelevant to this topic Please help, getting really frustrating. Fin
  17. wetNreckless

    Server Database Transfer

    Hello Everyone, So I have been running my servers on my own dedicated server in the US for over a year now and have recently gotten a EU dedicated server and want to transfer the database from one of my servers over to the new EU one. Does anyone know of way that I can transfer all player data over without them losing their bases and vehicles? I will be grateful for every. Thanks in advanced. -wetNreckless
  18. YETEH

    MYSQL Issues

    Hey. I'm setting up a new server. And i am getting the following error. I already have one server that runs fine. So what could be causing this issue? Appreciate it! https://pastebin.com/CiBfPSnG
  19. zoblan

    This is solved so please remove

    Im stuck in ground when i'm joining my server. this is my arma3/@ExileServer/extDB/logs log: extDB2: Found extdb-conf.ini extDB2: Detected 8 Cores, Setting up 6 Worker Threads [10:48:27:711129 +01:00] [Thread 5528] extDB2: Database Type: MySQL [10:48:27:962154 +01:00] [Thread 5528] extDB2: Database Session Pool Started [10:48:27:967155 +01:00] [Thread 5528] extDB2: SQL_CUSTOM_V2: Loading Template Filename: c:\games\173_199_72_201_2302\1356771\arma3\@ExileServer\extDB\sql_custom_v2\exile.ini [10:48:27:967155 +01:00] [Thread 5528] extDB2: SQL_CUSTOM_V2: Version 12 Detected, Latest Version 12 Available [10:48:28:361194 +01:00] [Thread 2104] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.container' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: UPDATE container SET abandoned = NOW(), pin_code = '0000' WHERE (SELECT flag_stolen_at FROM territory WHERE territory.id = container.territory_id AND territory.flag_stolen_at < DATE_SUB(NOW(), INTERVAL ? DAY)); [10:48:28:361194 +01:00] [Thread 2104] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:28:482206 +01:00] [Thread 2104] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: setAbandonedUnlocked:2 [10:48:28:557214 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.construction' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: UPDATE construction SET deleted_at = NOW() WHERE spawned_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND territory_id IS NULL AND deleted_at IS NULL [10:48:28:557214 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:28:560214 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.territory' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: UPDATE territory SET deleted_at = NOW() WHERE last_paid_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND deleted_at IS NULL [10:48:28:560214 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:28:757234 +01:00] [Thread 4084] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.territory' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: DELETE FROM territory WHERE deleted_at < DATE_SUB(NOW(), INTERVAL ? DAY) [10:48:28:757234 +01:00] [Thread 4084] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:28:966254 +01:00] [Thread 3276] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.container' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: UPDATE container SET deleted_at = NOW() WHERE last_updated_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND territory_id IS NULL AND deleted_at IS NULL [10:48:28:966254 +01:00] [Thread 3276] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:29:166274 +01:00] [Thread 6956] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.vehicle' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: UPDATE vehicle SET deleted_at = NOW() WHERE last_updated_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND deleted_at IS NULL [10:48:29:166274 +01:00] [Thread 6956] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:29:300288 +01:00] [Thread 4084] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteUnpaidTerritories:3 [10:48:29:300288 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: markDeleteOldConstructions:2 [10:48:29:300288 +01:00] [Thread 6956] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: markDeleteOldVehicles:3 [10:48:29:300288 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: markDeleteUnpaidTerritories:7 [10:48:29:300288 +01:00] [Thread 3276] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: markDeleteOldContainers:10 [10:48:29:367295 +01:00] [Thread 5528] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.clan' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: SELECT id FROM clan LIMIT ?,? [10:48:29:367295 +01:00] [Thread 5528] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:29:367295 +01:00] [Thread 5528] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: loadClansIdPage:0:100 [10:48:29:367295 +01:00] [Thread 4084] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.construction' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: DELETE FROM construction WHERE deleted_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND territory_id IS NULL [10:48:29:367295 +01:00] [Thread 4084] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:29:367295 +01:00] [Thread 4084] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteOldConstructions:3 [10:48:29:369295 +01:00] [Thread 2104] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.container' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: DELETE FROM container WHERE deleted_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND territory_id IS NULL [10:48:29:369295 +01:00] [Thread 2104] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:29:369295 +01:00] [Thread 2104] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteOldContainers:3 [10:48:29:369295 +01:00] [Thread 6956] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.territory' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: DELETE FROM territory WHERE flag_stolen_at < DATE_SUB(NOW(), INTERVAL ? DAY) [10:48:29:369295 +01:00] [Thread 6956] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:29:369295 +01:00] [Thread 6956] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteBaseFlagStolen:3 [10:48:29:375295 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.vehicle' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: DELETE FROM vehicle WHERE deleted_at < DATE_SUB(NOW(), INTERVAL ? DAY) [10:48:29:375295 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:29:375295 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteOldVehicles:3 [10:48:29:377296 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.container' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: UPDATE container SET abandoned = NOW(), pin_code = '0000' WHERE last_updated_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND class = "Exile_Container_Safe" AND territory_id IS NULL [10:48:29:377296 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:29:377296 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: addAbandonedSafes:7 [10:48:38:058164 +01:00] [Thread 5528] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.account' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: SELECT CASE WHEN EXISTS(SELECT uid FROM account WHERE uid = ?) THEN 'true' ELSE 'false' END [10:48:38:058164 +01:00] [Thread 5528] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:38:058164 +01:00] [Thread 5528] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: isKnownAccount:76561198032881159 [10:48:52:766634 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.account' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: UPDATE account SET last_disconnect_at = NOW() WHERE uid = ? [10:48:52:766634 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:52:766634 +01:00] [Thread 2476] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: endAccountSession:76561198032881159 [10:48:52:768634 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Table 'c1356771_exile.player' doesn't exist [mysql_stmt_errno]: 1146 [mysql_stmt_sqlstate]: 42S02 [statemnt]: UPDATE player SET name = ?, damage = ?, hunger = ?, thirst = ?, alcohol = ?, oxygen_remaining = ?, bleeding_remaining = ?, hitpoints = ?, direction = ?, position_x = ?, position_y = ?, position_z = ?, assigned_items = ?, backpack = ?, backpack_items = ?, backpack_magazines = ?, backpack_weapons = ?, current_weapon = ?, goggles = ?, handgun_items = ?, handgun_weapon = ?, headgear = ?, binocular = ?, loaded_magazines = ?, primary_weapon = ?, primary_weapon_items = ?, secondary_weapon = ?, secondary_weapon_items = ?, uniform = ?, uniform_items = ?, uniform_magazines = ?, uniform_weapons = ?, vest = ?, vest_items = ?, vest_magazines = ?, vest_weapons = ?, temperature = ?, wetness = ? WHERE id = ? [10:48:52:768634 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [10:48:52:768634 +01:00] [Thread 5144] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: updatePlayer::0:100:100:0:1:0:[]:0:13237.161133:11705.337891:-0.000514984:["ItemMap","ItemCompass","ItemWatch","ItemRadio"]::[]:[]:[]:::["","","",""]::::[]::["","","",""]::["","","",""]::[]:[]:[]::[]:[]:[]:0:0:-1
  20. I'm trying to continue the work done by airtonix etc in making a docker friendly exile setup. My new arma 3 docker image is working great, but when I wire up the volumes with exile files and connect, I spawn in the grass and no keybinds work, similar to this post . I suspect this is a DB issue, though I am able to connect from arma container to the mysql db container on the cli, and all of the tables are created, it seems that extDB2 is never initialized (no logs etc). I also turned off strict mode in mysql - see docker-compose.yml RPT - https://ghostbin.com/paste/zjz22 To replicate: this works to connect to the db from the server container, where db is the hostname of mysql container server_1 | 14:39:31 Player Blah connected (id=). server_1 | 14:39:31 BattlEye Server: Verified GUID () of player #0 blah server_1 | Unaccessible server_1 | 14:39:36 Server: Object 4:62 not found (message Type_121) server_1 | 14:39:36 Server: Object 4:51 not found (message Type_121) server_1 | 14:39:36 Server: Object 4:52 not found (message Type_121) server_1 | 14:39:36 Server: Object 4:53 not found (message Type_121) etc I did an `ldd extDB2.so` and all of the needed libs were loaded ok
  21. Demon95

    HElP

    5 times I created a clean server Exile(1.0.3) still this error, the server starts but when connecting says "connecting..." Version of ARMA 3 1.70 32 and 64 bit no difference
  22. Anarchist Wolf

    MySql Error on Joining

    Whenever i start up the server and try to join i get this Error Message. In the config ive already pointed it to the exile database. but i still get this error. 14:48:20 "ExileServer - Installed extDB2 version: 71" 14:48:20 "ExileServer - MySQL connection error!" 14:48:20 "ExileServer - Please have a look at@ExileServer/extDB/logs/ to find out what went wrong." 14:48:20 "ExileServer - MySQL Error: Could not add database: [0,""Database Exception Error""]" 14:48:20 "ExileServer - Server will shutdown now :(" /home/buildbot/buildslave/steam_rel_client_linux/build/src/tier1/../tier1/fileio.cpp (3997): Assertion Failed: CFileWriterThread: pending file writer content_log.txt /home/buildbot/buildslave/steam_rel_client_linux/build/src/tier1/../tier1/fileio.cpp (3997): Assertion Failed: CFileWriterThread: pending file writer connection_log_2302.txt Bad thread local/home/buildbot/buildslave/steam_rel_client_linux/build/src/tier0/threadtools.cpp (1431) : Assertion Failed: Thread synchronization object is unuseable
  23. I'm currently trying to setup an arma 3 Exile server on a virtual machine, the VM is running Ubunutu Server 16.10, with MySQL 5.7 for the database. At first I was unable to get exile working with extDB2 (the arma 3 serer and MySQL server weren't connecting), I was recently able to get the server to connect to the database by using extDB3. When I attempted to join the game however I was greeted with a longer then usual loading time (frozen load bar) and eventually when I loaded in my camera was stuck onto the ground like so: I went back to see what the problem was, and found a few thing that I suspect might be the culprits, I'm just not able to find a fix myself. The first thing I was unsure of was the creation of my database through phpMyAdmin, using the unaltered exile.sql, at first when I tried to run the .sql file I got the error; "#1215 - Cannot add foreign key constraint". If I unchecked the "Enable foreign key checks" I seemed to work, but i'm unsure if that is the correct way to address the aforementioned error. Here is a picture for reference: Also here is an album containing pictures of the messages I get when the database is created successfully: http://imgur.com/a/opgor Other than that the only other idea I have is to take a look at the log files, the RPT log seems to have a lot of errors that occurred between the time where my client froze and it loaded in stuck to ground. On the other hand I can't find anything wrong with the extDB3 log but i'm hoping it might help someone else help me. RPT Log: extDB3 Log: Thanks in advance to anyone who takes a look at my problem, any suggestions are much appreciated!a FIX: Switching back to extBD2 fixed this problem, and most of my other problems had been fixed by either switching MySQL to non-Strict mode, or using the arma 3 performence binary MySQL Strict mode Disabling: https://dev.mysql.com/doc/refman/5.7/en/sql-mode.html Arma 3 Performance Binary: https://forums.bistudio.com/forums/topic/160288-arma-3-stable-server-168-performance-binary-feedback/
  24. iamkaarp

    No extDB

    So. I've setup an exile server I can login to the server and it places me as a ghostplayer. I have exactly no extdb logs I have exactly no entry of extdb/mysql/sql in any rpt-file It seems that exile doenst load extdb files at all There is nothing wrong with extdb-conf.ini since i've tried both the exile user I want and the root password and both works in MySQL Workbench Database is a MySQL 5.7 running on a centos 7 machine extDB is updated to version 71 any ideas?