happydayz

Enigma Exile Revive - v0.80 [UPDATED 08/09/16] 1.02 Compatible

881 posts in this topic

So I think Enigma Revive is a great mod but I feel like it's missing something the timer should be able to be stopped or slowed down by the use of a bandage. This process of applying the bandage should be quick. Is this an option you can add to you mod?  I think the bandage is useless, but if you add this feature, It would give it purpose...

Edited by marcelotk
  • Like 2

Share this post


Link to post
Share on other sites
On 9/16/2016 at 10:32 PM, happydayz said:

updated with hopefully a simple fix to stop the duping. and fixed readme.

Testing this fix on my Esseker and Tanoa servers today. Will report back with results. Thanks for your hard work!

Share this post


Link to post
Share on other sites
Advertisement

Hello everyone, i have followed all the steps to add the revive to my server and i keep get kick by battleye for #40 Battleye script restrictions. When i open my scripts.log, i have this...
 

#40 "#line 1 "mpmissions\__CUR_MP.Tanoa\init.sqf"

[] execVM "Custom\EnigmaRevive\init.sqf";
"

I just have unpacked the mission Exile.Tanoa PBO to add the Custom folder and the init.sqf (i didn't have one), repacked and upload the mission pbo.

------------------------

I tryied to fix this issue by adding this line in the ExecVM in Scripts.txt in Battleye.

!"Custom\EnigmaRevive\init.sqf"

Now i am kick for Battleye script restrictions #0

#0 "["antidupe", 1, true];



"EnigmaRevive" addPublicVariableEventHandler {
private["_newPlayerObject","_oldPlayerObject","_packet""

 

What did i do wrong ? can someone please help me ?

Edited by Aruvyel

Share this post


Link to post
Share on other sites
On 9/17/2016 at 7:00 PM, Psikys said:

Anyone else have all players getting "0x0000005 - Status_Access_Violation" Crash to desktop after enabling the mod? Other servers without Enigma Revive work fine, mine causing all players to crash to desktop.

Blame B.I.

This error has nothing to do with this script. I myself have encountered this error for quite some time now. 

I may sound mental, however if you try and alt tab once you click the "close" button on the infamous "bin\config.bin/CfgWeapons/Iteminfo.scope" error, and then come back to the Arma 3 application after ~10 seconds. You should be able to join the game. Don't ask me why or how this is even possible as I am clueless af. I read this solution elsewhere and it has seemed to work for me so far.

Share this post


Link to post
Share on other sites
On 9/18/2016 at 5:02 AM, marcelotk said:

So I think Enigma Revive is a great mod but I feel like it's missing something the timer should be able to be stopped or slowed down by the use of a bandage. This process of applying the bandage should be quick. Is this an option you can add to you mod?  I think the bandage is useless, but if you add this feature, It would give it purpose...

This could be a nice feature , however I am pretty sure that happydayz is for the most part, done updating/adding features to this script. As happydayz has stated on the last post on page 63,

"Not New additions at all. I haven't changed other than bug fixes for updates in this since January. It's really low on my priority list these days."

Share this post


Link to post
Share on other sites
2 minutes ago, Alexis said:

There are problems with 1.0.2 Exile?

Not that I'm aware of. I'm running it on my Esseker and Tanoa servers and it's functioning properly.

On 9/21/2016 at 7:36 PM, serveratze said:

new version new bug

when I revive a player it happens that terminates my game.  it doesn't always happen but it happens!

This happens from time to time too. Seems like it's random. Friend revived me 4 times in 30 minutes, on the 4th revive he crashed, this was before the 1.64 and 1.0.2 updates though. Haven't had a crash since the update.

  • Like 1

Share this post


Link to post
Share on other sites

Hello, i was just wondering: Open up your mission file and if you have an existing init.sqf then merge the execVM line into your init.sqf file (Must be executed by both server and client!)!

Where do copy the line? Atm my init looks like this: 

[] execVM "Custom\EnigmaRevive\init.sqf";

// bAdmin Exile by Biabock

#define DEBUG false

[DEBUG] call compile preprocessFileLineNumbers "badmin\globalCompile.sqf";

if (!isDedicated) then
{
    if (hasInterface) then // Normal player
    {
        execVM "badmin\client\init.sqf";
        
    }
};

if (isServer) then
{
    diag_log "bAdmin - Initializing";
    [] execVM "badmin\server\init.sqf";
};

OPEN_bADMIN_FNC = {
    switch (_this) do {
        //Key U
        case 22: {
            nul = [] execVM "badmin\client\systems\adminPanel\checkAdmin.sqf";
        };
    };
};

waituntil {!isnull (finddisplay 46)};
(findDisplay 46) displayAddEventHandler ["KeyDown","_this select 1 call OPEN_bADMIN_FNC;false;"];

 

Thanks.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.