happydayz

Enigma Exile Revive - v0.80 [UPDATED 08/09/16] 1.02 Compatible

881 posts in this topic

If you use Infistar, there latest update has fixed the blurred vision when you respawn, so you wont need to merge the fixes in the revive bleeding out sqf, update to Infistar v0068a then use the original ExileClient_object_player_death_startBleedingOut you get from exile revive, remember to delete your custom code path in your config.cpp.

Edited by DavieReid88

Share this post


Link to post
Share on other sites
55 minutes ago, DavieReid88 said:

If you use Infistar, there latest update has fixed the blurred vision when you respawn, so you wont need to merge the fixes in the revive bleeding out sqf, update to Infistar v0068a then use the original ExileClient_object_player_death_startBleedingOut you get from exile revive, remember to delete your custom code path in your config.cpp.

I did what you said, it will show up in the menu but still doesn't do anything.

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

@Jidyfly Sorry took so long to reply, working away from home just now, I have only updated my Infistar haven't actually tested revive, I thought with it being the original revive file it would work but I guess not, seems like the only way to get revive working at the moment is to downgrade from 1.66.

Edited by DavieReid88

Share this post


Link to post
Share on other sites
23 minutes ago, DavieReid88 said:

@Jidyfly Sorry took so long to reply, working away from home just now, I have only updated my Infistar haven't actually tested revive, I thought with it being the original revive file it would work but I guess not, seems like the only way to get revive working at the moment is to downgrade from 1.66.

No problem. Thank you for trying though!

Share this post


Link to post
Share on other sites

Infistar updated to v0069 and now the rpt shows:

18:23:28 "Enigma Exile Revive: fn_init 0"
18:23:28 "Enigma Exile Revive: Compiles Started - 0"
18:23:28 "TCAGame/BIS_fnc_log: [preInit] EnigmaRevive_fnc_init (0.999451 ms)"
18:23:28 "TCAGame/BIS_fnc_log: [preInit] BIS_fnc_getServerVariable (0.999451 ms)"
18:23:28 "TCAGame/BIS_fnc_log: [preInit] RHS_fnc_init (0 ms)"
18:23:28 Error in expression <respawnDelay","_layer","_descriptions"]
_respawnDelay = _this
oldgroup = group p>
18:23:28   Error position: <_respawnDelay = _this
oldgroup = group p>
18:23:28   Error Missing ;
18:23:28 File mpmissions\__cur_mp.IslaDuala3\custom\EnigmaRevive\ExileClient_object_player_death_startBleedingOut.sqf, line 2
18:23:28 Error in expression <respawnDelay","_layer","_descriptions"]
_respawnDelay = _this
oldgroup = group p>
18:23:28   Error position: <_respawnDelay = _this
oldgroup = group p>
18:23:28   Error Missing ;
18:23:28 File mpmissions\__cur_mp.IslaDuala3\custom\EnigmaRevive\ExileClient_object_player_death_startBleedingOut.sqf, line 2

 

Share this post


Link to post
Share on other sites

Original revive should work. I haven't messed with revive when I updated to 1.66. I didn't do any hotfix or infistar I waited till hotfix came out and just updated arma and it works fine 

Share this post


Link to post
Share on other sites

I have the original revive on my server, still getting kicks for this

08.12.2016 14:09:59: Jidyfly () 2bbb5767a9969f48710adcf822205ed5 - #0 "enigmarevivepermitted" = false 2:6843 Exile_Unit_Player
08.12.2016 14:09:59: Jidyfly () 2bbb5767a9969f48710adcf822205ed5 - #0 "antidupe" = 1 2:6843 Exile_Unit_Player
08.12.2016 14:11:30: Jidyfly () 2bbb5767a9969f48710adcf822205ed5 - #0 "enigmarevivepermitted" = true 2:6843 Exile_Unit_Player
08.12.2016 14:11:30: Jidyfly () 2bbb5767a9969f48710adcf822205ed5 - Value Restriction #0 "bleedoutcountdownend" = 7776.59 2:6843 Exile_Unit_Player
09.12.2016 13:24:02: Jidyfly () 2bbb5767a9969f48710adcf822205ed5 - Value Restriction #0 "bleedoutcountdownend" = 280.804 2:2104 Exile_Unit_Player

This is my Set variable txt (Lines are messed up due to the forum)

Spoiler

//new
1 "" !="exilexm8isonline" !="bis_fnc_selectrespawntemplate_respawned" !="ExileCameraInUse" !="isrunning" !="bis_fnc_setunitinsignia_class" !="bis_accesscounter" !="antidupe" !="enigmarevivepermitted" !="bleedoutcountdownend" !="[0-9]*" !="[0-9].[0-9]*e\+[0-9]*" !="[0.0-9.9]*" !="[0-9]*e\+[0.0-9.9]*"
1 "ExilePurse"
1 "ExileBank"
1 "ExileMoney"
1 "ExileScore"

 

Edited by Jidyfly

Share this post


Link to post
Share on other sites

Since 1.66 hotifx i am having an issue with revive system on my server.

randomly when trying to revive a player it will glitch and choose an alive player in proximity and try to revive them then fail killing the player

these two players are on the ground trying to revive each other

0b953d9379.png

shortly after this player dies in a heli above them.

Untitled.png

this started with 1.66 hotfix

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.