Lunchbox

[XM8 App] Personal Base Location Markers

86 posts in this topic

Advertisement

What´s this:

"No permission

Sorry, we can't show this content because you do not have permission to see it."

What does need to be installed to make the base map markers work?

Edit:

 OK, i have it xD

Edited by JerryF

Share this post


Link to post
Share on other sites
35 minutes ago, Bruiser said:

Thanks, it works! 

when I turn it on a message comes up the the message is blank, no text.. is there a way to fix that ?

 

It shouldn't be blank. When you turn it on it should read "Base Markers toggled on." But it's all defined in onLoad.sqf

5319d456157467b277b9c3d4c85637c4.png

Edited by Beowulfv

Share this post


Link to post
Share on other sites
2 hours ago, ItsMe2017 said:

Thank you @Beowuflv !
Same Problem like Buriser, blank message, but it works.

I'll keep looking for other methods to display the message. I switched it from the original because it would display a message, and I also tried Exile Server display but it didn't, they don't even pop up. Odd it doesn't work for some of you. Line 50 and line 68 in onLoad.sqf is where that is executed.

["Success",["Base Markers toggled on."]] call BIS_fnc_showNotification;
["Whoops",["Base Markers toggled off."]] call BIS_fnc_showNotification;

The default is  
call ExileClient_gui_notification_event_addNotification;

And just to see if it would work I tried 
call ExileServer_system_network_send_to;

That's when I thought to use good'ol BIS functions. 

Edited by Beowulfv

Share this post


Link to post
Share on other sites
On 2/9/2017 at 4:29 PM, ItsMe2017 said:

Thank you @Beowuflv !
Same Problem like Buriser, blank message, but it works.

 

On 2/9/2017 at 1:10 AM, Bruiser said:

Thanks, it works! 

when I turn it on a message comes up the the message is blank, no text.. is there a way to fix that ?

 

 

To fix the blank message: there are 2 methods;

Method 1 (Manual way)

Spoiler

1. go to the base marker folder and open 'onLoad.sqf'

2. find: 


["Success",["Base Markers toggled on."]] call BIS_fnc_showNotification;

3. change it to:


["SuccessTitleAndText",["Base Markers toggled on."]] call ExileClient_gui_toaster_addTemplateToast;

4. find:


["Whoops",["Base Markers toggled off."]] call BIS_fnc_showNotification;

5. change it to:


["ErrorTitleAndText",["Base Markers toggled off."]] call ExileClient_gui_toaster_addTemplateToast;

Method 2 (replace the onLoad.sqf)

Spoiler

 

1. Copy this from pastebin(Or the Github Fork): http://pastebin.com/dr3W2kCM or https://github.com/clarkycal/BaseMarkers_ExAd

2. open your onLoad.sqf in your BaseMarker Folder(For github just replace the old files with the new)

3. replace with the fixed version above

 

I do not take credit for the script at all, it's just a fix for the 'Blank Message'. @Beowulfv - make these changes on your github (I forked and Committed(Pull Request)) :D

Have fun!

Edited by clarkycalLad
More Typos
  • Like 3

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.