ctrlText Missing Last letter SOLVED

2 posts in this topic

Hello, I am attempting to pull the text from a RSCEdit Box to a variable so I can verify the text in the box.


_Reason = ctrlText _ctrl;
systemchat format ["Reason: %1", _Reason];

The last character from the RSCEdit Box is missing, and you have to add a new character to see it. For example i could type:


into the RSCEdit Box and the _Reason Variable would return: 



Anyone got any ideas as to why this is happening and how to solve the issue.

Thanks in Advance


Jamie C

Edited by Jamie

Share this post

Link to post
Share on other sites

Solved this issue by using a different event handler, Char is called before the key is registered, however KeyUp registers the key and passes it through to the variable.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.