Black Screen on Login

2 posts in this topic

Hey, I have checked so many possible ways of resolving this issue. But nothing I have found will resolve it.

Mods Installed Client Side: @Exile;@CBA_A3;@CUP_Units;@CUP_Vehicles;@CUP_Weapons; (Exile is the most recent update and so is ARMA on both my machine and the server)

Mods Installed Server Side: @ExileServer;@AdminToolkit;

Issue: When logging into the server, it gets as far as displaying the HUD then stops with the screen black. It does not kick me back to the lobby.

When did the issue start: After I installed CBA and other CUP mods.

Fixes Tried:

1. I tried the CBA fix, changing the ExileServer_System_Network_DispatchIncomingMessage.SQF as per

2. Removing all changes made to the server before CUP(Saved default files of everything then reverted back to a known good state).

3. Deleting my self from the database to allow recreation in case my account was corrupt.

4. Deleting all SQL tables and recreating them as per the most recent script.

5. Disabling Battleye.

6. Uninstalling and Reinstalling Exile Client on my PC.

7. Asking a friend to test, received the same issue.

8. Replaced the Exile.ini file and also making sure all the keys were valid ones as per

9. Ensuring that ARMA3 is up to date.

10. Double checked my SQL details are correct in ARMA3Config\Config.cfg and @ExileServer\extdb-config.ini

11. Double checked mods were named correctly as per the readme's.

12. As a last resort I then scrapped the entire server and started from a clean install. This resolved the issue, up until the point of adding CUP back onto the server.


I am beginning to lose my mind, I cannot possibly think of anything else I can try bar from not using CUP. Which would kind of ruin my experience as its more fun with more stuff.

Please if anyone has any ideas of other things I can try, I have probably done quite abit more than this as its been a long week or so trying to resolve it... But its hard remembering all the stuff I have tried. Also if there are any logs someone could advise me looking into which may give me a clearer idea whats going wrong it would be amazing. At this point I cannot see anything of use in the locations I know of already.

Please obi one kenobi you're my only hope!

Share this post

Link to post
Share on other sites

After troubleshooting a lot more, I found that my issue was relating to CBA. The change advised in 1. was causing the issue.

ExileServer_system_process_preInit.sqf for some reason wasn't taking to my changes too well. I have since given up on using CBA and CUP due to its complications. I was reverting a different file back to its default values as I miss read the instructions when troubleshooting.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.