• 0

DB connection always fail (windows 10) [fixed]



I'm turning nuts with the installation because i'm totally unable to connect to the DB !! 
I'm webdev so i don't forgot the basics (and it's fucking simple to connect to a DB), but I am using windows 10 and I usually work on Debian so maybe I'm wrong with some security settings.


  • I've  installed the A3 server from the Steam\Library\Tools installer
  • I've created the DB and executed the .sql file
  • I've set the @ExileServer\config.cfg hostname, password, passwordAdmin, serverCommandPassword values
  • I've set the @ExileServer\extdb-conf.ini [Rcon]password, [exile]Name, [exile]Username, [exile]password values
  • I've set the sql-mode="" in the my.ini file
  • I've checked the local database connection with phpmyadmin and command line (I've tried with the user root and I've created another user) 
  • I've set arma3server.exe to be executed as admin
  • I've authorized the arma3server.exe to do some modifications
  • I've authorized the connections on the firewall (but the server is local, on the same machine)
  • I've launched the server with this .bat:
    echo Demarrage du Serveur
    ping -n 2 >NUL
    cd "G:\Serveurs\A3 exile server\"
    echo Serveur Exile... Actif !
    start "Arma3" /HIGH /min /wait arma3server.exe "-mod=@exile;kart;heli;mark;" "-servermod=@exileserver;" "-config=G:\Serveurs\A3 exile server\@ExileServer\config.cfg" -port=2302 "-profiles=SC" "-cfg=G:\Serveurs\A3 exile server\@ExileServer\basic.cfg" -name=SC -autoinit
    ping -n 1 >NUL
    echo Le serveur Exile est arrete!


And I continuously have this error:

11:48:42 "ExileServer - MySQL connection error!"
11:48:42 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
11:48:42 "ExileServer - MySQL Error: Unable to locate extDB2 extension!"

The rep @ExileServer/extDB/logs/ doesn't exists, so I'm unable to see what happened. But why the server is unable to locate the extDB2.dll ?

This really turn me nuts !! So, if you have any idea to fix this problem ?
It's vanilla Exile 1.0.0  (with no mods).

Edited by XoO

Share this post

Link to post
Share on other sites

3 answers to this question

  • 0

Ok.. 2 people turning nuts.. any solution..?  except i don't even get any errors what so ever..!!

It just won't connect to MySql at all.. i tried to connect to the database from external PC. it's success.. but with same userID and password in extdb-conf.ini  it seems not to connect to the mysql .. still laying in the grass when connect to server. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.