• 0

Signature check failed


I've had this problem for about one week now, I can't figure out how to fix it.


I am getting kicked from modded multiplayer servers.  I am being kicked for Signature Check Failed/invalid/etc and that happened with different mods (Exile,extended base mod,Battleroyale).  I screenshotted the message I get and Post it here.

I have located all the files I got a problem with:

23 files are in error. Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\dbo_old_bike.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_assets.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_client.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_an2.pbo.exile.bisign
Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_brdm.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_btr40.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_gaz_volha.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_hmmw.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_ikarus.pbo.exile.bisign
Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_lada.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_lrc.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_octavia.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_suvarm_a3.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_suv_a3.pbo.exile.bisign
Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_towtractor.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_tractor.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_uaz.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_uh1h.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_ural.pbo.exile.bisign
Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_v3s.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_vwgolf.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\exile_psycho_weapons.pbo.exile.bisign Key not found for signature C:\Program Files (x86)\Steam\steamapps\common\Arma 3@Exile\addons\gnt_c185.pbo.exile.bisign


I get kicked after 1-2 minutes when I joined the Server


I have performed the following steps - they have all failed:


1) Verifying game cache

2) Deleting pbo's/signature files for Arma 3, verifying cache

3) Re-installing Arma 3

4) Re-installing mods

5) Getting signature files from friends

6) Getting signature files from Armaholic

8) Moved shadowplay temp recordings to HDD

9) Deleting my in-game profile (a suggested fix, this is Arma after all, your profile probably controls whether or not you game even runs)

10) Deleting all data from $appdata$ pertaining to Arma 3

11) Verified a server I was attempting to play on was running verifysignatures = 1 and not = 2

12) Reinstalled BE (downloaded from website, deleted old information

13) Arma 3, BE, Arma 3 launcher all running as admin

14) Added specific filters to firewall for BE

15) Tested ping / jitter / packet loss to server(s), all within acceptable bounds (better than acceptable)

16) Deleted Arma 3 .

17) Checked/tested my routers MTU, fine

18) Manually set MTU in clientside settings

19) Manually set proper load order for mods (compatibility -> Scenario -> peripherals -> content -> maps)

20) Moved back to SSD, tried using 2 different VPN's

21) Servers updated to latest infiSTAR

22) Changed port for BE on the server from 2300->2330

23) Deleted physx_x86.dll from Arma 3 folder, redownloaded

24) Opened WAN ports for Arma 3

25) Manually moved keys from mods into the keys folder

26) Mods were moved to a folder at the top of a drive, basically .

27) Tried changing launcher config, turned off verifysignatures (it was finding 150+errors anyway) and logs to increase performance

28) Deleted all Arma 3 related files/folders.  Restarted PC.  Deleted all Arma 3 related registry information.  Restarted PC.  Deleted all BIS files/folders/registry, restarted.  Unsubbed from all Steam content, deleted all mods, everything.  .

29) Installed fresh Arma 3.  Installed fresh mods.  Joined a server.  Kicked.

30) Reinstalled Windows, reinstalled all programs, Arma 3, mods, disabled anti-virus.


My PC is as follows:


i5 3350P @3.1GHz



Windows 10 64b

I would be glad if someone can help me.




Edited by [WASP]Jockel

Share this post

Link to post
Share on other sites

11 answers to this question

  • 0
2 hours ago, BLTZ71 said:

2 things post your rpt log and check to see if you have the latest keys in your key folder of root dir of Arma 3 folder. 

Hello, first I have to say Im not hosting  the Server at home , these are random servers.

Furthermore I can say that this problem only happens when I join a mod server, nonmodded server are no problem.

I just got 1 key in the Keys folder of Arma 3 and that is the a3.bikey , but a friend of mine have only this key too.

latest rpt file:



Share this post

Link to post
Share on other sites
  • 0



IF you can connect to a non-modded server without issues, then it is NOT ARMA.  The problem lies in one area only (basically):


Your mods and the server mods are NOT the same.  They may have v2 and you are using v1.5 - It will NOT WORK.



Best bet is to DELETE the old mods and re-download the mods from Steam, ARMAHolic.Com, or the author's website, not 'Billy Bob's ARMA' site.


I personally have seen a 'delay' in reading/verifying the files and get the sig error when there was NO ERROR.  In other words, the sig error message was/is a 'generic catch-all' error message.  This 'trick' in not uncommon and is a sign of 'lazy programming'  Instead of have 10 unique error messages for 10 unique errors, they will put 7 errors under one 'generic' error message and the other 2 under another 'generic message'.


Try this,  as SOON AS YOU LOG ON, open your map and zoom AS CLOSE AS YOU CAN and as QUICKLY AS YOU CAN.  By doing this, you will get the maximum FPS possible for your setup.  Let it sit for about 2-5 minutes, then close map and play normal.  This will allow ARMA to verify your files without being 'bothered' by the engine trying to load other crap while this is going on.  Do not move anything during this time, mouse, player, map, etc.


This little 'trick' I discovered when I felt the file verification process was taking too long and the process timed-out, due to reading files for verification and the loading of ARMA, and ARMA did not know what to do, thus the 'sig error', though the files were fine.  I do believe this was an issue on the server to start with, BUT, this 'trick' allowed me to play even with the 'potential' server issues.  This info is based on 40+ years of programming experience.


I personally 'feel' this error is due most times to a 'time out' in the verification process, and in my case and others, this was the case as we all have the correct mods installed.


Try this:

#1 - Re-download your mods

#2 - If you have a NON SSD drive - DEFRAGMENT your ARMA HDD - If you DO HAVE A SSD, DO NOT DEFRAG!!!

#3 - Join a modded server and see what happens

#4 - If you get the error again, try my 'little trick' - Others have used this trick and it worked for them as well.


Hope this helps ya out!




  • Like 1

Share this post

Link to post
Share on other sites
  • 0

Hey Z80CPU thanks for your answere but I have to say that all this stuff didnt work for me :/ .

2 friends want to play exile with me and I loaded the mod from this url:http://www.exilemod.com/downloads/ like they did It too,

It works for them but not for me .

But I have to say that your little trick is really nice for people who have some lagging issues when they Join a server.

Any other Ideas?


Edited by [WASP]Jockel

Share this post

Link to post
Share on other sites
  • 0

Hello Jockel,


Well, that error is when ARMA creates a checksum (in a sense), sends the result to the server and the server 'checks" your checksum against the servers.  Anything in this process can cause a failure.

Some of these would be:

Flakely internet

Flakely RAM

Flakely HDD

Other Flakely HW

Wrong or INCOMPLETE mods or a MIXTURE MOD (some v1 and some v3 for example)


I have been guilty of the 'mixture mod' myself on my own server.  BEST THING is to DELETE the mod folder COMPLETELY.  This will ensure no 'mixes' of different files.  In my case, it was CBA.  Example:  V3 had 100 files, v4 had 75 files.  I just 'overwrote', which usually works.  In this case, I have 25 v3 files left over when i copied over v4, which the v3 puked with the v4.  Deleted the CBA folder, put in 100% v4 - no issues.  It does happen...  ;)


IF, and again, IF, you can connect to a NON MODDED server, your ARMA install is ok.


Try this:

1 - Find some server which has only 1 mod (if possible) loaded, small mod would be nice. (one that you do NOT use/have)

2 - Get mod/install or use the A3 to get mod

3 - See what happens


If you can join a NON MODDED ARMA server with NO ISSUES (>15 mins, BOOTS ON THE GROUND) and it pukes for you on the modded one, well...and this will NOT be nice:

Before attempting the following below, check for any virus and any 'weird' firewall settings.


1 - Uninstall ARMA completely, includes deleting


3 - Remove ALL items related to ARMA/ARMA mods from your registry  <-- this is time consuming and a pain-in-the-butt

4 - Re-Install all above items onto a DIFFERENT HDD (if possible) or into a DIFFERENT folder (this is just in case, you missed something somewhere, the old stuff will not be pointing to the new install as it is now in a new location)


If none of this works, then I can only suspect HW issues...RAM, sys brd, internet, etc.


It's a pisser and I feel for ya!


Good luck!




  • Like 1

Share this post

Link to post
Share on other sites
  • 0


Upgrading is NOT a '100%' fix.  It is ONE of the POSSIBLE fixes though.  Also, though I did not mentioned it in this post, I have many times before, and look at the date too.


While you do not know this Robbo1, my suggestions are based on:

17 years of ARMA

10,000+ hours in ARMA3 alone

35+ years as an IT tech who can do board level repairs and know the formulas (and education) behind these repairs (e=ir, p=ie, 1/r1 + 1/r2 + 1/r3 + etc.)

45 years of programming

I would say that I am more than qualified to make my assessments.  Am I 100% correct all the time?  No.  I do have, and use, a wealth of knowledge, experience and actual education to support my claims, that most do not have at their disposal.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.