Spawning in grass

8 posts in this topic

Hi, i have made an Exile server but when i spawn i just end up in grass then the view goes to the sky and i'm kicked. The database connects just fine as can be seen in the rpt logs, has anyone got a solution to this as it's rather frustrating! Below is my rpt log


Here is the database connection part:

23:58:54 "ExileServer - Installed extDB2 version: 70"
23:58:54 "ExileServer - Connected to database!"
23:58:54 "ExileServer - Database protocol initialized!"



Share this post

Link to post
Share on other sites
extDB2: Found extdb-conf.ini
extDB2: Detected 8 Cores, Setting up 6 Worker Threads

[00:35:49:322417 +00:-1] [Thread 4728] extDB2: Database Type: MySQL
[00:35:49:333479 +00:-1] [Thread 4728] extDB2: Database Session Pool Started
[00:35:49:334409 +00:-1] [Thread 4728] extDB2: SQL_CUSTOM_V2: Loading Template Filename: C:\Arma\Server\@exileserver\extDB\sql_custom_v2\exile.ini
[00:35:49:334506 +00:-1] [Thread 4728] extDB2: SQL_CUSTOM_V2: Version 12 Detected, Latest Version 12 Available

EXTB log

Edited by jedifer

Share this post

Link to post
Share on other sites



I have had this too.  In my case, and I think you will find it too, you have made a 'severe boo-boo'.


In my two cases:

1 - DB config error

2 - A real stupid one, I left out one of the two required folders for the server...duh...



Do this:


Ensure all files/folders are present

Remove/Do not use any mods on server

Then test with a DEFAULT EXILE SETUP


If it still fails, you can try installing these SAME files onto you PC and creating server there (local) and testing.   You will have to download MySQL though.


Bottom line, there are many things (notice - plural) that can cause this error, you just need to find out 'which one'.


Good luck!



Share this post

Link to post
Share on other sites

I'm using vanilla exile from here: 

Added everything that needed adding as far as i know....@exileServer, the tbbmalloc.dll, the @exile folder.

Could you be more specific about the DB issue and folders. This is what i have in the root server folder:


I have gone over the database about 10 times now to ensure there are no errors in that, installed, reinstalled, but i still spawn in the grass :(

Share this post

Link to post
Share on other sites

Well, as I stated, there could be MANY reasons, I just listed two that I am aware of.  The DB issue is a 'big' one from a lot of people that I have seen.


Also, because you can 'see' yourself in the DB, does NOT equate to 'exile can work with/use it'.

As an example, did you 'setup' the DB with the CORRECT DB script or an older one/the upgrade one?  If you used an OLD DB setup script, you can expect issues.

Also, you need to disable the 'strict mode' in the  MySQL program config too.  Otherwise, it will NOT WORK.  You should also check/verify the MySQL settings in that file anyway.  One wrong setting and bam!  No go for you.  But, this is but another reason it will not work.


Two starting points for the 'strict mode':"disable+strict+mode"




In my 'second problem', I forgot to copy over one of the exile server folders.  This occurred when updating to a new version.  Yes, I was a putz and I know better, but mistakes can and will happen.


Regardless, and I am not an 'expert', I would wager it is a config issue and/or a missing file/folder somewhere.  Start with a DEFAULT install.  If you have to 'start over', so be it.  Make a back-up FIRST of everything before starting.


You could also install on a local PC.  This would make testing/fixing a lot easier too.  Once fixed, copy those files to the 'real' server.  If you do this, WATCH OUT FOR ALL IP ADDRESSES!

Your home PC IP <> Server's IP - You will have to change them in the config files!


The two servers I have setup for others, this is exactly what I did, so when I copied the files from my personal server to the 'real' server - it worked as designed, 'out-of-the-box'.  No taking the server up and down, while pissing off and running off players.  I would suggest you do this also for any changes you make to your server.  Again, no down time and works right away.  Install/test/configure on your local PC, then copy those changes to server.  Quick, simple, and effective.  ;)



Also, if you search the forums, this question has come up before and you might find some extra help/tips there too!




Share this post

Link to post
Share on other sites

Strict mode is disabled :) 

The SQL is from September 2016, the newest version i assume. There were 3 upgrade files in there with much earlier dates so they were not used for obvious reasons.

 Im using a dedicated server, i have other games running on it so it's not a problem to use it to set up an Exile, i just put a password on it to prevent people from joining. I'll probably just reinstall the lot tomorrow to be honest, but i can't see myself missing any files as im fairly meticulous when it comes to stuff like this, clearly there is something wrong, a few people have posted on these forums but none have come back to say whether or not they fixed it or how to do so.

 Im almost certain it's nothing to do with the database, i have set up dozens in the past with no issues, i can't see why this one would be any different..but as you say, we all make mistakes, so i'll try again tomorrow and update when and if i find the reason for the grass spawn.

 Thanks for the advice, i will bare it in mind and double check :)

Share this post

Link to post
Share on other sites

Well, MY two 'mistakes' are two of the many possible.


As an example, let say you have a laptop and you turn it on, the screen is black.


So, the problem is defined as:  Black Screen

Possible Causes:

bad sys brd

bad back light

bad lcd

bad internal pwr supply

bad battery

dead battery

ac adpt not plugged into laptop

ac adpt not plugged into pwr strip

pwr strip not turned on

pwer stip not plugged into wall

wall outlet bad

breaker/fuse for outlet tripped/blown

master breaker/fuse tripped/blown

area has no ac


And a few more too.


See?  All these items create the same issue: a black screen.


The same goes here too.  There are MANY things that can cause this.  The most common is an issue with your DB.   As a silly example in regards to you seeing the 'account table'.  Does opening a door on a car mean that the car will start?  Nope!  It just means you can open the doors and nothing more.  Same here, seeing the account table does not mean exile can use the ENTIRE DB, just a PORTION of it.


All I can do is mentioned what happened to me and that is about it sadly.  Remember what happened to me, I had missing server files (entire folder) and had the SAME THING HAPPEN TO ME, and it was NOT A DB ISSUE;)



Do check you server logs and it would not hurt to view the DB logs too.  They, at times, can point you in the right direction!




  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.