Sign in to follow this  

FuMS + A3 Tasks Overhaul + Exile = No 3d Map Markers?

2 posts in this topic

I've been editing FuMS to try and make the thing utilise the 3d map markers from the Arma 3 Tasks Overhaul.

It's easy enough to get the tasks to create, and do all that kind of stuff.
But the little 3D floating skull icon just will not display in game, I'm wondering if this is something that has been disabled in Exile? Is there a way to re-enable it?

Basically this is the pvar eh i wrote up. as you can see i've tried to use the  BIS_fnc_taskSetAlwaysVisible feature to force it, but as yet, no luck!

"FuMS_TaskCreation" addPublicVariableEventHandler {
	_data = 			_this select 1;	
	_messageTitle = 	_data select 0;
	_message = 		_data select 1;
	_taskType = 		_data select 2; 
	_eCenter = 		_data select 3;
	_taskState = 		_data select 4;
	_taskID = format ["Task_%1",_messageTitle];
	diag_log format ["FuMS ||| TASK CREATE ARRAY MSG RECEIVED : %1",_data];
	if (_taskState isEqualTo "CREATED") then {
		[independent,[_taskID],[_message,_messageTitle,_taskType],_eCenter,"CREATED",2,true] call BIS_fnc_taskCreate;
		[_taskID,"Kill"] call BIS_Fnc_taskSetType;
		[_taskID, true] call BIS_fnc_taskSetAlwaysVisible;
	} else {
		_null = [_taskID, _taskState] spawn BIS_fnc_taskSetState;
		[_taskID, false] call BIS_fnc_taskSetAlwaysVisible;

So it works, mostly...

Task Creation: Check

Task displays on Map: Check - select Assign....

GODDAMN IT. NO 3D SKULL ICON. :( Ideally I'd like to implement this so players can assign the task on the map and it will create a marker for them.
Anyone of you fine chaps or chapettes able to point me in the right direction to fixing this?


Share this post

Link to post
Share on other sites

update: seems like it's an issue related to difficulty settings,
when i changed the difficulty to regular on my test box it worked, when i switched to veteran it didnt work.
and both exile regular and exile hardcore disable it.

I'm not sure which setting this falls under, commands, waypoints.
bis wiki documentation unclear. dick stuck in ceiling fan tbh.

But if you're ever working with tasks and cant get the icons to display. its related to difficulty.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.