Sign in to follow this  
Followers 0
Teacher

Messages about the restart!

9 posts in this topic

Hi Chris! Decided to use the restart function, the server goes down with a Bang, all right, but messages do not appear and the signal "Alarm" not hear what I did wrong?

Spoiler

/* show time left to next restart */
USE_RESTART_TIMER = "true";

USE_RESTART_TIMES_ARRAY = "true";
/* if USE_RESTART_TIMES_ARRAY = "true"; -> {hour,minute} .. put in the times when your server restarts (server real world time) */
RESTART_TIMES[] =
{
    {00,00},
    {04,00},
    {08,00},
    {12,00},
    {16,00},
    {20,00}
};

/* if USE_RESTART_TIMES_ARRAY = "false"; -> restart time in minutes (default: 180min == 3 hours) */
RESTART_TIME_IN_M = 240;
TIME_FUNCTION_USED = "diag_tickTime";    // diag_tickTime (starts with arma3server.exe), time (starts with mpmission init)
SHOW_RESTART_TIMER = "true"; // shows a restart timer on "escape menu" and "gear menu"

/* show restart announcement message x min before restart -> SERVER RESTART IN: X MINS  |  (calculated from RESTART_TIMES[])*/
RESTART_ANNOUNCE_X_MIN[] = {1,3,5,10,30};

/* SERVER_END_FUNCTION -> #shutdown or #restartserver */
SERVER_END_FUNCTION = "#shutdown";
USE_RESTART_TIMER_SHUTDOWN = "true";
RESTART_WARNING_SOUND = "Alarm";    // for example: Alarm or air_raid

 

Edited by Teacher

Share this post


Link to post
Share on other sites

Ya I noticed it wasnt work a few versions ago but forgot to say something

Share this post


Link to post
Share on other sites
Advertisement

Oh, I must have an issue within the calculation of real time then. I will check that again

Share this post


Link to post
Share on other sites

The timer that shows up when esc is pressed seems to start countdown from when the player logs into the server not when the server starts.

Share this post


Link to post
Share on other sites
3 hours ago, Razor77 said:

The timer that shows up when esc is pressed seems to start countdown from when the player logs into the server not when the server starts.

So I even press Esc and the timer does not appear:(

Share this post


Link to post
Share on other sites
Spoiler

RESTART_TIME_IN_M = 240;
TIME_FUNCTION_USED = "diag_tickTime";    // diag_tickTime (starts with arma3server.exe), time (starts with mpmission init)
SHOW_RESTART_TIMER = "true"; // shows a restart timer on "escape menu" and "gear menu"

It shows top of screen when esc is pressed, but mine is starting at 4 hours from when the player logs in not when the server starts.  Im guessing I have a setting wrong somewhere :)

Share this post


Link to post
Share on other sites

think I have found my error now didnt have the the array set to restart times 4am,8am etc had it set to 240 minutes

Share this post


Link to post
Share on other sites

I do not display the time until a restart of the server, and fuck is it necessary? In the status bar, and so it is time to restart! But the message is an ambush!:( In General, I will or we will wait for the hotfix:rock:

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.