Tobias Solem

Real time restarts not working properly

16 posts in this topic

Description of issue:

So, I have realtime restarts in infiSTAR setup, to restart every three hours, like so:

 

USE_RESTART_TIMER = "true";

USE_RESTART_TIMES_ARRAY = "true";

and then the array:

RESTART_TIMES[] =
{
	{00,00},
	{03,00},
	{06,00},
	{09,00},
	{12,00},
	{15,00},
	{18,00},
	{21,00}
};

Now, for whatever reason, every hour, like at 59 minutes... ALL of the pre-restart warning messages (including the sound) all drop all at once.

It actually only restarts at the right times, however, it's just the warnings that are weird that way.

Share this post


Link to post
Share on other sites
Advertisement

SHOW_RESTART_TIMER = "changeme"; // shows a restart timer on "escape menu" and "gear menu"  

this is set to true

USE_RESTART_TIMER_SHUTDOWN = "changeme";

is this set to true or false

Share this post


Link to post
Share on other sites
36 minutes ago, hogansheroes said:

SHOW_RESTART_TIMER = "changeme"; // shows a restart timer on "escape menu" and "gear menu"  

this is set to true

USE_RESTART_TIMER_SHUTDOWN = "changeme";

is this set to true or false

Thank you for your thoughts, but this solution is not related to my issue. :)

Share this post


Link to post
Share on other sites

Hello Tobias Solem,

Well, I had a similar issue, mine just would not restart.  What I did to solve this and would be a 'work-around' for you, is to use BEC.

Yeah, a pain, BUT, it does work and works every time.

 

This would be a solution to your issue.  Yes, I know you would rather have it 'within exile' as I would too.  But sometimes...you gots to do what you gots to do... ;)

:)

 

Share this post


Link to post
Share on other sites
1 hour ago, Z80CPU said:

Hello Tobias Solem,

Well, I had a similar issue, mine just would not restart.  What I did to solve this and would be a 'work-around' for you, is to use BEC.

Yeah, a pain, BUT, it does work and works every time.

 

This would be a solution to your issue.  Yes, I know you would rather have it 'within exile' as I would too.  But sometimes...you gots to do what you gots to do... ;)

:)

 

 

The problem isn't that it doesn't restart. The problem is that it warns every hour on the hour that it will restart in 15,10,5,2 minutes (all at once), and restarts when it's supposed to.

Share this post


Link to post
Share on other sites

Oh, I know that.  Using BEC, you can use it to 'inject' these messages.  I use it for the restart and the messages which is what you need.

It 'pushes' the messages via 'chat', so there would be no 'toast messages' that I am aware of.  It sends the messages via RCon.

It is just an idea!

:)

 

Share this post


Link to post
Share on other sites

Its restarting the server at the correct time for me 4, 8 and 12 o clock but the messages are happening around 45 minutes early.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.